Monkey 1 Ultimate Talkie Edition (released)

All the inane chatter goes in here. If you're curious about whether we will support a game, post HERE not in General Discussion :)

Moderator: ScummVM Team

Post Reply
ILikeThoseOldGames
Posts: 23
Joined: Mon Aug 30, 2010 6:00 pm
Location: Germany

Post by ILikeThoseOldGames » Tue Mar 20, 2012 4:46 pm

Sounds good. Do you think, it could be possible to support the iOS version too?

OmerMor
Got a warning
Posts: 147
Joined: Thu Nov 17, 2005 9:29 pm
Location: Israel
Contact:

Post by OmerMor » Thu Mar 22, 2012 9:11 pm

I failed to run the ultimate edition with the embedded mt-32 emulator.
Any idea why?
Did others manage where I failed?

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Thu Mar 22, 2012 9:26 pm

I have been using the SE digital music not the MT32 music. Did you try that?

OmerMor
Got a warning
Posts: 147
Joined: Thu Nov 17, 2005 9:29 pm
Location: Israel
Contact:

Post by OmerMor » Fri Mar 23, 2012 9:10 am

The digital soundtracks are working fine (both se and original), but I also wanted to try it with the MT-32 tracks it was supposed to support.
When I don't set an extra path to the digital soundtrack folder, it plays midi soundtrack but it's definitely not the MT-32 emulator, even though this is was I chose in the settings. I can tell because there is no MT-32 initialization pop-up when I run the game.

User avatar
md5
ScummVM Developer
Posts: 2258
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Fri Mar 23, 2012 11:15 am

OmerMor wrote:The digital soundtracks are working fine (both se and original), but I also wanted to try it with the MT-32 tracks it was supposed to support.
When I don't set an extra path to the digital soundtrack folder, it plays midi soundtrack but it's definitely not the MT-32 emulator, even though this is was I chose in the settings. I can tell because there is no MT-32 initialization pop-up when I run the game.
The new MT-32 emulator has a much faster initialization time, so you don't really see the initialization dialog anymore

CheeseMeister
Posts: 13
Joined: Tue Apr 24, 2012 9:10 pm

Post by CheeseMeister » Tue Apr 24, 2012 9:23 pm

As far as I can tell, the MT-32 (either an emulator or a real one) is not supported in the ScummVM version. However the DOS version can played with MT-32 by running the game with the command "monkey r1".

This is a shame for two reasons:

a) I would like to be able to use the MT-32 (I am using a real one, connected via USB, but many will want to use an emulator) in the ScummVM version, just because I'm an obsessive completist like that.

b) The installer for the DOS version does not copy any of the music OR ambient sound tracks (waves crashing onto shore, the ticking of the clock tower etc).

This makes me feel like neither is complete. I would LOVE it if I could play with a real (or emulated) MT-32 alongside the ambient sound effects, either in ScummVM or DOS. As long as there was one version that's perfect. I create launchers for DOSBox, so using that is not a bother to me.

LogicDeLuxe, you've already done so much - but is either of these things possible?

Apologies if you've already been asked this.

User avatar
LogicDeLuxe
Posts: 392
Joined: Thu Nov 10, 2005 9:54 pm

Post by LogicDeLuxe » Sat Apr 28, 2012 1:16 pm

It's all in this patch: http://sourceforge.net/tracker/index.ph ... tid=418822
It seems, the native MIDI attribute did not make it to the official release for some reason.

The DOS version is not able to play any of the ambient tracks. The DOS SCUMM V5 executable which can, does not support talkie versions, unfortunately.

CheeseMeister
Posts: 13
Joined: Tue Apr 24, 2012 9:10 pm

Post by CheeseMeister » Sun Apr 29, 2012 12:38 pm

Thanks for posting that. I can't wait to try it out but - I don't know if I'm just being dense. I've been trying for the last 24 hours and I have no idea how to install this patch. I've put it in the 'patches' sub directory but that doesn't seem to work. I've googled it, searched the readme, searched this forum - and I can't find any instructions. Can anyone tell how to install a patch into ScummVM?

Rasi
Posts: 23
Joined: Tue Jan 10, 2006 11:23 am

How to use on linux?

Post by Rasi » Fri Jun 15, 2012 4:46 pm

I am trying the whole day to get this to work on linux but i fail.
wine cmd shows extracting of lots of wav files, but in the end no wav file is written it seems.

Code: Select all

  1869144     PCM  44100 2 16 NAR_36_mansion-ext_11_1.wav
  6076580     PCM  44100 2 16 NAR_14_sh-galley_39_1.wav
  172782      PCM  44100 1 16 GUY_59_stans_75_3.wav
  104442      PCM  44100 1 16 GUY_38_lookout_3_49.wav
  98592       PCM  44100 1 16 GUY_38_lookout_3_50.wav

- finished (4551 files)

converting to wav
fixme:cmd:WCMD_for /F needs to handle options
Syntax error
File not found.

File not found.

fixme:heap:HeapSetInformation (nil) 1 (nil) 0
Converting %i to %~ni.wav failed with error ERROR_FILE_NOT_FOUND (The system cannot find the file specified)

cleaning up.
fixme:cmd:WCMD_for /R needs to handle supplied root
Syntax error
File not found.

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Fri Jun 15, 2012 10:26 pm

I think maybe the bat files need to be rewritten as shell scripts.
The problem seems to be in the bat handling in wine not the execution of exes.

I sort of gave up back then and ran the conversionin XP. It is a one time conversion anyway then you can get the data files and run them in Linux.

It would be nice if windows is not needed at all and I think that was fingolfin's goal as well.

Rasi
Posts: 23
Joined: Tue Jan 10, 2006 11:23 am

Post by Rasi » Sat Jun 16, 2012 8:39 am

I tried in in a Vbox WinXP now.

sadly build_monster.exe crashes with no useful error message :/
But it seems that the sog file was created anyway.

Sandy
Posts: 1
Joined: Sat Jan 05, 2013 3:01 pm

Post by Sandy » Sat Jan 05, 2013 3:06 pm

Sorry I realise this thread has been quiet a while just wondered if anyone knew what might be going wrong for me:

I run the install_flac.bat and it runs through very quickly with what seems like quite a few errors and nothing is produced at the end. Here is the first part:

Code: Select all

-----------------------------------------------------------------
- The Secret of Monkey Island - Ultimate Talkie Edition Builder -
-----------------------------------------------------------------
version 1.0
(running in flac mode)

Access is denied.
Access is denied.
This patch will take about 15-30 minutes, depending on your hardware.
Please be patient while I'm busy.


extracting samples.
Access is denied.

XWB/ZWB files unpacker 0.3.2
by Luigi Auriemma
e-mail: aluigi@autistici.org
web:    aluigi.org

- open file         ..\..\audio\SFXNew.xwb
- the tool will try to add a header to the extracted files
- change directory  samples

Error: No such file or directory

XWB/ZWB files unpacker 0.3.2
by Luigi Auriemma
e-mail: aluigi@autistici.org
web:    aluigi.org

- open file         ..\..\audio\Speech.xwb
- the tool will try to add a header to the extracted files
- change directory  samples

Error: No such file or directory
converting to wav

cleaning up.
Access is denied.

mixing special case samples.

cleaning up.
Could Not Find C:\Program Files (x86)\Secret Of Monkey Island SE\MI1_Ultimate_Ta
lkie_Edition_Builder\tools\temp.wav
Could Not Find C:\Program Files (x86)\Secret Of Monkey Island SE\MI1_Ultimate_Ta
lkie_Edition_Builder\tools\TRL_57_bridge_16_2.wav
The system cannot find the file specified.
Could Not Find C:\Program Files (x86)\Secret Of Monkey Island SE\MI1_Ultimate_Ta
lkie_Edition_Builder\tools\GUY_20_main-beach_71_3.wav
The system cannot find the file specified.
The system cannot find the file specified.

extracting classic resources
Extracting monkey1.000...
Extracting monkey1.001...

patching scripts
Press any key to continue . . .
Press any key to continue . . .
Seems like its not being able to find or access the files it needs, which is odd as they are there I have checked the SE version of the game works no problems. I am running windows 7 on this PC I have full admin rights etc. Tried looking around the web but couldnt find any suggetions as to what might be wrong.

Any help is much appreciated folks!

Cheers
Sandy

User avatar
raina
Posts: 231
Joined: Thu Jan 12, 2006 12:31 pm
Location: Oulu, Finland
Contact:

Post by raina » Mon Jan 07, 2013 9:16 am

Sandy wrote:Seems like its not being able to find or access the files it needs, which is odd as they are there I have checked the SE version of the game works no problems. I am running windows 7 on this PC I have full admin rights etc. Tried looking around the web but couldnt find any suggetions as to what might be wrong.

Any help is much appreciated folks!

Cheers
Sandy
It looks like you're getting multiple access denied messages and files not being found under the Program Files hierarchy.

Unless you lower Windows 7's security settings on purpose (I think), Program Files is protected by the system. By default you're still running normal apps as a normal user, even if you can use Administrator power when specifically required. To let applications modify protected files, they have to be started as an Administrator (from the context menu). Otherwise they'll fail at writing to protected locations, or if they're aware of the environment, they can raise that modal popup dimming the rest of the desktop and making you confirm the writes.

The installer is a command script, run by the Command Prompt app which is one of those apps that just fails at those writes if not run as administrator. So first it can't create the temporary .wav files and later it can't find them for obvious reasons. It should work, if you copy the files into another, non-protected location and run the installer there OR right click on the installer and choose to run it as administrator.

CaptainJei
Posts: 195
Joined: Wed Jun 15, 2011 3:57 am

Post by CaptainJei » Thu Feb 21, 2013 8:57 pm

I just want to say thanks to everyone involved in making this happen, on ScummVM or otherwise. Awesome work.

User avatar
xadox
Posts: 27
Joined: Thu Jan 25, 2007 9:24 pm
Location: GERMANY

Post by xadox » Fri Jun 14, 2013 8:51 am

Realy great work. Big Thx.

Post Reply