Controls used in ScummVM for Symbian devices

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu Oct 21, 2010 8:08 am

Can't you use the volume control in the options menu?`Or you also need the global volume?

User avatar
Mataku
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku » Fri Oct 29, 2010 2:07 pm

sure we CAN, but we had such an easy shortcut, why take it away? also, fyi, checking "mute all" doesn't actually mute anything, at least not for me.

Sokolas
Posts: 1
Joined: Tue Nov 30, 2010 11:39 am

Post by Sokolas » Tue Nov 30, 2010 11:46 am

I've got a problem on my Nokia 5230. The edges of the touchscreen don't react to taps and I can't move the cursor to the edge of the screen (to invoke inventory in Beneath a Steel Sky, for example) without using CUR mode. Is there any way to move the game screen or make some borders around it?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Nov 30, 2010 6:38 pm

Well you can use the mou mode, intead of cursor mode, but I guess you would like to be able to tap at the edge and that is not possible right now.

sunboy
Posts: 2
Joined: Tue Dec 21, 2010 10:46 am
Location: Latvia
Contact:

Post by sunboy » Tue Dec 21, 2010 10:52 am

how can i map F8 and F10 keys in Scumm?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Dec 22, 2010 10:31 am

That depends on your phone.
But they are accesible by enabling FN mode.
Green+'1'+Green will toggle between numeric or FN keys on the numpad (0-9 for F1-F10).
On touch devices extend the vkb, and tap FNC directly for enabling F1-F10 keys.

sunboy
Posts: 2
Joined: Tue Dec 21, 2010 10:46 am
Location: Latvia
Contact:

Post by sunboy » Wed Dec 22, 2010 2:35 pm

I have Nokia 6120.

hippy dave
Posts: 127
Joined: Mon May 05, 2008 3:37 pm

Post by hippy dave » Fri Oct 21, 2011 1:21 pm

ok i haven't quite figured out the finer details of the mousebutton modes, i'm on a s60v5. i managed to play my way through loom, but for other games i should probably know when i'm left-clicking or right-clicking :)

so i understand the
*_ for left click,
_* for right click and
__ for just moving the cursor, with seperate LFT & RGT on the popup controls

but i don't know exactly what the <> does, can you explain?

also, long ago, this guy requested a way to map the phone's physical volume keys as left/right mousebuttons, i think that would be very convenient if it's doable.

any other tips for getting the controls set up in the most convenient way?

cheers!

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Mon Oct 24, 2011 8:38 am

The <> is a toggeling left right mode. I.e first click is left, next is right, next is left etc.

Should be good for some games where for example right opens a menu and left selects in it.

hippy dave
Posts: 127
Joined: Mon May 05, 2008 3:37 pm

Post by hippy dave » Mon Oct 24, 2011 12:13 pm

oh ok, thanks.

tucors
Posts: 2
Joined: Thu Nov 03, 2011 2:04 pm

Post by tucors » Thu Nov 03, 2011 2:08 pm

i've changed the scummvm.ini file in my N97 after installing Scummvm and now the application won't start... I'm just trying to map keys, but now even if I undo the modifications in the file, Scummvm doesn't work anymore...

is there any wrong or right way to modify the config files?

edit: I just wanna play Lands of Lore, and just need the right mouse click to play properly.....scummvm will work only if I reinstall...and then the scummvm.ini will be default...

User avatar
tsoliman
ScummVM Developer
Posts: 403
Joined: Wed Jan 19, 2011 3:47 pm
Location: USA

Post by tsoliman » Thu Nov 03, 2011 3:56 pm

If you can edit scummvm.ini, I am assuming you can copy it to somewhere outside the device. If so, then after scummvm fails to start, copy the scummvm.ini outside the device and compare it with the "default" one using some sort of diff tool (e.g. kdiff3)
This will hopefully shed some light on what is going on.

tucors
Posts: 2
Joined: Thu Nov 03, 2011 2:04 pm

Post by tucors » Thu Nov 03, 2011 8:33 pm

thanks tsoliman, but i made a backup of the file before messing it, I copied and renamed it to scummvm.ini.old, so I'm sure it's not messed.

Then when I tested and it didn't work i just deleted the modified file and renamed the original to scummvm.ini again. But ScummVM still wont work....so im guessing the way I moved or saved the files may have messed it, maybe the codification (ANSI, UTF-8), maybe the way win7 is communicating with my N97...i dunno.

Its strange, because in version 1.3 i did it and it worked fine, but there were no Lands of Lore support.

PS.: I'm using this new build made in 18/oct/2011

Post Reply