SVN Build updated

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Mon Jan 31, 2011 1:35 pm

And now some these issues should be fixed. Still same link.

User avatar
Mataku
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku » Thu Feb 03, 2011 2:49 pm

does the newest build have the toonstruck engine in it?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Fri Feb 04, 2011 10:53 am

Yes its a very much ALL engines build :-D

User avatar
Mataku
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku » Fri Feb 11, 2011 1:29 am

yea toonstruck crashes on me on 5800 when trying to leave the first room. =\
this app is starting to grow a bit out of that phone's range... at game time it takes over 55mb of ram.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3303
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Fri Feb 11, 2011 5:25 am

Mataku wrote:yea toonstruck crashes on me on 5800 when trying to leave the first room. =\
this app is starting to grow a bit out of that phone's range... at game time it takes over 55mb of ram.
I fixed (I hope) a memory leak a couple of minues ago that caused PAK files to not be unloaded. That should keep the ScummVM process from growing - or at least from growing as quickly as before - but it might not help you because it's still preloading quite a bit of data. For instance, it seems to want to keep the entire DREW.PAK in memory, which is 20 MB right there. I'm not really familiar with this game engine, so I have no idea if that can be easily changed.

spazomataz
Posts: 2
Joined: Thu Mar 10, 2011 5:56 am

Post by spazomataz » Mon Oct 17, 2011 12:52 am

Could we get an up to date svn version please? it's been a while and the fan patch for talkie monkey islands was included

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Oct 18, 2011 7:41 am

New build here.. or well it is one week old.. but not too bad.

http://anotherguest.se/cvsbuilds/scummv ... v3_all.sis

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Oct 18, 2011 7:53 am

Todays update here

http://www.anotherguest.se/cvsbuilds/sc ... v3_all.sis

SCI, TSAGE etc updates.

hippy dave
Posts: 127
Joined: Mon May 05, 2008 3:37 pm

Post by hippy dave » Fri Oct 21, 2011 11:54 am

thanks!

hippy dave
Posts: 127
Joined: Mon May 05, 2008 3:37 pm

Post by hippy dave » Mon Oct 24, 2011 1:34 pm

in case anyone's interested, i've been trying out the unofficial monkey island 1 "ultimate talkie edition" (rc4) with this new build - first i tried it with ogg speech & music, it kinda worked but crashed a lot, maybe decoding speech and music at the same time was too much. tried again with uncompressed speech (that version just uses synth music i think) and seems to be much more stable, no crashes as yet.

edit: uncompressed speech + ogg music seems stable, so far.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu Feb 02, 2012 7:53 am

1.4.1 is now up on the download page, but the download says sis file, it is actually a zip file containing two sis files, one full sis file and one with split engines.

Tested on N95 8Gb (full) and N73 (split)

hippy dave
Posts: 127
Joined: Mon May 05, 2008 3:37 pm

Post by hippy dave » Thu Feb 02, 2012 2:26 pm

brilliant, thanks :) - the mouse buttons mapped to the volume keys seem to be working fine, and will make playing a lot of games much easier.
the direct link on the download page doesn't work, like you say it's pointing to a sis file which doesn't exist, so you then have to go into the scummvm folder and find the zip file at the top

Praetorian
Posts: 34
Joined: Tue May 08, 2007 8:54 am

Post by Praetorian » Wed Feb 08, 2012 6:49 am

Many thanks Anotherguest!
I can confirm it works on Symbian^3 Belle at least for LOOM EGA that I've tried. It worked on Symbian Anna too. My phone is a C6-01.

Only issue I had, was that after installing Belle (yesterday) and reinstalling the full sis, the screen orientation was detected wrong always (it was the opposite of the right thing for the screen orientation). But, this was fixed by uninstalling ScummVM and reinstalling it.

Also, the default settings for the audio, cause some sound crackling (?) when bass is played (a few seconds in the main theme at the LOOM EGA intro). I had to override them the default audio settings for the game. Setting Music Device to Adlib Emulator DosBox OPL emulator and output rate to 44 Khz seems to fix it.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Feb 08, 2012 10:00 am

Usually all Nokia devices has no problem with any of 8khz-44khz audio, but perhaps some of the newer dont like the lower sample rates. Nice to hear that it works.

Post Reply