SCI (LSL6) control issues on Wiz

Subforum for discussion and help with ScummVM's GP2X, GP2X Wiz and Caanoo ports

Moderator: ScummVM Team

Post Reply
derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

SCI (LSL6) control issues on Wiz

Post by derboo » Thu Sep 02, 2010 4:48 pm

I don't know if this applies for all SCI games, but I'm experiencing problems with the controls in Leisure Suit Larry 6 with the lates build (1.2.0svn52440). Each time I click on a spot on the touchscreen, the cursor will go to that place, but the selected action is executed to the spot where it was before the clicking.

Also, SCI games seem to run a lot slower than anything else so far (LSL6 stutters even at 700MHz, while everything else I tested runs fine with 533MHz). Don't know if that's an issue with the Wiz port, though, my PC might be just too fast for it to make a difference.

User avatar
DJWillis
ScummVM Porter
Posts: 174
Joined: Wed Oct 26, 2005 8:55 pm

Post by DJWillis » Thu Sep 02, 2010 6:18 pm

Thanks for the bug report, I'll look into it.

The SCI game performance is rather variable, it tends to vary on a game by game basis. I can't say I have tried LSL6, I'll try and track down and buy a copy.

derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

Post by derboo » Fri Sep 03, 2010 6:25 pm

I tested the rest of the Larry series now. I get the same pointer problem in LSL5 and LSL1VGA, but not LSL3.


Also most SCUMM engine games don't seem to work, anymore.

User avatar
m_kiewitz
ScummVM Developer
Posts: 156
Joined: Tue Dec 01, 2009 10:09 am
Location: Daventry

Re: SCI (LSL6) control issues on Wiz

Post by m_kiewitz » Fri Sep 03, 2010 7:47 pm

derboo wrote:(LSL6 stutters even at 700MHz, while everything else I tested runs fine with 533MHz).
If you are trying the hires SCI2.1 version, please try to get the SCI1.1 version instead.

derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

Post by derboo » Sat Sep 04, 2010 8:07 pm

No, it's the low res version to begin with, Larry 5 and 1VGA are also slow (with standard 533MHz), but not as bad as 6 (in 700MHz or probably even less they run fine).

derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

Post by derboo » Wed Sep 08, 2010 1:36 pm

I now set the music to Adlib and MAME OPL according to your blog post to be able to run the Scumm games, and as a nice side-effect, the music in LSL6 now runs perfectly fluid. The game itself runs still rather slow, though.

Post Reply