Error in compiling whith the new scheme (configure script)

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
mac_es
Posts: 104
Joined: Mon Oct 31, 2005 9:37 am

Error in compiling whith the new scheme (configure script)

Post by mac_es » Tue Oct 27, 2009 3:03 pm

Hello,

I'm trying to compile it. Some time ago I was able to compile it using the makefile, now when I had tried to compile it I saw that it failed.

As I have seen it has moved to the configure script for crosscompiling.

I have setted the CXXFLAGS and LDFLAGS correctly, indeed it compiled but when linking I get these errors:

Code: Select all

backends/platform/wince/wince-sdl.o:wince-sdl.cpp:(.text+0x24c4): undefined refe
rence to `Normal2xAspect(unsigned char const*, unsigned int, unsigned char*, uns
igned int, int, int)'
engines/saga/libsaga.a(sndres.o):/engines/saga/sndres.cpp:330: undefined reference to `Audio::loadShorten
FromStream(Common::ReadStream&, int&, int&, unsigned char&)'
collect2: ld returned 1 exit status
make: *** [scummvm.exe] Error 1
When compiling I see some warnings whith alignment warnings, also I have some warnings about invalid char '0x20' in some classes.

I'm compiling it using: Windows Vista SP2+MSYS+cegcc also I have tried cygwin...

As I have seen in buildbot configuration is the same as mine, and it result is ok. So anybody can assist me?

cheers

mac_es
Posts: 104
Joined: Mon Oct 31, 2005 9:37 am

Post by mac_es » Wed Oct 28, 2009 9:47 am

I cleared all the files and today is working... ¿?

Post Reply