[SOLVED] Sam & Max - Bumpusville Audio Problem

Subforum for discussion and help with ScummVM's Nintendo DS port

Moderator: ScummVM Team

Post Reply
User avatar
Morden
Posts: 149
Joined: Mon Nov 03, 2008 10:15 am
Contact:

[SOLVED] Sam & Max - Bumpusville Audio Problem

Post by Morden » Mon Nov 03, 2008 9:15 pm

When you get to Bumpusville, you can see Conroy perform a song in the room on the far right. The problem is, you can't hear Conroy sing. The announcer comes on, then Sam says "I hate floor shows" and throughout the duration of Conroy's song you can't hear a thing. Just as if the song file didn't load at all.

After Bumpus is done, sound gets back to normal again. I have transferred my DS saves to my N73 and tried them with the corresponding Symbian build [0.12] and everything worked fine there. You can hear Bumpus' song just fine.

A DS bug? I haven't found any other post reporting this. I'm not sure if it's a DS specific issue associated with limited memory, but I thought I'd let you guys know.
Last edited by Morden on Thu Aug 20, 2009 8:07 pm, edited 2 times in total.

Bowen747x
Posts: 47
Joined: Tue Aug 05, 2008 7:13 pm
Location: Ny

Post by Bowen747x » Mon Nov 03, 2008 11:43 pm

im pretty sure this has been discussed several times before, its a glitch.

User avatar
Morden
Posts: 149
Joined: Mon Nov 03, 2008 10:15 am
Contact:

Post by Morden » Tue Nov 04, 2008 12:46 am

Any links? And is this glitch present in all of the ScummVM DS builds? I'm curious if anyone of the port developers has commented on this. Is that something that can be fixed?

tomten
Posts: 139
Joined: Mon Oct 16, 2006 9:16 am

Post by tomten » Tue Nov 04, 2008 7:22 am

Morden wrote:Any links? And is this glitch present in all of the ScummVM DS builds? I'm curious if anyone of the port developers has commented on this. Is that something that can be fixed?
While your questions are many, the searches you performed are few:

viewtopic.php?t=5132&highlight=conroy

viewtopic.php?t=608&highlight=conroy

viewtopic.php?t=4842&highlight=conroy
Last edited by tomten on Tue Nov 04, 2008 7:37 am, edited 1 time in total.

User avatar
iPwnzorz
Posts: 301
Joined: Sat Jan 06, 2007 3:55 pm
Location: Hampshire, England

Post by iPwnzorz » Tue Nov 04, 2008 7:33 am

You're better off not hearing it anyway :P

User avatar
Morden
Posts: 149
Joined: Mon Nov 03, 2008 10:15 am
Contact:

Post by Morden » Tue Nov 04, 2008 9:25 am

Most people seem to think this issue is related to ScummVM not playing the audio tracks [and they often mean the bonus tracks that came with the first edition of the game].

I see that agentq put this on the "issues to fix" list, so maybe the next build will fix this? Hopefully it will. I know the song, since I played Sam & Max about a thousand times now :] I just kind of missed not being able to hear it this time. Worked fine on Symbian though.

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Tue Nov 18, 2008 1:15 pm

This has been on my list for a while. Eventually I will get around to looking at it, but since it's something that happens in one place in one game, it always slips down the list after all the major game-breaking bugs.

If you've got a save before this section it would really help me out.

User avatar
Morden
Posts: 149
Joined: Mon Nov 03, 2008 10:15 am
Contact:

Post by Morden » Sat Nov 22, 2008 11:58 am

I know it's a low priority bug and I figured that's exactly why it's still there. I'm sure that you have plenty to do as it is, keeping the build up to date.

It would be nice to hear Bumpus sing his crazy song though and if a savegame helps, a savegame is what you'll get.

Just click HERE to download a zipped save file. It's just outside Bumpus' stage room. Step in to the left and he'll perform. You can hear the announcer just fine, but when Bumpus starts to sing, his sound sample doesn't play.

User avatar
Morden
Posts: 149
Joined: Mon Nov 03, 2008 10:15 am
Contact:

Post by Morden » Thu Jul 09, 2009 1:19 pm

I just installed the latest build of ScummVM DS [0.13.1] and tested it with my old Bumpus save. The audio glitch is still there, after a full build number up. Was it forgotten, or is it really that low priority?

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Tue Jul 14, 2009 10:37 pm

Sorry, I haven't looked at that. Yet again, all my time was spent making the games all run without crashing. I may be able to take a look at it for the next version. If I do, your save game will be a big help, so thanks for that.

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Tue Aug 04, 2009 10:59 pm

Hi, I took a look at this issue today (at long last) and it appears that it works if your speech file is MP3 compressed.

I'm going to try to sort out a solution for the original audio files too, if I can.

agentq
ScummVM Porter
Posts: 806
Joined: Wed Dec 21, 2005 4:29 pm
Location: London, UK

Post by agentq » Mon Aug 17, 2009 10:36 pm

You'll be glad to hear that bumpusville audio now works pefectly! Download the new 1.0.0 beta 1 to test it.

Bowen747x
Posts: 47
Joined: Tue Aug 05, 2008 7:13 pm
Location: Ny

Post by Bowen747x » Tue Aug 18, 2009 9:06 am

interesting 8)

User avatar
Morden
Posts: 149
Joined: Mon Nov 03, 2008 10:15 am
Contact:

Post by Morden » Thu Aug 20, 2009 8:04 pm

Confirmed working. Loaded my save file, and hey! Bumpus is finally singing. If the details interest anyone, I'm using a R4 cartridge and Sam & Max: Hit the Road copied directly from the CD to the MicroSD.

I guess we can close this up. Thanks agentq, for finding the time to fix this. It was a minor bug, but a bug nonetheless.

Added "Solved" in the thread title.

Post Reply