no music in broken sword 2

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
MaGe159
Posts: 2
Joined: Thu Jul 23, 2009 11:40 pm

no music in broken sword 2

Post by MaGe159 » Fri Jul 24, 2009 12:44 am

I have an htc touch diamond 2 and scummvm 0.13.1
In broken sword 2 the speech plays fine but there is no music
The older versions of scummvm can play the music but in those versions the game freezes after a couple of minutes So either I choose freezing or no music. my scummvm.ini says:[sword2]
description=Broken Sword 2: The Smoking Mirror
output_rate=44100
speech_volume=192
talkspeed=60
reverse_stereo=1
music_mute=false
path=\Storage Card\Broken Sword 2 [comp]\
sfx_mute=false
gfx_details=3
landscape=2
gameid=sword2
object_labels=true
sfx_volume=192
music_volume=256
music_driver=towns
subtitles=false
speech_mute=false

User avatar
pncFreak
Posts: 146
Joined: Sun Nov 02, 2008 3:33 pm

Post by pncFreak » Fri Jul 24, 2009 7:59 am

Which file format are your music files?

MaGe159
Posts: 2
Joined: Thu Jul 23, 2009 11:40 pm

Post by MaGe159 » Fri Jul 24, 2009 12:09 pm

.clg same as speech

User avatar
pncFreak
Posts: 146
Joined: Sun Nov 02, 2008 3:33 pm

Post by pncFreak » Fri Jul 24, 2009 12:29 pm

If you set debugflag=3 --debugflags=music
in your .ini file I'm sure it would be more to go on for the devs when you post the stderr/out files on the bug tracker.

Alternatively you just set debugflag=1 and see what the output of that tells you.

You are sure that your music files are not corrupted? Have you tried copying them from your CD on to your storage card once more?

Search the forum for how the files should be organized/renamed for them to work with the latest version of scummVM.

Post Reply