Sam And Max Leave The Room

Subforum for discussion and help with ScummVM's Palm port

Moderator: ScummVM Team

Post Reply
kunarion
Posts: 3
Joined: Tue Jan 31, 2006 4:07 pm

Sam And Max Leave The Room

Post by kunarion » Tue Jan 31, 2006 4:50 pm

Hi!
I'm having trouble figuring out the controls in the game "Sam and Max Hit The Road" (the only Scumm compatible game I own), running on a Palm OS LifeDrive.

I'm trying to find out how to:
- Select "Walk" mode, after holding an item.
- Get a game menu on screen, if its in full-screen mode (no menu icon)

The documentation seems to apply to PCs with a keyboard. And if I were using a PC, I'd hit the "ESC" key to perform either of the above functions. I've read the FAQs and documentation, and tried some menu settings, with no luck. If someone would point me in the direction of a ScummVM Palm OS game control FAQ, I'd appreciate it. I can't even get Sam and Max to exit their office at the start of the game.

There are many things listed in the ScummVM readme file, such as "command line options" and "hot keys". If I'm NOT in "full-screen mode", I can pop up a game menu, but that's all. I tried the 5-way control, and it didn't do anything, Then I pushed the select button, and the game froze (music playing, no motion).

I'm in Landscape Mode, but have not run "Full-screen", since that eliminates the "menu" (the icon is hidden, so I can't tap it).

kunarion
Posts: 3
Joined: Tue Jan 31, 2006 4:07 pm

Post by kunarion » Wed Feb 01, 2006 4:34 pm

As it turns out, Full-screen mode works well! I selected "Wide (Hi-Res+)" and "Fullscreen" and "Low" audio quality. Now the animations match the voices rather closely. It runs smoothly at a decent speed, with no choppiness in the sounds.

The game only only locked up once, and the background music was still playing. It seems to freeze at random, but infrequently. This is a great improvement over the previous version!

Here's what I figured out so far:

To allow the characters to walk out a door:
First click the Inventory Box. Then select the icon for Max (and the view switches back to the main screen), then click the Inventory Box again. This places Max back into Inventory, and the cursor is in walk mode! Click the door to leave the room.
Is there a quicker way to do it?

In Fullscreen, the LifeDrive responds well to hardware key clicks. Press the "Home" key to leave Fullscreen and pop up the Menu icon. That's how to save/load/quit a game.

The 5-Way navigator moves the cursor around, and this allows you to slowly scan a room without "clicking" on any objects.

goetz
Posts: 111
Joined: Fri Dec 09, 2005 10:11 am

Re: Sam And Max Leave The Room

Post by goetz » Wed Feb 01, 2006 5:11 pm

Don't know if it is the same on LifeDrive, but on my Tungsten C the following things work:
kunarion wrote: - Select "Walk" mode, after holding an item.
On the PC version the right mouse button can be used to cycle through the different cursor actions. On the Tungsten C this is mapped to hardware button 4 ( usually memo app).
kunarion wrote: - Get a game menu on screen, if its in full-screen mode (no menu icon)
Strangely enough, this is mapped to hardware button 3 (to do) as well, probably because in full screen mode there is no menu key or graffiti area on some devices. :)

Maybe the hard buttons have a similar effect on your device.

HTH,

- Goetz

kunarion
Posts: 3
Joined: Tue Jan 31, 2006 4:07 pm

Post by kunarion » Wed Feb 01, 2006 5:55 pm

Thanks, goetz!
Since I could find no documentation about hard buttons, I hadn't fiddled with them. They usually just switch apps, which could cause problems. Those buttons had to be avoided in ScummVM Version 0.71.

Now I tried all the buttons, and here's what they do:

Home: Full/Compact Screen
Folder: Cycle Cursors
Photo: Skip Scene
Star: Game Menu
Landscape/Portrait Button: Horizontal/Vertical orientation
Voice Memo: (Nothing)
5-Way Navigator: Move the cursor.
Center Button: (Nothing)

While operating the Landscape button, the game screen went black, and the PDA stopped responding to inputs, with background music still playing. After running the game a dozen times (for 5-10 minutes each time), this crash has happened 3 times, and only when a button is pushed. I then must perform a soft reset.

BeeVee
Posts: 1
Joined: Fri May 18, 2007 7:22 pm

Post by BeeVee » Fri May 18, 2007 7:27 pm

Hi all,

And for the Palm Tungsten E2 the bottom right hard button, the Notepad one, is the switch between functions! Thanks for the hint kunarion. The audio quality is pretty poor on my Palm version - it breaks up a lot and I daren't have the music on as well, thanks heavens for the subtitles. Any advice on speeding up performance?

B

joeboy
Posts: 1
Joined: Sat Jul 26, 2008 9:33 am

Sam n Max Look for Frog Rock

Post by joeboy » Sat Jul 26, 2008 9:56 am

Hello,

I'm stuck and having trouble controlling the binoculars. It's plugged in and magnified so I'm wondering if the mouse emulation is the issue.

I'm use version 11 on a Treo 680. What settings should I use?

Regards,

Ben

Post Reply