Screen mode issues with 0.13.1

Subforum for discussion and help with ScummVM's GP2X, GP2X Wiz and Caanoo ports

Moderator: ScummVM Team

Post Reply
simonscumm
Posts: 10
Joined: Sun Mar 19, 2006 5:11 pm

Screen mode issues with 0.13.1

Post by simonscumm » Fri May 15, 2009 5:52 pm

Hi,

I've been using version 0.13.1 on my F100, which runs very well, with one small exception.

If I try to choose the screen mode as 1x (or anything else for that matter), the graphics seem ok for a while but if I use the right shoulder button to save or bring up the menu, the screen becomes distorted and stretched to fill (fast rendered).

If I leave it as the default the screen is sort of stretched but anti-aliased so not so bad.
But I prefer 1x because it's easier to read the text and the games seem to run a bit faster.

I was just wondering if anyone else has experienced the same or if they know how to sort it?
Perhaps it's just a bug?

User avatar
DJWillis
ScummVM Porter
Posts: 174
Joined: Wed Oct 26, 2005 8:55 pm

Post by DJWillis » Fri May 15, 2009 7:01 pm

Interesting, I'll check more later but I suspect the menu and ScummVM GUI is being rendered at 320*240 but the games are respecting the aspect ratio setting.

I'll be totally honest and say I did not test that side of things at length. If you can get more info I would appreciate it. Is it fairly solid for everything else?

simonscumm
Posts: 10
Joined: Sun Mar 19, 2006 5:11 pm

Post by simonscumm » Fri May 15, 2009 9:36 pm

DJWillis wrote:Interesting, I'll check more later but I suspect the menu and ScummVM GUI is being rendered at 320*240 but the games are respecting the aspect ratio setting.

I'll be totally honest and say I did not test that side of things at length. If you can get more info I would appreciate it. Is it fairly solid for everything else?
Yes, it's the best version so far, especially in terms of performance.
I'll try a fresh install to recreate my steps and report back :)

simonscumm
Posts: 10
Joined: Sun Mar 19, 2006 5:11 pm

Post by simonscumm » Mon May 18, 2009 7:39 am

Ok, just did a fresh install and launched FOTAQ.

By default the Aspect Ratio button is ticked in the global options.

I didn't adjust game specific options, I just launched the game.

The game launched and the screen was stretched to fill and anti-aliased.

I then quit, relaunched and this time edited the options specific to FOTAQ, I selected Overide global graphic settings and unchecked Aspect ratio correction.

This time when the game launched it was not stretching, the graphics were at actual size. All is good until I press the right shoulder button to load a game, then the screen stretches to fill (fast render, not anti-aliasing).
I then quit the game but as I quit for a second the screen goes back to actual size before finally quitting.

The same thing also applies if I try to use the 1x graphic option specific to the game.

So I then tried unticking the Overide global graphic settings specific to the game and altered the global settings from the main Options menu:
I tried unticking the Aspect Ratio correction and launched FOTAQ. It launched as before filling the screen and anti-aliasing. As I quit the game the screen still filled to stretch the graphics (did not return to actual size for a second.
Also on the next launch of Scummvm the main menus where now stretched to fill the screen and fast rendered (rough with no anti-aliasing).

So I now tried altering the global graphic options and set the graphics mode to 1x. The game launched and the graphics were still stretching fast rendered. I then quit. On the next launch the main menus were still stretched fast rendered.

I then quit and again altered the global graphic options and this time ticked Aspect ration correction (so this and 1x were set). This time it still stretched to fill only the graphics were anti-aliased. I then quit, upon the next launch the main menus were rendered actual size (no stretching).

I then tried ticking Aspect ration correction,1x and full screen; it still stretched to fill and the graphics were anti-aliased.

Finally I tried ticking 1x and full screen and it still stretched to fill and the graphics were anti-aliased.

Think that's all the combinations I could try, hope that made sense :)

simonscumm
Posts: 10
Joined: Sun Mar 19, 2006 5:11 pm

Post by simonscumm » Wed Oct 14, 2009 8:23 am

Happy to report that the latest version of scummvm (1.0.0rc1) has no problems with the screen mode.

For 1x size, under the graphics settings I have:

Graphics mode: 1x
Render mode: default
Aspect ratio correction: UNCHECKED
Fullscreen mode: UNCHECKED

Post Reply