Broken Sword 2 broken.

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

Post Reply
howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Broken Sword 2 broken.

Post by howl »

In Broken Sword 2 at the tree house, after the helichopper destroy the boat, right clicking the panties, makes the scummvm debbuger to appear. I have dumped the files from my original cd game.

User avatar
Raziel
ScummVM Porter
Posts: 1187
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Re: Broken Sword 2 broken.

Post by Raziel »

Have you read this?

Especially 3a!

howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Post by howl »

The problem is that i don't know if this is a bug or the game played natively crash in the same way.

User avatar
Kaminari
Posts: 274
Joined: Mon Oct 24, 2005 2:25 am
Location: Paris, France
Contact:

Post by Kaminari »

Common sense dictates that if the ScummVM debugger appears, the error message should be reported ASAP to the ScummVM bug tracker.

howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Post by howl »

Ok doing it.

Edit: Mmm i'm not going to try the svn version of scummvm that is said in the faq.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3334
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

howl wrote:Ok doing it.

Edit: Mmm i'm not going to try the svn version of scummvm that is said in the faq.
Without any indication of what error you get, there isn't much we can do about it, really. Did you try copying the data files from your CDs again? A surprising number of mysterious crashes have turned out to be damaged and/or truncated data files.

howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Post by howl »

ERROR: File::seek: File is not open!

The gamedata files are correct. I will try to see if is a game bug that happens also installed and runned without using scummvm.

User avatar
md5
ScummVM Developer
Posts: 2261
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

Can you give us a list of the files in your game's folder?

howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Post by howl »

All the files that appears in viewtopic.php?t=5384 plus clusters/vielogo.tga, the vielogo.tga is supposed to be unused by scummvm but i have it in both cd's of the game.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3334
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

howl wrote:ERROR: File::seek: File is not open!

The gamedata files are correct. I will try to see if is a game bug that happens also installed and runned without using scummvm.
I vaguely remember some music-related error like that when changing from the first to the second CD. But I thought/hoped that it was fixed long ago. Which version of ScummVM are you using?

howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Post by howl »

ScummVM version 0.11.1, in this case is not the music, is the description of the panties that Goerge says in a concrete part of the game.

Don't know when i could try to test this with the game played natively, don't have win or msdos, but, i have to ask one thing. I have read in the scumm wiki that there are programmed some workarounds for games that have bugs themselves, if this result in a broken sword bug, and not a scummvm bug, should i report in the scummvm bug database anyway?

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3334
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

howl wrote:ScummVM version 0.11.1,
The music bug I'm thinking of was fixed back in July, so it's possible that it was in 0.11.1. Does it still happen with 0.12.0?
howl wrote:in this case is not the music, is the description of the panties that Goerge says in a concrete part of the game.
You may be right, though I do believe that examining the panties is one of the things that always causes a certain piece of music to be played.
howl wrote: if this result in a broken sword bug, and not a scummvm bug, should i report in the scummvm bug database anyway?
The music bug was a bug in ScummVM, not the original.

howl
Posts: 24
Joined: Sun Nov 23, 2008 2:53 am

Post by howl »

Yes, it seems to be that, i have just tested with 0.12.0 debian etch package in ubuntu intrepid and now it works. Thanks.

Post Reply