scummvm is not a valid pocket pc application

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

scummvm is not a valid pocket pc application

Post by rab » Sun Jul 13, 2008 4:08 pm

I've just installed scummvm on my PPC and I'm getting this error. And yes, my PPC has is arm based.

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech » Sun Jul 13, 2008 4:42 pm

Which download did you take from the ScummVM website?

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Sun Jul 13, 2008 5:15 pm

Windows CE ARM package (scummvm-0.11.1-WinCE.zip)

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech » Sun Jul 13, 2008 6:15 pm

This one should normally run. I had it also on my PPC (Loox N560). What´s your device?

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Sun Jul 13, 2008 6:30 pm

HTC Hermes, Windows Mobile 6.1

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech » Sun Jul 13, 2008 9:09 pm

Normally the ScummVM WinCE version is compiled for WinCE 3.0 (PPC2000/PPC2002 compatible) and WM6 should be downward compatible. Do you know if other programs which have been originally written for PPC2000 or PPC2002 can start on your device?
Is there another error message shown for example that a DLL is unknown or missing?

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Sun Jul 13, 2008 9:42 pm

No idea if programs that old would run on 6.1, I wouldn't even know where to find something to test with. However, like you say, it should be able to.

I only get the error mentioned in a little dialog box, nothing more useful unfortunately.

I looked at recompiling it with visual studio, but the source distro no longer contains VS project files for the CE version. I didn't have time to look into the preferred compiler.

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech » Mon Jul 14, 2008 6:31 am

I just compiled an actual SVN plugin version with some changed compiler settings (compiled for ARMV5 architecture and WinCE 5.0). I don´t know if this will make a great difference and I could only test this with WM5 but perhaps it´s worth a try.
I uploaded everything as a ZIP archive on Rapidshare. If you prefer a CAB installation I can also upload the same binaries as CAB package.
Here is the download link.
But remember: this is not an official ScummVM build since I´m not an maintainer.

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Mon Jul 14, 2008 7:24 am

Thanks very much for your efforts, but I get the same error when running that on my device.

I tried it on the MS windows mobile emulator too (which is only running WM 6.0). It hangs the whole emulator when I run your version (but appears to run the official version fine). Very odd.

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Mon Jul 14, 2008 7:37 am

Done a little more testing and v9.1 & v10.0 work fine. Only v11.0 & v11.1 fail with the above error.

Is this around the time the compiler switched from Visual Studio to cegcc? Are you using the latest cegcc (just in case there are any fixes)?

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech » Mon Jul 14, 2008 7:47 am

Yes, I´m compiling with cegcc since there is no support for other compilers anymore.
It´s interesting that the the emulation with WM6 also fails because I tested with a WM5 device and a WM5 emulation so it seems that WM6 does generally not accept the cegcc binaries although they still run on WM5.
At the moment I cannot help you further since I have no clue what could be changed to get this working again.
Perhaps one of the devs has an idea.

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Mon Jul 14, 2008 8:16 am

Although the official 11.1 build did run on the WM 6.0 emulator, so it may just be WM 6.1 that's the problem.

It's unfortunate that visual studio support was removed, because that is always likely to work. Even going back to v9/10 (pre-cegcc) works on WM 6.1, so it sounds like cegcc is the real problem. I'll submit a bug.

User avatar
knakos
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Wed Jul 16, 2008 10:37 am

I have not heard of any WM6.1 incompatibilities reported. But it could be that eithe the OS loader drops applications on the floor when the executable header values for system, subsystem are lower than some value (meaning f.ex.: in WM6.1 only applications built for WM2003 and upwards are compatible). You could check this by changing the header to appropriate values and trying to run again. The same kind of error can occur when a critical system dll is missing (or one of its exports). Scummvm relies on a bare minimum of dlls which are known to exist on all wince versions.

The reasons for changing compilers are outlined in the wiki and I won't go into that matter here.

mac_es
Posts: 104
Joined: Mon Oct 31, 2005 9:37 am

Post by mac_es » Wed Jul 16, 2008 10:45 am

Hi,

I'm using scummvm (compiled by me whith cegcc)in my trinity WM6.1 whithout any error. I have provided him a version compiled by me (just in case...) and he gets the same error...

Only thing that I can think about is the build of WM6.1...
@rab

which ROM is in your hermes? Mine is 19213.1.0.4
Have yoy tried soft resetting the device?

rab
Posts: 8
Joined: Sun Jul 13, 2008 4:05 pm

Post by rab » Wed Jul 16, 2008 2:14 pm

I have CE 5.2.19588 (build 19212.1.0.0).

I've tried a soft reset (I must admit that didn't initially occur to me, only just tried that this morning), but that didn't fix it.

Starting to sound like this really is just me that has this issue. I posted on at xda-developers in the rom thread and other people who have the same rom as me are able to run it! I can't imagine anything else I have installed on it (sat nav & various medical apps) could be causing this.

Oh well, I just won't be able to play Monkey Island on the move, but I've survived so far without.

Post Reply