No sound at all [Fedora 8]

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
urlauber
Posts: 5
Joined: Wed Jan 16, 2008 10:24 am

No sound at all [Fedora 8]

Post by urlauber »

Hi there,

if I start scummvm via console it says:

Code: Select all

WARNING: Could not open audio device: No available audio device!
if I start a game e.g. DOTT:

Code: Select all

WARNING: Sound mixer initialization failed!
The sounddriver I selected in scummvm is 'default'. If I select 'alsa' it doesn't start at all:

Code: Select all

Can't subscribe to MIDI port (65:0) see README for help!
Scummvm runs perfectly in Ubuntu with the MT32-emu, but that doesn' work in Fedora either.
I'm new to Fedora, I think it uses pulseaudio as the soundserver, could this be the problem?
Standard apps like amarok, xmms... are working fine.

Some specs (feel free to aks for more).
scummvm version: 0.10.0 (from Fedora repository, August 22nd)
sound: intel centrino chipset (snd_hda_intel)
Installed everything sdl-related - didn't work...

Any hints? Thx alot!
urlauber
clem
Posts: 2160
Joined: Mon Oct 31, 2005 11:14 am

Post by clem »

Indeed there seems to be a problem about SDL + PulseAudio; I asked on the ScummVM irc channel, and apparently a workaround is to set SDL_AUDIODRIVER to "esd" - I haven't booted into linux since so I didn't check yet
User avatar
eriktorbjorn
ScummVM Developer
Posts: 3359
Joined: Mon Oct 31, 2005 7:39 am

Re: No sound at all [Fedora 8]

Post by eriktorbjorn »

urlauber wrote: The sounddriver I selected in scummvm is 'default'. If I select 'alsa' it doesn't start at all:
The music driver setting in ScummVM only controls how synthesized music is played. "ALSA" means using the ALSA sequencer to play MIDI. The "default" setting probably means using (emulated) AdLib music instead.
urlauber wrote: I'm new to Fedora, I think it uses pulseaudio as the soundserver, could this be the problem?
I've never used Fedora, but maybe this bug report is what you're looking for.
urlauber
Posts: 5
Joined: Wed Jan 16, 2008 10:24 am

Post by urlauber »

The workaround to set SDL_AUDIODRIVER to esd does the job for now, thx!
Post Reply