Full Throttle doesn't start up

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
smackattack
Posts: 4
Joined: Sat Aug 04, 2007 8:55 pm

Full Throttle doesn't start up

Post by smackattack » Sat Aug 04, 2007 9:01 pm

Thanks to this guide I've gotten all my old lucasarts games to work on my Pocketpc (viewsonic v35 running windows mobile 2002) with the exception of Full Throttle. I've followed the steps in the guide but every time I start it up it SCUMM the screen goes to black and then it drops back to the file explorer (I'm using an original win95 cd that I think has the dos version in the resource directory). Am I missing something? This is easily my favorite lucasarts game second only to Monkey Island (and about even with The Dig) and I'm getting pretty frustrated here.

Moderatorial: Split from SirDave's post

User avatar
knakos
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Sun Aug 05, 2007 8:05 am

Do the same FT files work with a desktop PC version of scummvm?

How much free memory does your device have (this is the most probable culprit)?

smackattack
Posts: 4
Joined: Sat Aug 04, 2007 8:55 pm

Post by smackattack » Tue Aug 07, 2007 10:34 pm

Actually I tried it on my PC as well. I'm guessing that I'm either missing a step or something is fudging in the compression. It runs fine if I use the SCUMMVM on the pc using just the cd itself as the assigned directory but as soon as I move the files to the hard drive and run the compressions- no go. I got Day of the Tentacle, the Dig, and Sam n' Max working with no problems. I've gone though it twice now from the very beginning with still no luck. I don't know. I'm out of town until Thursday (was actually hoping to have it running for this trip) but I'll try again when I get home. Thanks.

smackattack
Posts: 4
Joined: Sat Aug 04, 2007 8:55 pm

Post by smackattack » Thu Aug 09, 2007 11:34 pm

Ok, after testing between the various steps, it seems that the problem is when I compress the .san files. It works fine when I run the native files off the cd, it works fine with the uncompessed files on the hard drive, also fine when I compress the audio, but after I compress the san files it won't run. Not even on the PC.

Does anyone know if there were any releases of FT that don't compress well? According to SCUMM I'm using Full Throttle Version A/ENGLISH and looking in the readme it says it's 1.00. Do I need to run a patch or something? I'm quite flummoxed as I haven't had any problems with any of the other games.

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem » Thu Aug 09, 2007 11:48 pm

smackattack wrote:Ok, after testing between the various steps, it seems that the problem is when I compress the .san files. It works fine when I run the native files off the cd, it works fine with the uncompessed files on the hard drive, also fine when I compress the audio, but after I compress the san files it won't run. Not even on the PC.

Does anyone know if there were any releases of FT that don't compress well? According to SCUMM I'm using Full Throttle Version A/ENGLISH and looking in the readme it says it's 1.00. Do I need to run a patch or something? I'm quite flummoxed as I haven't had any problems with any of the other games.
which version of ScummVM/of the ScummVM tools are you using to compress the files? there has been a bug which trashed the files/crashed the game with Full Throttle, but I thought that has been fixed by now

edit: I found this: https://sourceforge.net/tracker/?group_ ... id=1390815
Last edited by clem on Thu Aug 09, 2007 11:55 pm, edited 1 time in total.

User avatar
PsYcO
Got 2 warnings
Posts: 513
Joined: Sun Dec 24, 2006 9:27 pm
Location: UK, Enfield
Contact:

Post by PsYcO » Thu Aug 09, 2007 11:53 pm

assuming that his running on 0.X.0, don't the latest tools come with that version?

smackattack
Posts: 4
Joined: Sat Aug 04, 2007 8:55 pm

Post by smackattack » Fri Aug 10, 2007 12:30 am

I'm running 0.10.0 both for the tools and for the SCUMM interface.

EDIT: I suppose that since I've figured out that it's not a PPC/WINCE issue the topic could probably be moved to the general area.

Second edit: After figuring out how to catch the error message I got this info:

"WARNING: Language file is forced to be ignored!
Cannot open file roadrash.rip"

davelar
Posts: 1
Joined: Wed Sep 19, 2007 3:02 am

Post by davelar » Wed Sep 19, 2007 3:05 am

I had the same problem and found that something had gone wrong with the DATA directory compression. I found that if I left the directory uncompressed the game runs fine. It means an extra 30MB on my Axim, but at least it runs.

Post Reply