Bug in scummVM interface

General chat related to ScummVM, adventure gaming, and so on.

Moderator: ScummVM Team

JDAdams
Posts: 16
Joined: Mon May 28, 2007 7:37 pm

Post by JDAdams »

My entries look like this:

[gob1]
description=Gobliiins (CD)
path=C:\Games\ScummVM\gobliiins\
gameid=gob
language=en

[gob2]
description=Gobliins 2 (CD)
path=C:\Games\ScummVM\gobliins2\
gameid=gob
language=en

If you're using an SVN build, move the scummvm.ini file to the new location (documents and settings/{userID}/application data/scummvm and see if that helps.
derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

Post by derboo »

Moved it, but still no effect.
User avatar
eriktorbjorn
ScummVM Developer
Posts: 3393
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

JDAdams wrote: If you're using an SVN build, move the scummvm.ini file to the new location (documents and settings/{userID}/application data/scummvm and see if that helps.
The location of the ScummVM configuration file shouldn't matter, as long as ScummVM can find it. In fact, if he's using the current stable release (0.9.1), the new location wouldn't work at all since it was added later.

To me, the main mystery is still how ScummVM could possibly run Gobliiins with only Gobliins 2 data files. Are there any game data files in the same folder as scummvm.exe itself? Is the Extra Path setting pointing to a folder with any game data files?

From what I remember, 0.9.x is the version of ScummVM that tries to look in every single sub-folder it can find, so it might actually be a problem if scummvm.exe is in C:\Games\ScummVM. The development version (and the yet-to-be-released 0.10.0) shouldn't have that particular problem, though.
derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

Post by derboo »

The problem seems to be that it opens the folder scummvm/games/gob1/ first, even though the selected path for the game is in scummvm/games/gob2/. Does it give priority to the automatic search before the selected path?

Ahhh, I don't know, maybe it's just strange for me because i use a korean Windows...
fingolfin
Retired
Posts: 1452
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin »

derboo, look, people are trying to help you, but as long as you blatantly ignore all the questions, esp. eriktorbjorn's, that won't be possible.

So please read Torbjörn's post, and answer his questions. Alternatively / additionally, it would be interesting to see the *full* [scummvm] section of your .ini.
derboo
Posts: 25
Joined: Sun Jun 17, 2007 5:50 am

Post by derboo »

I don't think I've ignored "all the questions", though I have to admit that I kinda read over the important paragraph in his last post. :oops:

The Extra path was pointing at the scummvm folder and changing it did finally solve the problem. Thanks all, especially eriktorbjorn.
Post Reply