Reason for random crashes?

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
User avatar
frank_m24
Posts: 97
Joined: Sun Oct 30, 2005 4:10 pm
Location: Germany

Reason for random crashes?

Post by frank_m24 » Fri Dec 08, 2006 6:26 pm

Hello,

some people are reporting random crashes of PocketSCUMM 0.9.1 with various games. Yesterday I had a similar problem. Suddenly ScummVM crashes when starting DOTT, which was stable before.

What I found out: The behaviour is affected by the size of the scummvm.ini. If I delete some (unnecessary) lines (e.g. the Smush_force_redraw lines), ScummVM runs stable. As soon as this line is added several times in the game blocks (happens automatically if the game is started), PocketSCUMM suddenly becomes unstable. In this way I can have a "stable" scummvm.ini or an "unstable" one. But unfortunately it is not the case, that ScummVM becomes always unstable if the scummvm.ini exceeds a specific size: up to e.g. 2000 Bytes it is stable, from 2000 - 2200 Byte it is unstable, over 2200 Byte it is stable again, over 3000 Bytes unstable ... (just fantasy sizes, only tried to delete some game entries in order to check the effect, like a proof of concept).

If I remember right, we had a similar problem some releases ago. I think, it had something to do with an uninitialised variable (a bool?), maybe regarding the keyboard or the tool bar. But I'm not sure at this point.

kind regards

Frank

User avatar
knakos
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Fri Dec 08, 2006 7:33 pm

Good catch Frank, and very thorough investigation. Please copy this post verbatim on the bugtracker and add a couple of those problematic ini files.

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin » Sat Jan 13, 2007 1:58 pm

Has this been filed as a bug report (as knakos requested) and/or fixed already? I didn't see it on the bug tracker, but then maybe I just missed it, or it was already fixed and closed... if there is a tracker item (even a closed one), it might be nice to add a link to it here :-)

Thanks!

User avatar
knakos
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Sat Jan 13, 2007 6:10 pm

Hum, hum, I thought this had indeed been submitted in the tracker but I can't seem to find it. So I'm going ahead and opening an item for this, so we won't overlook it. It would be nice if frank_m24 got around to submitting a bug report, also attaching a problematic .ini file. In that case I'll close mine as a dupe.

Post Reply