crash on QTEK 9100 (monkey island)

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
jaspov
Posts: 6
Joined: Tue Jun 27, 2006 8:57 pm

crash on QTEK 9100 (monkey island)

Post by jaspov » Tue Jun 27, 2006 9:09 pm

Hello,

I have DOTT running on the latest version of SCUMMVM. The sound is still missing but I am working on converting the files as described in a thread here.

Monkey Island crashes however. I can't seem to figure out why?

Monkey Island crashes right after I see the lucasarts logo. I just see it and then I get the unrecoverable error message. Here is the log:

----------------------------------------
Exception Access Violation Flags 00000000 Address 000bcab0
Parameter 0 00000000
Parameter 1 26000008
----------------------------------------
Context dump
R0=00000000 R1=0062c550 R2=0033f9fa R3=00000000 R4=00000000
R5=00000000 R6=00000000 R7=00000001 R8=00000000 R9=00000000
R10=03fa61d0 R11=00000000 R12=0db6bf2f
Sp=263ff77c Lr=000beb58 Pc=000bcab0 Psr=60000010
----------------------------------------
Memory dump at 000bca7e
58 e1 04 00 00 ca 01 00
00 ba 01 00 50 e1 01 00
00 8a 01 70 94 e2 00 80
a5 e2 07 10 a0 e1 08 20
a0 e1 06 00 a0 e1 61 fb
ff eb 06 00 a0 e1 08 20
9d e5 08 30 b0 e5 0c 10
9d e5 03 20 52 e0 04 30
90 e5 06 00 a0 e1 03 30
c1 e0 40 10 8d e2 3c fa
ff eb 7f 30 e0 e3 00 90
a0 e1 01 a0 a0 e1 0a 00
a0 e1 03 00

Unfortunately this means nothing to me so I was hoping someone here might help me solve this. The cdtracks I converted to ogg, but also with audio set to "no music"I get this error. I read some people have problems with mp3 in versiom 0.9 but this is ogg so it should work.

[edit]I found a bug has been submitted describing crashes with ogg files so I'll convert to mp3. Hope that works since other users post problems with mp3 http://sourceforge.net/tracker/index.ph ... tid=418820[/edit]

[edit2]DOTT now works with ogg audio so at least ogg works sometimes. I converted Monkey island audio from ogg to mp3 and it still crashes right at the lucasarts logo. Now the log says:
----------------------------------------
Exception Access Violation Flags 00000000 Address 00044954
Parameter 0 00000000
Parameter 1 10f03fb8
----------------------------------------
Context dump
R0=00790030 R1=0064b510 R2=00000001 R3=10f03fb0 R4=00000001
R5=00000000 R6=ffffffff R7=00625150 R8=00790030 R9=0064b510
R10=006429e0 R11=203ff874 R12=4e5825f7
Sp=203ff81c Lr=00044958 Pc=00044954 Psr=20000010
----------------------------------------
Memory dump at 00044922
87 e5 28 30 87 e5 0c 90
87 e5 10 40 c7 e5 11 50
c7 e5 18 60 87 e5 2c 80
87 e5 18 00 00 0a 00 00
58 e3 11 00 00 0a 00 30
98 e5 08 00 a0 e1 0f e0
a0 e1 08 f0 93 e5 2c 20
97 e5 0c 40 99 e5 00 50
a0 e1 00 30 92 e5 02 00
a0 e1 0f e0 a0 e1 14 f0
93 e5 20 30 dd e5 05 20
a0 e1 04 10 a0 e1 44 0a
00 eb 28 00
[/edit2]

cryptoknight
Posts: 7
Joined: Thu Jun 15, 2006 4:16 am

Post by cryptoknight » Wed Jun 28, 2006 1:07 am

my monkey island tracks are in mp3, and it crashes at the lucas arts logo, too. i was gonna convert to ogg out but looks like it still crashes...

jaspov
Posts: 6
Joined: Tue Jun 27, 2006 8:57 pm

Post by jaspov » Wed Jun 28, 2006 6:14 am

Do you have the same hardware? a qtek 9100 or similar phone?

I just installed Scummvm 0.82 and that works with Monkey Island, so could it be something that changed in between versions?

Flynn
Posts: 2
Joined: Wed Jun 28, 2006 2:01 pm
Contact:

MI1 MP3 crashes on MDAc

Post by Flynn » Wed Jun 28, 2006 3:17 pm

I have the same problem (crash while first logo is displayed) with:
Game: Monkey Island 1 CD (en)
Compression: MP3
Scumm: ScummVM 0.9.0 WinCE
PDA: MDA compact (HTC Magician/QTEC S100) / Win Mobile 2003SE

The game works on the pda if I remove all the mp3 files.

The game files including the mp3 music work just fine with ScummVM 0.9.0 Win32.

cryptoknight
Posts: 7
Joined: Thu Jun 15, 2006 4:16 am

Post by cryptoknight » Wed Jun 28, 2006 6:18 pm

jaspov wrote:Do you have the same hardware? a qtek 9100 or similar phone?

I just installed Scummvm 0.82 and that works with Monkey Island, so could it be something that changed in between versions?
Sorry yea lemme clarify. I have an HTC Wizard like yours (Cingular 8125).

jaspov
Posts: 6
Joined: Tue Jun 27, 2006 8:57 pm

Post by jaspov » Wed Jun 28, 2006 6:27 pm

I hope the bug described above is fixed soon. I tried to create a logon to sourceforge but logging on is not possible at this moment....in the mean time the old version works although the on screen keyboard gets in the way...

User avatar
knakos
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Wed Jun 28, 2006 6:45 pm

the game should work ok if you delete the sound files until the issue s resolved.

Flynn
Posts: 2
Joined: Wed Jun 28, 2006 2:01 pm
Contact:

Post by Flynn » Mon Jul 03, 2006 7:43 pm

The fixed binary by knakos (viewtopic.php?t=1728) corrects the problem I reported here.
Thanks a lot.

jaspov
Posts: 6
Joined: Tue Jun 27, 2006 8:57 pm

Post by jaspov » Tue Jul 04, 2006 5:10 pm

Thanks! it works! great!

Post Reply