FLAC compression

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
maff.brush
Posts: 19
Joined: Fri Jun 25, 2010 1:01 pm

FLAC compression

Post by maff.brush » Sat Jul 24, 2010 4:31 pm

Hi!
Is there a reason why there is no flac support? Is it too demanding on CPU?
(It's just that I converted a lot of games to flac, and converting everything again would be a little annoying)

oh, and... keep up the great work!

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Jul 27, 2010 7:24 am

Well it makes the binary larger, not tested.. and hmm well.. not sure about the cpu. I guess adding support would be no problem. You could be the tester. :-)

maff.brush
Posts: 19
Joined: Fri Jun 25, 2010 1:01 pm

Post by maff.brush » Tue Jul 27, 2010 4:21 pm

Sure, I'm ready to test! 8)

as for cpu utilization, according to this, no problem with flac.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sat Jul 31, 2010 7:47 pm

Do you have any scumm games flaced? like Monkey Island 1 VGA CD version or so. I guess that would be nice to test with.

maff.brush
Posts: 19
Joined: Fri Jun 25, 2010 1:01 pm

Post by maff.brush » Sat Jul 31, 2010 9:44 pm

I have Monkey Island 1 VGA CD (Italian version), with all cd tracks as .fla files.
Maybe I can help also with Day of the tentacle or Sam&Max: they have flac audio inside monster.sof.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sun Aug 01, 2010 8:08 pm

That will also work. I have a new gsoc build I will try to get tested. But it does n't quite start yet. I will be back when that builds starts.

maff.brush
Posts: 19
Joined: Fri Jun 25, 2010 1:01 pm

Post by maff.brush » Fri Aug 06, 2010 1:23 pm

everything's working perfectly with the last svn.
Both Monkey Island (with .fla files) and Day of the Tentacle (with monster.sof) can be played with sound and without problems.

thanks! feel free to ask me if yoo want some more testing

OT: how about language support for the GUI?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Fri Aug 06, 2010 1:46 pm

Whoo so it did work! :-D Nice. No extra asm opts in flac. I just managed to build it, wrap around some H files and then enabled it in ScummVM. :-) Goodie Woodie ! :-D

Language support I have n't looked into yet.And its only the UI not the games. I think the about box has the most text.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Fri Aug 06, 2010 2:03 pm

Ok.. just another define to enable for translation. So doing a testbuild now.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Fri Aug 06, 2010 4:12 pm

I have now uploaded a new version supporting language change in the ui.not all languages are supported due to the way the themehandler manages the font.so no russian,hungarian etc.delete the scummvm.ini if you get problems.

maff.brush
Posts: 19
Joined: Fri Jun 25, 2010 1:01 pm

Post by maff.brush » Fri Aug 06, 2010 10:40 pm

can you tell me which is the last version (with ui translation support)?
I tried to download scummvm-100806-SymbianS60v3_all.sis again, but nothing changed.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Mon Aug 09, 2010 7:00 am

Latest sis (same date) should have langauage selection available in the global options menu. see if you can find it. last tab to the right

maff.brush
Posts: 19
Joined: Fri Jun 25, 2010 1:01 pm

Post by maff.brush » Mon Aug 09, 2010 8:16 am

ok, my fault. I installed the new version over the last one, while I should have uninstalled first. deleting scummvm.ini was not enough.

thanks again

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Mon Aug 09, 2010 10:28 am

Hmm I think upgrading should be enough. Looks like a UI bug, scummvm.ini should not block language even though you used a prev. version where it has n't been compiled in. Any how. It works. Well.. except for the fonts. :-) Need to be fixed.

Post Reply