Touch Problem

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Touch Problem

Post by muhul » Thu May 13, 2010 5:42 am

I use 5800xm

build scummvm 1.1.1 and install sis my phone

but touch not response

can't move cursor

and No virtual kerboad :shock:

what's wrong?

i guess SDL error

any solution?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu May 13, 2010 7:35 am

Yes I need to upload my latest version of SDL. I think the one uploaded should have touch support, but the VKeyboard might be missing.

muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Post by muhul » Thu May 13, 2010 7:41 am

Thanks reply Anotherguest

when can i get? :oops:

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu May 13, 2010 9:56 am

Where did you get my other sdl port?? I will upload it there :-) Of course

muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Post by muhul » Thu May 13, 2010 9:59 am

thanks Anotherguest :lol:

i am waiting :lol:

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu May 13, 2010 10:02 am

Hi! I checked my latest source upload and that contains my touch and vkey modifications so you MUST be using the wrong SDL.
Have you used the perl scripts to build or?

muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Post by muhul » Thu May 13, 2010 10:06 am

sorry my perl skill is beginner

I have used Perl here first

Sorry :oops:

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu May 13, 2010 10:11 am

What I wonder is if you used the build scripts located in scummvm\backends\platforms\symbian to build or if you have made your own symbian port.
The perlscripts creates all mmp files with the correct source files from the makefiles.

This is what should be documented in the wiki page but currently is only somewhat documented in a readme in the symbian folder.

Also I think you are using the standard Symbian SDL port, that does not contain bugfixes needed for scummvm (recursive mutexes) and not any adoptions for general device support (UIQ3, S80, S60, S60v3, S60v5).

My homepage is
http://www.anotherguest.se and there you can find my version of SDL for symbian.

muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Post by muhul » Thu May 13, 2010 10:20 am

ok I try :lol:

muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Post by muhul » Thu May 13, 2010 11:19 am

oops what is this?

make -r -j 2 -f "\S60\devices\S60_5th_Edition_SDK_v1.0\EPOC32\BUILD\scummvm-1.1.1\backends\platform\symbian\S60v3\GCCE.make" FINAL CFG=UREL VERBOSE=-s
make -s -C \scummvm-1.1.1\backends\platform\symbian\S60v3 -f "ICONS.MK" TO_ROOT=..\..\..\..\.. EPOCBLD=\S60\devices\S60_5th_Edition_SDK_v1.0\EPOC32\BUILD\ICONS\GCCE TO_BLDINF=..\..\..\..\..\scummvm-1.1.1\backends\platform\symbian\S60v3 PLATFORM=GCCE CFG=UREL FINAL
(1) : error: unknown line

i did build

but package failed :cry:

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu May 13, 2010 12:15 pm

Try building with -v at the end (you can now build with abld build gcce urel -v from the s60v3 folder). That would give you what the compiler and tools are doing

muhul
Posts: 14
Joined: Wed May 12, 2010 3:16 am

Post by muhul » Thu May 13, 2010 3:11 pm

I solved problem

thanks Anotherguest

Post Reply