Monkey Island 2 on Nokia 5800 crash

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
HarryH00t
Posts: 5
Joined: Sat Feb 06, 2010 6:19 pm

Monkey Island 2 on Nokia 5800 crash

Post by HarryH00t » Sat Feb 06, 2010 6:30 pm

Hi Guys,
I'm using ScummVM v 1.0.0 on my Nokia 5800 mobile. I finished Monkey Island 1 last Thursday. It helped me over several boring hours, so thanks for that.
I wanted to start playing MI2 today. I installed the game normally and I can start it as usual. But during the Intro, the game kinda crashes. I get through the dialog with Elane, and the Lucas Arts Logo/Title screen show up. Then the dancing monkeys appear. Guybrush comes into the screen and looks at them... this is where the game stops. The monkeys keep clapping their heads(or something else), but nothing else happens. And when I press ESC, the screen turns black and nothing happens anymore. I can quit the game over the menu normally.
I tried disabling all the sounds, but that didn't solve the problem. Can you help me please?
Harry

User avatar
Freddo
Posts: 281
Joined: Mon Oct 31, 2005 4:41 pm

Post by Freddo » Sun Feb 07, 2010 12:37 am

I played thru Monkey Island 2 using ScummVM 1.0.0 on my Nokia E52 without any issues.

So it seems to me like your files somehow got corrupt. So try playing the game on PC and see if it works there, and then copy over it to the phone again.

HarryH00t
Posts: 5
Joined: Sat Feb 06, 2010 6:19 pm

Post by HarryH00t » Sun Feb 07, 2010 11:13 am

Hi,
I've tried it on my pc and it worked really fine. Don't know whats wrong with my mobile :(
At least, this gave me another possibility: I skipped the intro on my pc, saved the game and copied the gamestate to my mobile. Seems to be working now. Really wish to know what is wrong there.
Thanks for the reply.
Harry

HarryH00t
Posts: 5
Joined: Sat Feb 06, 2010 6:19 pm

Post by HarryH00t » Sun Feb 07, 2010 1:24 pm

So, I played the game for about five minutes now, and I've got the next problem: when trying to enter the wooden head in the swamp, the water starts moving but nothing more happens. This time I can't use the ESC key to skip anything, it just stays this way until I quit the game. This really makes me sad :( any ideas ?

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3303
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Sun Feb 07, 2010 2:33 pm

I believe the closing of the jaw is triggered by the music, but I don't know why that wouldn't work on the SymbianOS port. (Come to think of it, I don't know anything about the SymbianOS port.)

User avatar
Mataku
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku » Sun Feb 07, 2010 2:49 pm

yhea it sounds like an iMuse issue. most of the game's actions are triggered with the music (or vice versa). try downgrading the Scummvm version. could be a regression.

HarryH00t
Posts: 5
Joined: Sat Feb 06, 2010 6:19 pm

Post by HarryH00t » Sun Feb 07, 2010 9:13 pm

So, I reinstalled Scumm VM. I don't know why, but now the game works great without any problems. I have no idea what was wrong with it. Only thing I changed was that this time I installed Scumm on my memory card. Dont think this was the problem since it made no problems on MI1. Anyways, I'm glad its working now. Thanks for your help.
Harry

HarryH00t
Posts: 5
Joined: Sat Feb 06, 2010 6:19 pm

Post by HarryH00t » Sat Feb 20, 2010 3:05 pm

Ok, I figured out what was the problem. Since I had sound although I checked the mute all option in the sound settings, I chosed the "no music" musicdriver in the soundsettings in order to have really no sound. I don't know why the game crashes at some points with this option, but selecting a musicdriver ended all problems.
H00t

Post Reply