Right 'selection' button not functioning on E71

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
Muncher666
Posts: 6
Joined: Wed Oct 04, 2006 4:32 pm

Right 'selection' button not functioning on E71

Post by Muncher666 » Fri Jan 22, 2010 2:38 pm

Hi guys,

I have an E71 that runs the symbian port of ScummVM very well - with one rather major niggle - the right selection button, right of the middle 'navi' button - does not seem to register or be mappable. I get the impression it is supposed to function as a right click - whenever I push it to map a key in ScummVM it registers as a full stop, and then when I go to use it in the program it does not respond (however the full stop does work as a right click). The Navi button and left selection button appear to function as left clicks, however.

Is this a niggle with the platform, the port, SDL or just my incompetence? I can't seem to sort it. Any advice would be much appreciated.

Thanks,
Allan.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Mon Jan 25, 2010 6:34 am

this depends on the version of scummvm you are using.green key and press m then green key again should turn on mouse mode in the latest versions.them left softkey is left mouse button and right softkey is right mousebutton.

Muncher666
Posts: 6
Joined: Wed Oct 04, 2006 4:32 pm

Post by Muncher666 » Tue Jan 26, 2010 10:31 am

Would appear to be ignorance. :oops:

Thanks very much! :)

Allan.

Post Reply