ScummVM 1.0.0 S60v5 Samsung i8910HD - BUGS

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
Posts: 2
Joined: Thu Nov 19, 2009 9:17 pm

ScummVM 1.0.0 S60v5 Samsung i8910HD - BUGS

Post by Xylen.C4 »

Hello guys,

i have a vew problems since i updated to latest version of scummvm!

The First bug is, that the rotation to the landscape mode doesn't work fine! But this problem has always existed since i use the i8910, so now i would report it! I have switch off the rotation for the hole OS to play games!

The second bug is that the button upper right is not working properly! While no game is started, its working fine but if a game has startet it will not longer works!

I've made a video of this, you can watch it here

yours sincerely Xylen.C4

User avatar
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku »

I don't know why the square is on the upper right to you, for me it's always been on lower right. Have you tried starting the game WHILST the keyboard is open?

The rotation thing has been adressed MANY times. Simple search would've fixed that for you. CTRL,2,CTRL (or, now... "Cur">"NUM">CTL>2>CTL) and viola...

ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

I don't have a i8910, but rotation works fine on the 5800 express music for example. Try starting the game in portrait mode and then rotating. Seems like phone is blocking the screenupdates when the sound is running. Strange...

Posts: 2
Joined: Thu Nov 19, 2009 9:17 pm

Post by Xylen.C4 »

"Cur">"NUM">CTL>2>CTL is working, the buttion is now lower right!

after a restart i have to do the same procedure.

but if i start a game the button wont work!

it doesnt mether if the menue is opend or not! It doesnt work!

do you tryed to emulate the i8910 with the i8910 SDK? ... ntsId=2341

€: ok, now im confused! The Landscape and Potrai mode works now correct!

Monkey Island 1 and Loom are working correct and the keyboard is working correct too!

but why doesnt work Broken sword? I will reinstall it once!

€€: It works now, i deleated the complete video folder!

I have the problems with the cuscenes at the windows version too, so i doesnt think its a problem of your port!

Post Reply