Sound on the 5800

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
hinrodath
Posts: 5
Joined: Tue Nov 03, 2009 4:05 pm

Sound on the 5800

Post by hinrodath » Tue Nov 03, 2009 4:52 pm

I am having trouble getting the sound to run on the 5800 for each game that I have tried.

The graphics and controls all seem to be fine, touch screen keyboard is workable =)

As a complete beginner to ScummVM (Only use it on my 5800) I would appreciate it if someone could detail the best way to get sound running.

I currently have the S60v3 Symbian 1.0.0rc1 version of ScummVM. I added 'The Dig', Indy 3, Indy 4 and Monkey Island 1 to the list of games, but I can't get sound for any of them.

The subtitles work ok, it is playable but sound would make it perfect! I tried playing around with the options in the root menu of ScummVM, but no luck. I tried all frequencies of sound available for each game, from 8hz upwards, tried turning the MIDI options off and on, but nothing seems to yeild any positive results.

I've read in some other threads that some people have these games running smoothly, with some sound working. Could you guys let me know how to get the settings right?

By the way, I have the FMTOWNS sound version of these games on the mobile, but I have tried the .ogg (which Nokia doesn't support). I tried the .wav version too, but no luck....

Thanks in advance.

User avatar
Mataku
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku » Tue Nov 03, 2009 6:05 pm

Try opening the side keybaord and press CTRL. press the Up arrow a few times (about 10 just to be sure). press CTRL again. Play game.

hinrodath
Posts: 5
Joined: Tue Nov 03, 2009 4:05 pm

Post by hinrodath » Tue Nov 03, 2009 8:38 pm

Mataku wrote:Try opening the side keybaord and press CTRL. press the Up arrow a few times (about 10 just to be sure). press CTRL again. Play game.
Hi thanks for the response, I wish it was that easy. Unfortunately, I've tried this and I still cannot get any sound.

Is there anything specific which needs to be done to the type of sound files used or the settings in the Audio or MIDI option menu?

Or any other suggestions?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Nov 04, 2009 9:51 am

Older games use FM emulation for music so thats not really an enconding issue. Tap square to get virtual keyboard. Tap Cur to get cursor mode. Tap Ctrl, tap up arrow, tap ctrl again for volume.

hinrodath
Posts: 5
Joined: Tue Nov 03, 2009 4:05 pm

Post by hinrodath » Fri Nov 13, 2009 1:39 pm

Thanks for your response.

This worked for certain games, only the Monkey Island 1 didnt work.

I found that the Sound on 'The Dig' and COMI start well in the cut scene at the beginning, but breaks out after the game becomes playable. Obviously, the subtitles work, so it's still playable - but still, it would be great to find out how to get this working with full sound.

Maybe this is down to the processing power of the 5800, which might struggle.

User avatar
Mataku
Posts: 196
Joined: Tue Apr 21, 2009 3:28 pm

Post by Mataku » Fri Nov 13, 2009 2:39 pm

hinrodath wrote:
Mataku wrote:Try opening the side keybaord and press CTRL. press the Up arrow a few times (about 10 just to be sure). press CTRL again. Play game.
Hi thanks for the response, I wish it was that easy. Unfortunately, I've tried this and I still cannot get any sound.
Anotherguest wrote: Tap Ctrl, tap up arrow, tap ctrl again for volume.
hinrodath wrote:
This worked for certain games,
he told you exactly what i did, but when he said it, it worked?

I found that the Sound on 'The Dig' and COMI start well in the cut scene at the beginning, but breaks out after the game becomes playable. Obviously, the subtitles work, so it's still playable - but still, it would be great to find out how to get this working with full sound.

Maybe this is down to the processing power of the 5800, which might struggle.
"The dig" only has sound when it's the original files, and not a compressed version. CMI will crash if it's uncompressed, and will be silent if is (but won't crash). So, in the meantime the only way to play CMI is using a compressed version that will be silent. MI1 has CD music, so unless you've ripped it and put the mp3\ogg files with the game files, you won't get any music.

hinrodath
Posts: 5
Joined: Tue Nov 03, 2009 4:05 pm

Post by hinrodath » Thu Nov 26, 2009 2:55 pm

'he told you exactly what i did, but when he said it, it worked?'

Yes, i'm an idiot- self confessed, but thanks for pointing it out to me.

Anyway thanks for your time responding, it has been really helpful.

Post Reply