SCUMMVM vs Nokia E65 problem

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
HeD_pE
Posts: 6
Joined: Mon Sep 14, 2009 9:09 pm

SCUMMVM vs Nokia E65 problem

Post by HeD_pE » Mon Sep 14, 2009 9:28 pm

Hi,

I've tried installing SCUMMVM on my Nokia E65 (FW - 2.0633.65.01) but it doesn't work at all! i mean, the app opens up but then nothing, the cursor doesn't move, the only thing i can do is enable ctrl by pushing the green button, but nothing more.
I tried changing from joystick to cursor mode and still nothing, it appears as if the only buttons doing something are the green (ctrl) and C (exits).
I tried pushing the app button to go to the menu and pushing again to switch back to scummvm and still nothing. Tested the app both in the memcard and the phone memory and with 2 versions 1.0.0rc1 and pre0.13.0 but my efforts were all useless.

Could someone help on this one please, i've searched for an answer and all i got was people saying it works fine with E65 :?

Thanks.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Sep 15, 2009 9:02 am

try green then 'm' or '0' and green again.

HeD_pE
Posts: 6
Joined: Mon Sep 14, 2009 9:09 pm

Post by HeD_pE » Tue Sep 15, 2009 12:20 pm

i've tried all the combinations with green + key + green and nothing happens, when i push the green the "CTRL" sign appears and i try pushing all the other buttons(except C and red) and it doesn't do anything, the only one that appears to work is the green one and C as I have said...

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Sep 15, 2009 1:35 pm

'm' would activate the mouse mode so you can move the mouse. An 'm' should be displayed on the screen ('m' or '0' should be pressed while 'ctrl' is visible).

Btw do the mouse cursor flash at a regular interval?

HeD_pE
Posts: 6
Joined: Mon Sep 14, 2009 9:09 pm

Post by HeD_pE » Tue Sep 15, 2009 2:16 pm

i've tried pressing all the keys one at a time with and without the visible ctrl.

yes the cursor's constantly flashing at a regular interval so it's not a freeze problem... but i can't move it from the up-left corner :?

btw, with ctrl enabled, when you press another key, it automatically disappears enabling the keys function or you have to hit green again to enable the function? i'm just asking this to know if the numpad keys are working on the app.

my guess is that the numpad/directional keystrokes aren't being recognized at all because there are a few java games that i've installed and the same happened, but never with all the keys.
e.g. in "Platinum Solitaire 2" i can play directions both with the d-pad and numpad, but the * and # don't work!

KuroShiro
Posts: 455
Joined: Thu May 15, 2008 7:42 am
Location: Miyazaki, Japan

Post by KuroShiro » Tue Sep 15, 2009 6:21 pm

I actually had the exact same problem on the N75 when I first got it working, but then for some reason it just started working properly. All I can suggest is to try turning your phone on and off, maybe removing the battery?

HeD_pE
Posts: 6
Joined: Mon Sep 14, 2009 9:09 pm

Post by HeD_pE » Thu Sep 17, 2009 11:52 am

nothing... even tried turning the phone on without the memcard and it's the same. maybe i'll try a format...

citizenk
Posts: 2
Joined: Tue Sep 22, 2009 6:48 am

Post by citizenk » Tue Sep 22, 2009 1:42 pm

Try green key -> 1 -> green key, it worked on my e75 anyway.
(For reference, I found this here)

HeD_pE
Posts: 6
Joined: Mon Sep 14, 2009 9:09 pm

Post by HeD_pE » Thu Sep 24, 2009 2:27 pm

citizenk, thanks for trying to help but i think i said i've tried all those options: green + 1 + green; green + 2 + green; etc.......

Just got it working after a thousand hard resets, and with some trial and error research, i've found out that it was an app i had installed in the phone mem(that's why it didn't work without the card) and it was causing this problem with scummvm and other apps/games, even got that platinum solitaire 2 issue working ;)

By the way, the app is called Platomix Security Genius for s60v3.

Thanks to all for everything!! ;)

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Fri Sep 25, 2009 6:27 am

Aha so I guess it was stealing your keyevents or something like that. grrr for that app, is a virus?

HeD_pE
Posts: 6
Joined: Mon Sep 14, 2009 9:09 pm

Post by HeD_pE » Fri Sep 25, 2009 3:04 pm

yeah that's what i thought from the beginning because only 2 keys were working and it wasn't the phone's problem. Since similar problem was noted on other apps, it could only mean that something was blocking the keys! I began with hard resets, and reinstalling everything again until i found out it was that app. at that i just thought: "damn, wasn't it easier using a task manager?" lolol

about the app, it's not a virus, it's a very useful app when u live in the suburbs where cell phone theft is very common... it sends sms's to 1 or more numbers designated by the user if the phone is powered on with another sim card! it gives u data about the sim number, phone number, active cell, operator.
only one problem, if the person who puts his simcard in the phone doesn't have money to send sms's... dang, no sms! lolol

well, that's the end of my thievery tracking :?

Post Reply