The Curse of Monkey Island on Nokia 5800

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Jul 21, 2010 12:59 pm

This all started to happen when the new mixing code strucutre was introduce. Strange its only affecting symbian arm , might be compiler optimiations that does it. Hmm should perhaps try without them.

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Wed Jul 21, 2010 1:05 pm

Anotherguest wrote:This all started to happen when the new mixing code strucutre was introduce. Strange its only affecting symbian arm , might be compiler optimiations that does it. Hmm should perhaps try without them.
it's strange yes, please keep us posted on any news :)

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin » Wed Jul 21, 2010 4:22 pm

Anotherguest wrote:This all started to happen when the new mixing code strucutre was introduce. Strange its only affecting symbian arm , might be compiler optimiations that does it. Hmm should perhaps try without them.
What "mixing code structure" do you refer to? Any particular revision to which you can pinpoint the problems?

Bye,
Max

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Jul 27, 2010 7:26 am

I will try a version before the new mixing code was introduced. It is playing music, but it sounds very very very distorted.

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Sat Oct 23, 2010 11:40 pm

they were all dead.

User avatar
md5
ScummVM Developer
Posts: 2258
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Sun Oct 24, 2010 10:26 am

sblantipodi wrote:they were all dead.
That doesn't make much sense, I'm afraid

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Sun Oct 24, 2010 11:36 am

md5 wrote:
sblantipodi wrote:they were all dead.
That doesn't make much sense, I'm afraid
it means that no one posts here anymore...
this section seems a desert...

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sun Oct 24, 2010 3:59 pm

And was dead? The 1.2 release? I will make a new build for it tomorrow. cheers

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Sun Oct 24, 2010 4:01 pm

Anotherguest wrote:And was dead? The 1.2 release? I will make a new build for it tomorrow. cheers
Wow, it will fix the COMI sound problem on S60 5th?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sun Oct 24, 2010 4:37 pm

Don't think so but it will run on more devices.

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Mon Oct 25, 2010 11:24 pm

Anotherguest wrote:And was dead? The 1.2 release? I will make a new build for it tomorrow. cheers
have you done the new build?
where can we get it?

thanks!

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Oct 26, 2010 11:22 am

Please try this:
http://www.anotherguest.se/scummvm-1.2.0-s60-v3.sis

test on 6120 and other older devices.

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Tue Oct 26, 2010 11:30 am

Anotherguest wrote:Please try this:
http://www.anotherguest.se/scummvm-1.2.0-s60-v3.sis

test on 6120 and other older devices.
is it good also for 5th devices?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Oct 26, 2010 11:41 am

Of course. :-)

sblantipodi
Posts: 44
Joined: Sun Apr 25, 2010 9:28 pm
Contact:

Post by sblantipodi » Tue Oct 26, 2010 12:29 pm

Anotherguest wrote:Of course. :-)
thanks.
just tryed it with comi, same audio problem :(

Post Reply