Nokia 9300 / S80

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Iggi
Posts: 2
Joined: Wed Oct 03, 2007 1:05 pm

Nokia 9300 / S80

Post by Iggi » Wed Oct 03, 2007 2:06 pm

Hi,
as requested on http://wiki.scummvm.org/index.php/SymbianOS_S80 a short note about the compatibility: ScummVM works on my Nokia 9300, with various SCUMM games tested so far.

However, I found the following problems:
- Sound: The sound does work, but only after switching to Joystick mode and then back to CURSOR mode. It's possible to switch back to Joystick mode then, but:

- Joystick mode: This mode doesn't really work. I would have expected that the Joystick mode in ScummVM works similar to the one in the integrated browser. In ScummVM, I have to start the movement horizontally oder vertically, otherwise the pointer won't move at all. When the pointer once moves, the direction can be changed a bit, but only if the stick doesn't leave the segment of that direction. (With segment I mean an area of about 45°)
I noticed that - if key click sounds are enabled on the phone - every move of the joystick makes a sound in ScummVM. When comparing that to the integrated Nokia browser, only the first move in the whole session makes that sound.

I hope the explanation wasn't too confusing and it somehow get's clear what I mean.


I've tested this on ScummVM 0.9.1, as this was the latest version I found for S80 phones.

This leads to the question: Is the S80 port still maintained at all? Also the SVN builds seem to have stopped...

Apart from these problems: Thanks a lot for this port, I've enjoyed it a lot so far :-)

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Thu Oct 04, 2007 7:26 am

Code base does NOT work for S80 any more. There might some tricks to make a new S80 version, but its not just a matter of recompiling the latest source, some fideling is required to get it to work. Its the same for S80, S90, UIQ2, S60v1 and S60v2. Currently only S60v3 and UIQ3 is supported.

Vicious
Posts: 38
Joined: Sun Jan 14, 2007 6:16 pm
Location: Poland

Post by Vicious » Sat Mar 01, 2008 10:59 am

Anotherguest - so threre are tricks to update this old version of scummvm for s80 ?? Could You explain how to do it?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sat Mar 01, 2008 2:14 pm

You mean updating the latest code base so that would run on a S80? Well.. that involves lots of patching and small configuration patches. Have not tried it in a while.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sat Mar 01, 2008 3:24 pm

I have just finished off patching and building a S80 and S60v2 version. Started fine on my N70, but it requires around 10mb to start. How is the memorysituation on the 9300/9500? At least older games would be playable, but newer larger ones, is like no no. I guess the GOB games would run!

Vicious
Posts: 38
Joined: Sun Jan 14, 2007 6:16 pm
Location: Poland

Post by Vicious » Sun Mar 02, 2008 12:13 am

Wow.Where I can fond this newer version :D ? I looked to cvsbuild but there aren't new version for s80v2. I think 10mb it's not a problem because 9500 have lots of free memory :D . I don't wanna play in new games.

I had a question. The Discworld and Police Quest are working on s80 ? I tried 2 versions and non of them works...

Sorry for my english. I lots of thanks to You Anotheguest!!! scummvm is a grat emulator!!!

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem » Sun Mar 02, 2008 12:26 am

Vicious wrote:I had a question. The Discworld and Police Quest are working on s80 ?
Discworld won't run in any port of ScummVM for the time being.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3316
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Sun Mar 02, 2008 12:27 am

Vicious wrote: I had a question. The Discworld and Police Quest are working on s80 ? I tried 2 versions and non of them works...
I don't know about the SymbianOS version of ScummVM, but generally speaking Discworld is not supported at all. Only the first Police Quest game is supported, and only if it's the original version. The 256-colour remake isn't supported.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Sun Mar 02, 2008 4:18 am

Yes AGI games might work, but well I have to test it. My usual FTP service is not really working, so I will figure out away to upload the files.

Vicious
Posts: 38
Joined: Sun Jan 14, 2007 6:16 pm
Location: Poland

Post by Vicious » Sun Mar 02, 2008 6:40 am

I thought that Discworld and Simon The Srorcerer are the same game. Sorry my fault. Only original version od Police Quest works - that text version ? It doesn't matter because I like both of them :) . And both of them I'm end .

So how can I get new version of scummVm AG ? When You repair Your FTP ? I'm waiting and I'd like really thank You :) .

Vicious
Posts: 38
Joined: Sun Jan 14, 2007 6:16 pm
Location: Poland

Post by Vicious » Tue Mar 04, 2008 11:44 am

BTW. I've got 20mb of free memory in 9500. It will be enough ?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Tue Mar 04, 2008 6:00 pm

Well.. If that is RAM then its ok for most games (not FT and other later games though)

Vicious
Posts: 38
Joined: Sun Jan 14, 2007 6:16 pm
Location: Poland

Post by Vicious » Tue Mar 04, 2008 9:58 pm

pq1,kq1,kq2,kq3,kq4,gob2 doesn't work... But still I think You make a great job. What kind of games could not work? I played in Flight Of The Amazon Queen CD version and It works good :) . It's amazing that I played in this game much faster then on my old Amiga computer :P . I'm waiting for new version - and If You want I can test all the games on my 9500. THX

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Mar 05, 2008 11:52 am

Well the latest version I have compiled shoudl support all the games you listed not working!

Vicious
Posts: 38
Joined: Sun Jan 14, 2007 6:16 pm
Location: Poland

Post by Vicious » Wed Mar 05, 2008 3:02 pm

sq1 and lure doesn't work too. Is there any chance to get new version?Sorry for my asking over and over again but this is because I can't wait for it :) .

Post Reply