SVN Build updated

Subforum for discussion and help with ScummVM's Symbian (mobile phones, etc) ports

Moderator: ScummVM Team

Post Reply
Sweeet
Posts: 11
Joined: Sat Feb 17, 2007 1:28 pm

Post by Sweeet »

Thank you! Your work on the Symbian builds is much appreciated. :)

User avatar
Noelemahc
Posts: 178
Joined: Sat Jul 07, 2007 2:24 pm

Post by Noelemahc »

Quick review: the ScummVM menu now loads four times as longer (!!!), Nippon Safes Inc. is no longer recognized as a supported game, the keymapper works and therefore the mouse-over problem is solved fully. But Goblins 3 still don't scroll the screen, only, fancy this -- the dropdown menu. Yesss, exactly, the menu moves as if the screen had moved, but the screen itself does not. Haven't yet tested how this affects the Full Throttle bike combat scenes.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

I don't even get Goblins III working properly in my emulator, I need to figure out how that menu positioning is working (it should always be centered regardsless of the offset of the whole screen). Currently the menu is always positioned at the same place as the whole screen, hopefully its only a Gob III problem (I have only seen it there).

Not sure what have been done to the menu handling. I guess you have lots of games installed??

User avatar
Noelemahc
Posts: 178
Joined: Sat Jul 07, 2007 2:24 pm

Post by Noelemahc »

Well, yeah, I do have to scroll. And I installed 0.11.0 on top of 0.10.0 to keep the saves and settings intact. At least that was my reasoning when I did it.

And it IS only a Gob III problem as only Gob III has screen scrolling :) Suffice to say it works well enough in the Win32 version of ScummVM as I've completed it there.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

Yes I know, I compared them my self. So I must be something really strange with the Symbian version. But at least I have a chance to debug it on the pc to figure it out.

And I have not heard any reports of big crashes on the last build which is good, since I swapped SDL version, which might cause problems.

User avatar
Noelemahc
Posts: 178
Joined: Sat Jul 07, 2007 2:24 pm

Post by Noelemahc »

This means, I guess, that it's time to re-try running the HE games and CoMI?

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

As for VGA rendering I think its still quite broken, so thats why VGA HE games and COMI games wont work very well. But for other HE games. And well.. even though the screen might be wrong, you still can test of course. :-)

User avatar
Noelemahc
Posts: 178
Joined: Sat Jul 07, 2007 2:24 pm

Post by Noelemahc »

Ohkay, Lure of the Temptress works, Broken Sword 1 is also not recognized as a valid game even though the Win32 ScummVM works from the same files without a hitch. I'm genuinely stumped, as I've thought the datafile checks are handled equally and identically across all platforms.

User avatar
sev
ScummVM Lead
Posts: 2058
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev »

Noelemahc wrote:Ohkay, Lure of the Temptress works, Broken Sword 1 is also not recognized as a valid game even though the Win32 ScummVM works from the same files without a hitch. I'm genuinely stumped, as I've thought the datafile checks are handled equally and identically across all platforms.
No. Each engine could be just not compiled. See list of engines compiled with your port build in the About dialog.

AFAIK, Broken Swords do not run at all, so I suppose Anotherguest just did not complie them to reduce executable size.


Eugene

User avatar
Noelemahc
Posts: 178
Joined: Sat Jul 07, 2007 2:24 pm

Post by Noelemahc »

Golly gee gosh, you're right! Nippon Safes and Broken Sword simply aren't compiled in. Guess I'll have to figure out this SVN thing for myself after all. Thanks for pointing my mistake out, Eugene :)

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

I have done testbuilds with the Broken swords engines before, but never actually tested them, but that was a long time ago.

Also the Symbian build system sometimes have a problem linking all of the engines into one exe, so continue looking forward to separate builds for different engines.

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

Now you can download first 0.12.0 SVN version and first for 2008!

http://anotherguest.k0.se/cvsbuilds/scu ... v3_all.sis

and
http://anotherguest.k0.se/cvsbuilds/scu ... Q3_all.sis

Tested S60v3 version on 6120 and UIQ3 version on W950.
GOB3 scrolls ok on both now even though left scrolling is harder than right scrolling.

S60v3 SDL changes
- Green key to enter/leave control mode
then
- 1 to change input mode
- 2-4 to change screen mode
- up and down to change the global SDL volume

- # with change caps mode when in multitap input mode
- 0 will not conflict while playing AGI games.

Known problems:
- LURE dont update screen properly when interacting with menus and items
- Control mode redraws sometimes leaves the screen blank, even though it should n't

User avatar
Noelemahc
Posts: 178
Joined: Sat Jul 07, 2007 2:24 pm

Post by Noelemahc »

Tested this and I've got to say - it works! The scrolling issue seems to be connected with the positioning of the 'borders' which the cursor has to rub against when scrolling the screen. If you move the cursor to the right, the screen will start scrolling before the cursor reaches the visible edge, but when moving left, the cursor has to go up against the edge directly to get a scroll out. Good thing the keymapper is finally fixed because rapidly tapping whatever you've mapped the "move cursor left" key to makes it scroll a lot faster that rubbing the stylus all over the place :)

I'm gonna set out on finding whether this is completable or not now, as the cutscenes work A-OK.

P.S. English floppy version of Gob3, running on UIQ3/W950 here :)

0AzK0
Posts: 71
Joined: Tue Feb 27, 2007 7:43 am

Post by 0AzK0 »

It works fine. However there are some troubles with scrolling in Gob3 and when I press button of options(of program, not of game) it crashes

Anotherguest
ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest »

The thing is that it will only scroll when having the mousebutton up, so tapping the screen will usually only try to select something. I'm thinking about adding a mouse mode,where pendown/up does not mean left/right button down, perhaps with the inclusion of having keyboard keys for left/right buttons.

Post Reply