Monkey 3 probs on iPAQ rx1900

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
Posts: 5
Joined: Wed May 28, 2008 2:42 pm

Monkey 3 probs on iPAQ rx1900

Post by killerpickle » Wed May 28, 2008 2:48 pm

Hi everyone,

I've been using scumm for the past few years on my laptop and Jornada and finally obtained an iPAQ. I installed the "Windows CE ARM" package that's on the site and it works fine on the iPAQ with The Secret of Monkey Island but when I try to load The Curse of Monkey Island it asks me to map a few keys and after I map them the screen goes black and then back to the Scumm folder. The game works fine on my laptop but for some reason it won't work on my iPAQ. Anyone have any idea about what might be going wrong here? Thanks in advance for any help.


User avatar
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Wed May 28, 2008 3:21 pm

Must be a crash because of low memory (checking out the diagnostic would help). We'll try to fix this before next release.

Posts: 5
Joined: Wed May 28, 2008 2:42 pm

Post by killerpickle » Wed May 28, 2008 3:38 pm

I put all of the files on a 1 gig SD card in the expansion port. I'm not sure how to check the diagnostic, could you point me in the right direction?

Posts: 5
Joined: Wed May 28, 2008 2:42 pm

Post by killerpickle » Thu Jun 12, 2008 1:39 am

Can anyone help me out here? I've been sitting here for about two hours trying to figure out how to enable diagnostics but I can't find the scummvm.ini file. I've been following what the readme said to do

"I'm having problems. Is there diagnostic output available ?

Insert a line in the [scummvm] section of scummvm.ini with the following:
Run ScummVM. When it closes scummvm_stdout.txt and scummvm_stderr.txt files will be
available at the program directory (see section above)."

Not working for me.

Posts: 157
Joined: Fri May 04, 2007 8:42 am

Post by Lostech » Thu Jun 12, 2008 5:50 am

Normally you can not edit the INI file which resides in the same folder like the ScummVM EXE with your PDA itself because the INI file will not be opened with a text editor like notepad if you tap on it. On the other hand does Windows CE/Mobile not show the file extensions in explorer so you will see several files named ScummVM without file extension and it would be difficult to find the right one. Therefore it should be easier to take out the SD card, plug it into a PC and open/modify the ScummVM.ini there.

Posts: 5
Joined: Wed May 28, 2008 2:42 pm

Post by killerpickle » Wed Feb 18, 2009 4:07 pm

Hi again everyone,

I've just reinstalled the most recent version of scumm on my ipaq and tried to get monkey 3 to play but still no luck. I've figured out how to enable the diagnostics (finally!) and this is what it said:

SDL: Version $Rev: 41 $ bootstrapping GAPI device
SDL: Device is portrait, OS version 5.1 build 1702
SDL: orientation 0
SDL: Starting video access detection --->
SDL: System 240x320
SDL: Checking for GAPI
SDL: GAPI OK, 240x320, H=2 V=480, 16bpp, landscape false
SDL: <----- Detection finished. Running on GAPI driver at 240x320 (real 240, 320), using ARM accelerated blitter
WARNING: Language file is forced to be ignored!
WARNING: ImuseDigiSndMgr::prepareSoundFromRMAP: Wrong version of compressed *.bun file, expected 3, but it's 2!
WARNING: Suggested to recompress with latest tool from daily builds!
(2:2003:0xB6): Out of memory while allocating 1966160!
(2:2003:0xB6): Assertion failed pixels (../../../graphics/surface.cpp, 59)!

Using configuration file: scummvm.ini
Sound opened OK, mixing at 22050 Hz
User picked target 'comi' (gameid 'comi')...
Looking for a plugin supporting this gameid... Scumm Engine
Starting 'The Curse of Monkey Island'
Using gameid comi, variant (null), extra
Using MD5 'fe60d6b5ff51b0553ac59963123b5777'
Sound opened OK, mixing at 22050 Hz
(0:1:0x10): DEBUG: room number in boot = 0
(0:1:0x31): DEBUG: sputm-debug = 1
(0:12:0x1D): DEBUG: exit room 1
(0:12:0x1D): DEBUG: exit room 1
(87:119:0x1E): Adding object 100 from room 1 into inventory
(87:12:0x1D): DEBUG: exit room 1

I'm not entirely sure what's going on here (I'm new to all of this), can anyone help me out?

I've tried to recompress the bun file with the tools on the download page but it doesn't seem to be working, any advice? Can anyone tell me what the rest of the errors mean? Thanks in advance and sorry for all of the questions, like I said I'm new to this and I'm trying to learn :D


edit: Thanks Lostech for the pointers on getting diagnostics working.

Posts: 5
Joined: Wed May 28, 2008 2:42 pm

Post by killerpickle » Wed Feb 18, 2009 4:54 pm

I just followed SirDave's guide for compressing the game and now instead of getting the difficulty select menu, I get a screen with the keyboard and some really tiny text that I cannot read. What's going on now? I was able to map my keys and such but no game at all this time.

ScummVM Porter
Posts: 1425
Joined: Sun Oct 30, 2005 2:27 pm
Location: Malmoe, Sweden

Post by Anotherguest » Wed Feb 18, 2009 7:10 pm

Still you had an out of memory situation, and the further you progress in the game, the more memory it will require. Sure compression will help, but complex scenes will also require lots of memory to operate properly.

Is there any good way to see how much free RAM is available in a CE device? Is there any limitations set in the exe it self?

Post Reply