SVN Compile Problems

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

SVN Compile Problems

Post by Lostech »

Since a few days I can not compile a WinCE version anymore.
SVN checkout seems to be OK since the regular Win32 version can be compiled without problems.
For the WinCE version I´m getting these compiler errors:
../../../gui/launcher.h:38: error: expected ',' or '...' before '&' token
../../../gui/launcher.h:38: error: ISO C++ forbids declaration of 'GameDescriptor' with no type
CELauncherDialog.cpp: In member function 'void CELauncherDialog::automaticScanDirectory(const FilesystemNode&)':
CELauncherDialog.cpp:80: error: 'GameList' was not declared in this scope
CELauncherDialog.cpp:80: error: expected `;' before 'candidates'
CELauncherDialog.cpp:82: error: 'candidates' was not declared in this scope
CELauncherDialog.cpp:83: error: 'GameDescriptor' was not declared in this scope
CELauncherDialog.cpp:83: error: expected `;' before 'result'
CELauncherDialog.cpp:84: error: 'result' was not declared in this scope
make: *** [CELauncherDialog.o] Error 1
Should I fill an error report or is this already known?

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin »

I just commited a fix for this (I hope, I can't compile for WinCE myself).

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech »

No problem if you can´t compile yourself the WinCE version.
I just tried a clean compile and now I´m getting this:
CELauncherDialog.cpp: In member function 'void CELauncherDialog::automaticScanDirectory(const FilesystemNode&)':
CELauncherDialog.cpp:80: error: 'EngineMan' was not declared in this scope
make: *** [CELauncherDialog.o] Error 1
Last edited by Lostech on Fri May 16, 2008 1:23 pm, edited 1 time in total.

fingolfin
Retired
Posts: 1466
Joined: Wed Sep 21, 2005 4:12 pm

Post by fingolfin »

Thanks! I commited another fix, which might help. Please tell us if it didn't help or if you get more errors.

Lostech
Posts: 157
Joined: Fri May 04, 2007 8:42 am
Contact:

Post by Lostech »

Yeah, with your new fix it did now compile without any errors. :D

A quick look on my PDA with the new compiled binary shows also that the binary can be started and I think the WinCE port is now OK again.

Thanks for the quick help :)

Post Reply