Problems mapping keys in HP iPAQs (I have an hx4700)

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
Posts: 2
Joined: Thu May 10, 2007 10:03 am

Problems mapping keys in HP iPAQs (I have an hx4700)

Post by g00ey »

I have an iPAQ hx4700 and I'm trying to run ScummVM 0.9.1 on it. It works fine but the problem is that I'm unable to map any keys on it.

This is the very same problem as several other PDA owners have. I'm just posting this thread so as to address this as a general issue at least among the hp iPAQs.

I can only see three different solutions to this:
It should be possible to enhance the key listener routine to listen to these "media key" memory addresses or interrupts or whatever they're called. Perhaps a routine to identify the make and model of the PDA and set up the key listener accordingly. This may be a bit complicated since there are a lot of different PDA with different key configurations. Or maybe not since there may be a standard for these additional media keys. I've seen working PDA games and applications that utilize these keys properly and I didn't see any label saying "custom made for iPAQ" on the package...

Another solution would be to add a set of customizable and mappable keys at the bottom of the screen next to the "Game Menu", "Movie Skip", "Sound mute" and "Map Key" buttons.

The third solution would be to publish a list of key codes to map these keys manually.
User avatar
ScummVM Developer
Posts: 84
Joined: Sat Apr 07, 2007 5:16 pm
Location: Hook Norton, Oxfordshire, UK

Post by robinwatts »

The key handling has been improved in the latest SVN build (of 0.10.1, I believe). Certainly it copes with more keys on my MDA Vario II than 0.9.1 did.

Have you tried the new version? (See the first thread in this forum)

Posts: 2
Joined: Thu May 10, 2007 10:03 am

Post by g00ey »

I suppose you mean build 0.10.0 (2-May-2007). I have now tried it. It works better but not 100%. It can map the 'record' button on the side (identified as application 5) but not the media buttons (the iTask, Messaging, Contacts and Calendar buttons) at the bottom. My guess is that they would be identified as application 1-4 buttons if working properly.
User avatar
ScummVM Porter
Posts: 423
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos »

Your device is injecting spurious and unknown atm keystrokes. Please comment and monitor the following bug: ... tid=418820

I'll prepare a debugging version for you to try (will announce on that bug report).
Posts: 3
Joined: Tue Nov 01, 2005 1:32 pm

Post by groov »

I'm happy to confirm that the latest build lets me map right-click to the record button on the hx4700 so I can play Sam and Max again! ENDLESS JOY, THX! This has been broken since version 0.7.1 or 0.8.0.

As for the hx4700 recording spurious keystrokes, could it have something to do with the touchpad on that device? Look:
User avatar
Posts: 11
Joined: Tue Feb 19, 2008 3:35 am

Post by wichozzz »

l got ipaq too ,when l try to start game "sam and max" ask for map the key..lm click right , multi ,up and not work..
so pls anybody know the secret to start this game on Ipaq
....or also lm install scummvM scummvm-0.10. scummvm-0.11
and always ask me for the(map the key) a
pls help l want play this game
thanks hope here something FW.!!
Post Reply