"Cannot find file: <file name>" on release 0

Subforum for discussion and help with ScummVM's PocketPC/HandheldPC port

Moderator: ScummVM Team

Post Reply
Posts: 7
Joined: Sat Jul 08, 2006 4:38 pm

"Cannot find file: <file name>" on release 0

Post by wohu » Thu Jul 13, 2006 8:12 am

I've already posted this on SirDave's manual thread, but he's right: it's probably better to start a new thread here.

I've got problems with some of the games on the PPC. :?
Some games crash with the message "Cannot find file: <file name>" and leave me with the debugger.
The requested file is always available. Sometimes the bug doesn't occur the next time I start the game (and do exactly the same).
In other situations the VM always crashes with that message.

For example Maniac Mansion (the version that comes with DOTT without any changes) sometimes crashes when I leave the first Screen (looking for 11.LFL) and sometimes it doesent.
However, it definitly crashes, when I enter the house, go to the kitchen and approach Edna.

I tried the same on my Windows-PC running ScummVM and everything works fine.

The same problem occurs on Monkey Island 1 (Dos VGA, modified like described in SirDave's Script - Thanx again for those!!!).
I've tried to move savegames to the game folders guessing that accessing another directory might confuse the VM, but that didn't help.

On the other hand I've just played through DOTT without any problems. 8)

I'm using ScummVM 0.9.0 on a Fujitsu Siemens PocketLoox N560 running MS Windows Mobile 5 at 640*480.

Has anyone experienced the same problems or even found a solution?

By the way: Many thanx for this cool tool. It's a great thing to play my childhood's favourites while I'm on the train. I'm so glad I've kept all those CDs :D

Posts: 7
Joined: Sat Jul 08, 2006 4:38 pm

Post by wohu » Thu Jul 13, 2006 8:16 am

Sorry for the cut off subject. :oops:
The relase is 0.9.0 not 0.

User avatar
ScummVM Porter
Posts: 424
Joined: Wed Nov 02, 2005 2:35 pm
Location: Athens, Greece

Post by knakos » Thu Jul 13, 2006 9:40 am

Can you please try out 0.9.0a and see if you still have these problems? Also please state exactly how we can recreate the fault conditions (especially for the "cannot find file" part).

Posts: 7
Joined: Sat Jul 08, 2006 4:38 pm

Post by wohu » Thu Jul 13, 2006 8:51 pm

Whooops I've been using 0.9.0a all along I've seen in my download directory. It's just the vm itself that is titeled "0.9.0" in the main screen.

Sorry about that - and: no, it doesn't work with 0.9.0a :wink:

Posts: 7
Joined: Sat Jul 08, 2006 4:38 pm

Post by wohu » Thu Jul 13, 2006 9:52 pm

On the topic of reproducability I have to admit that what went seemed to crash reliably yesterday works fine today - and crashes a little later.

Although it probably won't be of much help, here's what crashed yesterday:
Start Maniac Mansion and select the two girls as partners.
Go to the entrance with Dave and "take" the doormat.
Then take the key and use it on the door.
Open the Door next to the clock and enter the kitchen.
Pick up the flashlight and the chainsaw and advance to the right.
Edna will capture you and - would take you to a cell.
When the prison is loading the game exits to debug mode "cannot find file: <don't remember>.lfl".
It's the german version of MM that comes with DOTT.

All I can say about MI1 is, that it crashes rather often. So I've switched to Simon 1, which runs perfect so far.
I had the most errors with MI1 around the circus tent.

Post Reply