New version - OS5

Subforum for discussion and help with ScummVM's Palm port

Moderator: ScummVM Team

Post Reply
User avatar
Posts: 363
Joined: Wed Nov 02, 2005 6:50 am
Location: british columbia, canada

Post by glokidd »

be sure that your card is selected, tap the card icon and set it to your card.
Posts: 1
Joined: Mon Feb 06, 2006 10:42 pm

Post by stark »

I've installed the "2006-01-23 - ARM Test version" on my garmin iQue 3600. When I try to run either of the games I own (monkey island and sam&max) I get the following error message:

pnoARM.c,Line:43,out of memory

I have UDMH installed. the launcher memory info says:
Dynamic: 21713/25439
Storage: 20502/23391
Stack Size: 3

If I run scummvm by deselecting any game and pressing start to get the green and black gui, when I run the game I get a "ScummVM Fatal Error" that reads "Out of memory while allocating 42240"

Both games play if I downgrade to the most recent previous version I could find, 2005-03-21 Test version. Any suggestions?
Posts: 1
Joined: Fri Feb 10, 2006 4:35 pm

Post by Thorongil »

On my TX, it runs awesomely!

But in DOTT, I loose the sound totally after some minutes of playing.

Rather un-cool when running the talkie version :wink:
Posts: 5
Joined: Sat Feb 11, 2006 2:16 am

Trouble getting started on the treo 650

Post by raygundan »

I installed the frontend/skin to my treo 650 via hotsync, and then set up the directories on the SD card as follows:


I put the FOTAQ and Scumm engine files in the Mods directory, and dropped the mi2 and fotaq files into subfolders under games. I set up the games as follows:


Entry Name: monkey island 2
Path: /Palm/Programs/ScummVM/monkey2/
Game: monkey2
Engine: Scumm Games


Entry Name: FOTAQ
Path: /Palm/Programs/ScummVM/Games/FOTAQ_Floppy/
Game: queen
Engine: Flight of the Amazon Queen

I have checked and re-checked the pathnames and the required files (verified against the list at but the games won't start. Monkey Island 2 says "loading databases," then jumps to a white screen that lists the version and says "Loading, Please wait. Memory 4572 KB." Then it dumps back out to PalmOS.

I just got this phone, and haven't ever had scummvm working on it, but others report success-- so it has to be a config issue. Any suggestions?

Also, I haven't been able to find in the documentation or forums what the "game" field is for, or what the value should be.

Thanks for any help, and thanks to the authors and porters for putting this together in the first place!
Posts: 1
Joined: Thu Feb 23, 2006 5:45 pm

Latest ARM version is not working

Post by nosangseo »

I recently discovered ScummVM and I am so excited about the fact that I am able to run classic games on my Palm.

I'm using T|E and tried Monkey1, Monkey2, and Indiana Jones 4 on the latest ARM version of ScummVM.

I am able to start these with good sound support but they crash sooner or later giving a message like 'Memory point to NULL.'

When I go back to ScummVM 0.7.0, they work fine without problem except the fact that I cannot turn the sound on which seriously slows the game play.

Another thing is the D-pad is working in the 0.7.0 version so that I can move the cursor around, but in the latest ARM version, D-pad only moves the cursor up and down...

Thanks for all the hard work to make this happen.

User avatar
Posts: 363
Joined: Wed Nov 02, 2005 6:50 am
Location: british columbia, canada

Post by glokidd »

Hi Crillith, today i decided to go back and check out your latest stable release again. i decided for the hell of it i would try setting the sound quality to medium and rate to 8 KHz and test out the other LA titles i have. They all work Great!!! Music and sound, awesome speed, good sync. I then decided to try these settings with my cd versions, (MICD, zaktowns,loomcd) and discovered that, they too work perfectly, Amazingly in fact. This version is awsome, Chrillth, I have officially upgraded from 0.7.0 . You rock man
User avatar
ScummVM Porter
Posts: 130
Joined: Fri Nov 04, 2005 1:33 pm
Location: France

Post by Chrilith »

The new version is online
Posts: 1
Joined: Thu Mar 09, 2006 3:26 pm
Location: Germany

Post by phil68 »

Hello Chrilith,

thanks for all the hard work and a great job! the 2006-01-23 ARM version works fine on my T|T3.

i have some problems with...
1. full throttle.after the intro i get a "fatal exception",even when ben break out of the container?
2. ...the same with comi.after the intro i get a blackscreen and i must reset the T3?(intro works fine)
3. i cannot save in inherit the earth.i get an error with save file(getSaveFileName wrong idx)
4. ...i`m still waiting for the gobliiins engine. :wink:

sorry for my bad englisch :oops: ...a long time ago
Posts: 5
Joined: Sat Dec 31, 2005 3:07 am

Post by GoDz »

i'm just wondering, will the Zire71 ever be supported in the new ARM version? with or without scummvm.
User avatar
ScummVM Porter
Posts: 130
Joined: Fri Nov 04, 2005 1:33 pm
Location: France

Post by Chrilith »

May work with small games, the problem is the limited memory :( even with UDMH or so (what is important with those is the higher continue chunk)
Posts: 2
Joined: Wed Apr 12, 2006 9:11 am

Post by newtonc »

hi! i know you do have the sony clie nx series on your mind. But i just want to know if there's any progress with them, and any indication that the owners of the best pdas ever will be able to use scummvm for ARM.

Posts: 8
Joined: Sun Dec 18, 2005 7:14 pm

Post by trekkie22 »

phil68 wrote:4. ...i`m still waiting for the gobliiins engine. :wink:
Me too... :wink:
Posts: 9
Joined: Sun Jan 08, 2006 7:21 pm


Post by cartman »


I can't get the soundsand voices to play on my lifedrive. I have the scummvm 0.9.0 and Indy4 works perfectly with voices and all.
Do you have any clue?

Posts: 2
Joined: Wed Apr 12, 2006 9:11 am

Post by newtonc »

does someone has the 0.8.0 version? it's the latest that works on clie, and it's not available on the website :((((

please make it available
Posts: 2
Joined: Wed May 03, 2006 2:56 am

Post by Bleen »

Hi I'm new here...
I've been testing Scummvm on my palm lately.
First, I used the 0.7.1 version, which didn't work at all until I used UDMH. Then it worked nice, bit it was slow, even without sound (with sound it became unplayable).
For me, 50% of these games is the sound, so I downloaded the last ARM version after reading it was fast here in the forums. (0.9.0CVS, Jan 13 2006)
Installed it, used UDMH, and didn't work (memory error).
So I searched some more and found Fargo, which I installed and run.
THEN, the games (Monkey Island 2 and Indiana Jones and the Fate of Atlantis) worked... well, "worked"... because they both load, start playing the sound at very good framerate!... and after a couple of seconds, give me this error:

Monkey2 starts, I pass the copy protection, I select the game mode (easy, hard), and then: Fatal Alert MemoryMgr.c,Line:2757,MemMove to NULL

Atlantis gives the same error, as soon as the LucasArts logo wipes out :-(
This happens with and without sound enabled.

I'm floored, since performance seemed excellent (very playable, with SOUND!)... I sure hope you can fix this :-)

Anyone here with T2? Similar problems? fixes?

And thanks a lot for porting ScummVM for palm!
Post Reply