ScummVM 0.11.0svn PalmOS Port Feedback Thread

Subforum for discussion and help with ScummVM's Palm port

Moderator: ScummVM Team

Post Reply
Runesr
Posts: 8
Joined: Tue Aug 21, 2007 11:19 pm
Location: Copenhagen, Denmark

ScummVM 0.11.0svn PalmOS Port Feedback Thread

Post by Runesr » Mon Sep 03, 2007 2:36 pm

The following are experiences using Tungsten T5 and the ScummVM 0.11.0svn PalmOS Port

I just tested the new 0.11 port, but it seems that it is a bit worse than 0.10. By pressing the hardware "Home" button on my Tungsten T5 that enables widescreen (full screen) in 0.9.1, the picture does try to activate full screen, but the image does not stretch and just adds black bars to the top and bottom of the screen (like watching a 16:10 movie on a 4:3 display - but the image is still 320x200 pixels). Like the 0.10 port everything locks up and I have to do a hard reset (or hold down the 5-way navigator hardware button to do a soft reset).

Since all buttons worked perfectly in the 0.9.1 release, would it be possible to revert to that configuration, but still keep other advantages of the 0.11 port?

But there is a bit more to it - on the T5, when you activate the keyboard display (without activating full screen), you get access to the status bar. The status bar has software buttons for "Home", "Find", "Menu", "System info" etc. These buttons work, and "Home" works as pressing the esc button on a PC keyboard, while "Menu" activates the in game menu (letting me load a saved game). So this way the 0.11 port can work - but there is no wide-screen.
Below these software buttons the Tungsten T5 has hardware buttons for "Home", "Calendar", "Contacts" and "Files", but none of these work in the 0.11 ScummVM PalmOS port. Using the 0.9.1 these button worked perfectly, and pressing "Home" would (de-)activate wide-screen, "Calendar" worked as esc, "Contacts" activated the in-game menu and the 5-way navigator worked as a PC mouse.

Also sound FX worked fine, but I could not get the music to work in 0.11 (again both music and sound FX worked fine in 0.9.1).

I will gladly pay 5 euros to Chrilith, if for example Day of the Tentacle and Sam'n Max one day work in wide-screen without crashing, and I hope that many other will do the same (actually I would be happy just to get the 0.9.1 mods fixed so that several games from LucasArts do not crash in cases of vertical scrolling etc.).

I did like that the 0.11 port had the opportunity to disable autosaves.

Doing such a port must demand a lot of time and I am grateful that Chrilith keeps releasing new versions - also there are many different models from Palm, so my experiences with Tungsten T5 may differ from experiences using other models.

The 0.11.0svn and other ScummVM PalmOS ports can be downloaded here:

http://capers.free.fr/en/download.php?g=ScVM

So the situation in a nutshell:

0.11 - vertical scrolling does work and for example Day of the Tentacle no longer crashes. Wide-screen does not work and pressing the "Home" hardware button causes a severe error - making a reset the only option for quitting ScummVM. Music did not work, but Sound FX worked. Many games are supported.

0.9.1. - vertical scrolling does not work and for example Day of the Tentacle among other LucasArts games crashes horribly in some scenes making it impossible to finish these games. Wide-screen works perfectly. All hardware buttons work perfectly. Both sound FX and music work (at least in the 8 games I have tested). Only few games are supported in the 0.9.1 release compared to 0.11.

Madmanguruman
Posts: 5
Joined: Wed Oct 03, 2007 6:16 pm

Post by Madmanguruman » Thu Oct 04, 2007 2:11 pm

I'm trying this version (to see if my LSL1 save problem is still there) and have found that I cannot use the virtual keyboard, or the normal 'slash' motion, to send ENTER to the game. LSL1 is unplayable without ENTER working...

Madmanguruman
Posts: 5
Joined: Wed Oct 03, 2007 6:16 pm

Post by Madmanguruman » Fri Oct 05, 2007 3:47 pm

Further to my ENTER problem: in the log file, I noticed the following differences ENTER was pressed...

0.10.0:
cancel.line

0.11.0svn:
event AC:12 occured

Does this help?

User avatar
thatgui
Posts: 47
Joined: Sun Sep 24, 2006 9:49 pm

Post by thatgui » Mon Oct 08, 2007 5:12 am

Platform : Tapwave Zodiac 2 (last hard reset ~2 months ago, not much installed yet)
ScummVM Version: 0.11.0svn (2007-09-01)

lsl1:
Fatal exception after engine started (sometimes i can see the welcome screen of lsl1) tried both ways (configured profile in launcher and "direct" mode) also tried to play around with the settings, with no effect

gob2:
works great !! unfortunately i can't test gob3 (i need to get a copy from ebay)

Baphomets Fluch (can't remember the English title right now)
Support seems somewhat broken, i can't start it normally any more, a fatal exception is always thrown as soon as the new/load/exit screen appears. But i can still play it, if i set the game profile to auto load a previously saved game.

that all so far

Alexander
Posts: 4
Joined: Mon Oct 15, 2007 2:34 pm
Location: Russia, Moscow

Post by Alexander » Mon Oct 22, 2007 9:05 am

Platfrom: Lifedrive, Palm OS Garnet 5.4.8.

I tried several games. Some proved to be unstable causing ScummVM to crash and reboot the Palm with error report "Fatal Exception in <unknown application>".

After 2-3 crashes on avg. ScummVM refuses to start again and says "Cannot open/create games list DB". See another topic on this problem: viewtopic.php?t=4608. This can be cured by backup-secure erase-restore.

Experiments proved the following games to be stable :
- Beneath a Steel Sky
- Simon the Sorcerer (part 1, but not part 2)
- Day of the Tentacle
- Monkey Island 2
- Sam & Max Hit the Road

I was unable to crash any of them so far.

Thanks.

User avatar
Isdaron
Posts: 4
Joined: Sun Oct 28, 2007 2:26 pm

Post by Isdaron » Sun Oct 28, 2007 4:32 pm

thatgui wrote: Baphomets Fluch (can't remember the English title rightnow)
Just for the sake of completeness: it's "Broken Sword".

Best, Bjoern

Post Reply