Keypad controls are here

Subforum for discussion and help with ScummVM's PSP (PlayStation Portable) port

Moderator: ScummVM Team

Post Reply
Bluddy
ScummVM Developer
Posts: 139
Joined: Sun Nov 18, 2007 8:43 am

Keypad controls are here

Post by Bluddy » Fri Jan 01, 2010 2:12 pm

Hey guys, just to let you know that I've finally gotten around to adding the keypad controls to the D-Pad. This means SCI0 and AGI games are perfectly playable, as is the fighting in Indy3 and Indy4. Also, you can choose your game in the GUI using up and down. Don't forget that triangle is enter (except in virtual keyboard mode, when start is enter).

On the (minor) downside, the d-pad can't be used for fine movement of the mouse anymore. Just as a reminder, that functionality is still available by holding down the right trigger while moving the nub.

User avatar
JonWW
Posts: 29
Joined: Wed Feb 14, 2007 10:22 pm

Post by JonWW » Fri Jan 01, 2010 3:01 pm

What buttons are for left and right mouse buttons? I'm in the Save game menu of an AGI game and I'm not able to press X to "click" on Cancel. It just tells me that the Autosave slot is for Autosave only when [ 0. Autosave ] is highlighted. Other than this issue I love what you have done I've been waiting a long time for this.

EDIT: It seems that the "mouse button (X)" is acting like the "Enter key (triangle)" in the Save and Restore game menus for the AGI engine. X seems to be working correctly in all other areas. If you accidentally enter the Save menu you can press ESC (Left shoulder button) to exit the menu. I'll check further and report this to the bug tracker.

Bluddy
ScummVM Developer
Posts: 139
Joined: Sun Nov 18, 2007 8:43 am

Post by Bluddy » Sat Jan 02, 2010 4:59 pm

Yeah this is an AGI engine issue. The buttons in the save/load dialog can't be clicked. You have to use enter to save or escape to exit the menu.

User avatar
JonWW
Posts: 29
Joined: Wed Feb 14, 2007 10:22 pm

Post by JonWW » Sat Jan 02, 2010 5:09 pm

Great timing Bluddy I was just checking on a daily Windows build to see if it's a PSP port issue or within the AGI engine.

Post Reply