Scummvm 0.13 coming to psp?

Subforum for discussion and help with ScummVM's PSP (PlayStation Portable) port

Moderator: ScummVM Team

Post Reply
Pix2
Posts: 100
Joined: Sat Apr 05, 2008 12:02 pm
Contact:

Post by Pix2 »

7th guest doesn't work too well yet as I mentioned in an earlier post. Its nearly ok - its just moving the cursor around thats the real problem. I've added Bud Tucker to the build and uploaded again - this is one I don't own so I can't tell you how it runs.
jvprat
ScummVM Developer
Posts: 76
Joined: Mon Oct 30, 2006 9:10 pm

Post by jvprat »

In The 7th Guest, is moving the cursor the only really slow thing? i.e. once you reach the hotspot you want to click and you say you want to go there, is the video played smoothly? Do the introduction play correctly? (without audio stuttering)
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

Pix2 wrote:7th guest doesn't work too well yet as I mentioned in an earlier post. Its nearly ok - its just moving the cursor around thats the real problem. I've added Bud Tucker to the build and uploaded again - this is one I don't own so I can't tell you how it runs.
Thank you Pix.

Too bad my disc is scratched... I am going to try the toothpaste trick tommorow and check on DW1/DW2 (whether it improved in the newest build).

Cheers and Merry Christmas everyone!
Pix2
Posts: 100
Joined: Sat Apr 05, 2008 12:02 pm
Contact:

Post by Pix2 »

jvprat wrote:In The 7th Guest, is moving the cursor the only really slow thing? i.e. once you reach the hotspot you want to click and you say you want to go there, is the video played smoothly? Do the introduction play correctly? (without audio stuttering)
I've had different results depending on firmware. On 3.9 M33 it ran near enough full speed with slight audio stuttering. I've upgraded to 5.0 since and its half the speed. I might try downgrading again some time but there doesn't seem to be much point playing around with it much until I can move the cursor around.
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

Pix2 wrote:
jvprat wrote:In The 7th Guest, is moving the cursor the only really slow thing? i.e. once you reach the hotspot you want to click and you say you want to go there, is the video played smoothly? Do the introduction play correctly? (without audio stuttering)
I've had different results depending on firmware. On 3.9 M33 it ran near enough full speed with slight audio stuttering. I've upgraded to 5.0 since and its half the speed. I might try downgrading again some time but there doesn't seem to be much point playing around with it much until I can move the cursor around.
Pix, could be an issue with the card reading driver which was changed in newer firmwares?

Perform the fatmsmod:

1) for the flasher: http://www.dark-alex.org/
2) for the PRX: http://rapidshare.com/files/157184085/f ... rx_371.rar

Should work just as it did before you updated.


So, I checked Discworld with your newest build and this time it seems to crash at the very beginning, right after the PSYGNOSIS logo!

Oh, and my original, Polish copy of BUDD TUCKER doesn't work at all...

The CD is physically cracked in one place... Damn.
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

So, in the recent days, I've been looking very, very hard to track down the original, Polish version of Budd Tucker (nostalgia time!) to replace my old, cracked one.

Damn I loved that game back when I was in primary.

Now that the Discworld musical enh. by James Woodcock is finally complete, I can't freaking wait till 0.13 goes official.


Wonder why there were so many problems with those SVN builds we tried.
Can you be arsed to compile the newest SVN source yet again, Pix? :3


Don't bother if it's a tiresome or boring procedure since it's still most likely bugged. I appreciate what you've already done. Simon the Sorcerer and Kyrandia have never sounded better to me!

Just wanted to post in that thread since I can feel that desired 0.13 lurking around the corner.



I keep that Discworld waiting for a PSP playthrough, heh.
Pix2
Posts: 100
Joined: Sat Apr 05, 2008 12:02 pm
Contact:

Post by Pix2 »

I've compiled it and put it in the usual place.

I think the problems I was having with my new firmware and T7G were to do with having to use the 1.0 single eboot rather than the 1.5 kxploit version. The 1.0 was running at 222Mhz which I've fixed now. 7th guest is back to running at about 80% speed + the dodgy cursor is still there.

The good news is I've just had a quick go at Discworld and its looking like its all working but I've not tested it properly yet. I think the music has all been mapped in as well but there will be tracks missing until version 2 of the soundtrack is released. You can get into the save screen now using the start button, pressing L from here will bring up the main menu with the load game option and it saves and loads ok for me.

I've had to remove the Kyrandia games from this build so stick with version 12 if you want to play them for now.
User avatar
md5
ScummVM Developer
Posts: 2250
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

Jinx1337 wrote:Now that the Discworld musical enh. by James Woodcock is finally complete, I can't freaking wait till 0.13 goes official
Discworld won't be supported in the 0.13.0 version. We're still waiting on its freeware status
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

md5 wrote:
Jinx1337 wrote:Now that the Discworld musical enh. by James Woodcock is finally complete, I can't freaking wait till 0.13 goes official
Discworld won't be supported in the 0.13.0 version. We're still waiting on its freeware status
Why's that?

The source has been obtained legally, wasn't it?


I tried Discworld on that build you compiled Pix, thanks a bunch!
It doesn't crash anymore and is fully playable!

Just two minor things:

1) There's no main menu when you press "start", I still get the "save menu". To access the game's main menu one must push select for the gui keyboard and find the "`" symbol.

2) It's kind of slow in places with other animated sprites.
Music doesn't slow down, the cursor and Rincewind does. A lot. Even in 333 Mhz. I guess Tinsel still needs its fair share of optimization in ScummVM.

But hey, it's perfectly playable!

Thanks Pix.

Now, if only I could find that original, Bud Tucker: Double Trouble PL CD I so much desire...

edit:

Seems like the enhanced tracks aren't mapped in yet.
Not a single OGG file could be heard in the Unseen University so far. I even tried choosing the DIGITAL AUDIO REPLACEMENT hack of yours, heh. Too bad...
Pix2
Posts: 100
Joined: Sat Apr 05, 2008 12:02 pm
Contact:

Post by Pix2 »

You have to press L from the save screen to get to the main menu.

I probably should have mentioned that to get the music to work you need to rename all the music files - 22.ogg to track22.ogg etc so that the CD Audio player picks them up.
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

Pix2 wrote:You have to press L from the save screen to get to the main menu.

I probably should have mentioned that to get the music to work you need to rename all the music files - 22.ogg to track22.ogg etc so that the CD Audio player picks them up.
Ah, I overlooked that!

Thanks for the tip, I'm off to test it some more. So far the game hasn't crashed at me once!

It's just the slowdowns which are irritating a bit.
They also happen in a weird fashion. If there's lots of movement on the screen, the game slows down. But if you go to the edge of a "two-screen" location and cause the screen to scroll to the other half of area, the slowdowns dissapear for the time of scrolling (yet the animations don't stop).

But like I said - annoying but definately not game-breaking.
We get to enjoy Discworld on the run!

I'll report back on how the OGGs work and maybe check Discworld 2.
User avatar
md5
ScummVM Developer
Posts: 2250
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

Jinx1337 wrote:
md5 wrote:
Jinx1337 wrote:Now that the Discworld musical enh. by James Woodcock is finally complete, I can't freaking wait till 0.13 goes official
Discworld won't be supported in the 0.13.0 version. We're still waiting on its freeware status
Why's that?

The source has been obtained legally, wasn't it?
It's not related to the code itself. Yes, the code has been obtained legally, and no, it won't be announced/supported until we know about the actual licensing state of the game (i.e. if it'll be made freeware by its copyright holders). So the plan is to announce the game when these matters are solved. Plus, the engine itself still has some endianess issues, which mean that the games can't be played on big endian systems yet (e.g. older Macs with PowerPC processor, the Nintendo Wii etc)
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

md5 wrote:It's not related to the code itself. Yes, the code has been obtained legally, and no, it won't be announced/supported until we know about the actual licensing state of the game (i.e. if it'll be made freeware by its copyright holders). So the plan is to announce the game when these matters are solved. Plus, the engine itself still has some endianess issues, which mean that the games can't be played on big endian systems yet (e.g. older Macs with PowerPC processor, the Nintendo Wii etc)
Understood, thanks for explaining.

So I tried the game with the enh. soundtrack (after renaming the files) and yeah - it works pretty well!

Ill check Discworld 2 later on.
Tithe AD
Posts: 12
Joined: Wed Dec 10, 2008 12:37 am

Post by Tithe AD »

Thx for this new build no crashes to report on discworld.But,atlough i can now access the save and load menus i still cant seem to be able to save.No matter what button i use on the green tick on the save screen,nothing happens apart from taking me back into game:/

Have i missed something here?When i check the load files there are no save files to select.:(
Help me please.:D
Jinx1337
Posts: 144
Joined: Fri Jun 29, 2007 9:43 am

Post by Jinx1337 »

Tithe AD wrote:Thx for this new build no crashes to report on discworld.But,atlough i can now access the save and load menus i still cant seem to be able to save.No matter what button i use on the green tick on the save screen,nothing happens apart from taking me back into game:/

Have i missed something here?When i check the load files there are no save files to select.:(
Help me please.:D
You have to give the save file a name (use the OSK keyboard by pressing SELECT).

You can't just leave it blank.


If that doesn't work, try setting the savegame path in ScummVM's options.
Post Reply