How to compile for 1.0 or 1.5 or 2.0 from CVS ?

Subforum for discussion and help with ScummVM's PSP (PlayStation Portable) port

Moderator: ScummVM Team

Post Reply
dem1980
Posts: 7
Joined: Fri Dec 16, 2005 5:14 pm

How to compile for 1.0 or 1.5 or 2.0 from CVS ?

Post by dem1980 »

hello

i m compiling the new version of the psp port of scummvm
but i have a psp 2.0 and the 1.0 or 1.5 doesn t worked on it
i have download the cvs tree and i want to compile my version of scummvm
i had looked at cvs directories but i haven t seen the difference for compiling 1.0 or 1.5 or 2.0 version

could you give me the way to build 1.0 or 1.5 or 2.0 ?
how can i compile the good version ?

than kyou

User avatar
sev
ScummVM Lead
Posts: 2050
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev »

README in backends/psp states:
When you've installed these libraries (read their README.PSP for instructions),
type "make" in the backends/psp directory to build an 1.00 firmware EBOOT.PBP,
or "make kxploit" to build the 1.50/kxploit EBOOT.PBPs
Also there is USERSPACE_ONLY define which AFAIK makes build 2.0-compatible, but I may be wrong here, joostp will correct me.


Eugene

User avatar
joostp
ScummVM Developer
Posts: 490
Joined: Wed Sep 21, 2005 3:55 pm

Post by joostp »

What sev said :P

Post Reply