7th guest

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
fab@50
Posts: 4
Joined: Sun Jan 23, 2011 9:08 pm

7th guest

Post by fab@50 »

I'm trying to play t7g and have copied all the files, except audio which i don't care about. when i try to start the game i get a message "looking for a plugin supporting this game... Groovie engine and then intro.gjd not found" but i copied all files
User avatar
clone2727
Retired
Posts: 1611
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Re: 7th guest

Post by clone2727 »

fab@50 wrote:I'm trying to play t7g and have copied all the files, except audio which i don't care about. when i try to start the game i get a message "looking for a plugin supporting this game... Groovie engine and then intro.gjd not found" but i copied all files
I'm just going to throw this stupid question out there: Do you have intro.gjd in that folder you copied all the files to?
fab@50
Posts: 4
Joined: Sun Jan 23, 2011 9:08 pm

Post by fab@50 »

yep, double checked
User avatar
clone2727
Retired
Posts: 1611
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Post by clone2727 »

fab@50 wrote:yep, double checked
Could you post the whole folder contents?
fab@50
Posts: 4
Joined: Sun Jan 23, 2011 9:08 pm

Post by fab@50 »

I've already deleted it and thought I'd try the whole thing again at some other time - got too frustrated- but thanks for your help
jazzpaintball
Posts: 2
Joined: Thu Jan 27, 2011 2:52 am

T7G Save

Post by jazzpaintball »

I am not trying to steal this thread, but I would hate to make a new one for the same game this high on the thread list.

I can not get the game to save. The game save system works as long as you dont close the game (pointless at that point) and I can not find anything else in the read me about saving the game. F5 does not work, I have tried that reading some other posts.

Any info would be great,
Travis Walthall
User avatar
eriktorbjorn
ScummVM Developer
Posts: 3378
Joined: Mon Oct 31, 2005 7:39 am

Re: T7G Save

Post by eriktorbjorn »

jazzpaintball wrote: I can not get the game to save. The game save system works as long as you dont close the game (pointless at that point) and I can not find anything else in the read me about saving the game.
I'm not sure if I understand you correctly... By the "game save system", do you mean the menu you get when clicking at the top of the screen, where the cursor turns into a pyramid, or do you mean something else? (That menu seems to work fine for me, and I can return to the game afterwards.)
jazzpaintball
Posts: 2
Joined: Thu Jan 27, 2011 2:52 am

Post by jazzpaintball »

Yes, the game's menu (top of the screen/ouiji board). I had saved the game a couple times in my first run of the game (5 or 6 puzzles done), and the save worked. Although once running the game again today, it came up the main menu and it would not allow a continued game for it did not find any saves. Any advice? I would not mind using a 3rd party saving system (like SNES emulators number system) if it will work.

Thank you for your time,
Travis Walthall
User avatar
eriktorbjorn
ScummVM Developer
Posts: 3378
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

jazzpaintball wrote:Although once running the game again today, it came up the main menu and it would not allow a continued game for it did not find any saves. Any advice?
I'm afraid I don't know, then. I haven't played around much with The 7th Guest in ScummVM. Let's hope someone else has some idea.
User avatar
envisaged0ne
Posts: 159
Joined: Mon Nov 01, 2010 9:17 am
Location: United States

Post by envisaged0ne »

I've had this happen too. I will save a game and later it no longer showed up. So I had to start the game from scratch. Dunno what caused it.
User avatar
LordHoto
ScummVM Developer
Posts: 1029
Joined: Sun Oct 30, 2005 3:58 pm
Location: Germany

Post by LordHoto »

envisaged0ne wrote:I've had this happen too. I will save a game and later it no longer showed up. So I had to start the game from scratch. Dunno what caused it.
And you were able to load it successfully in the same run you saved the game?

Savegames "disappearing" is usually because either people readd the game to ScummVM, which might result in the game entry getting a different target id, which most engines use for the savegame filenames, so then ScummVM would not find any saves anymore.

Another possible problem might be that the save path is not writable and I am not sure whether Groovie shows an error in the GUI in this case. You might want to check the terminal output when saving for any warnings about that. (Of course if you can still load the saves in the same run, this should not really happen).

And last but not least it might be that you did not setup any save path and depending on the system you are running ScummVM on it might result in the saves getting written in the executable path or current working directory thus if you change that in the next run the saves are not accessible by ScummVM anymore.
User avatar
envisaged0ne
Posts: 159
Joined: Mon Nov 01, 2010 9:17 am
Location: United States

Post by envisaged0ne »

I have ScummVM saved on my H:\ drive (H:\ScummVM). Using Windows 7. The save files are saved under H:\ScummVM\SAVES. And I have ScummVM pointing to that directory in the GUI options. I've made sure that it allows me to write to that directory without any problem.

I have several games that I've saved/restored from that path without any problem. Even after updating to the latest daily builds. But a couple times Ive noticed that the saved games just disappear for The 7th Guest. Haven't seen it happen lately, but I have seen it in the past. Well, like 2 weeks ago was the last time I noticed it happen.
fab@50
Posts: 4
Joined: Sun Jan 23, 2011 9:08 pm

Post by fab@50 »

I've been successfully playing the 7th guest, everything works until I try to enter the secret passage after the coin puzzle, I think to the altar room. Message comes up that console is ready Error: Groovie: Resource: couldn't open ch+rl. Any suggestions? Thanks
User avatar
ScottT
ScummVM Developer
Posts: 30
Joined: Fri Nov 28, 2008 12:08 pm
Location: .au

Post by ScottT »

Sounds like ch.rl is missing - double-check that you copied it off the game discs.
Post Reply