Kings Quest VI Problems W/Video

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
HappehLemons
Posts: 22
Joined: Sat Sep 11, 2010 9:29 am

Kings Quest VI Problems W/Video

Post by HappehLemons »

Examples of everything mentioned here is within this video I made to go along with this post.
http://www.youtube.com/watch?v=eOaNJihsdI0

1) The Windows version and the DOS version play the same music, where the Windows version should play the (or at least be given an option to pick) "extended level midi" that was exclusive to the Windows version of the game.

2) Some instruments in the background music are not loading up upon entering a new area with music. This is most clearly seen when entering the area with the shops at the beginning of the game. There should always be a tambourine playing in the background music in that area but it will only load up sometimes. (Quickly exiting and reentering the area will trigger it to play, but it always be playing and this should not be necessary)

3) When skipping dialog in the Windows mode Character portraits will just hang with there mouths open for a few seconds.
Although it's normal for the portraits to stay up for a second after a dialog scene is skipped the mouths should close immediately when the dialog stops and not just hang open.

That's all for now :)
User avatar
md5
ScummVM Developer
Posts: 2250
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

http://forums.scummvm.org/viewtopic.php?t=17
3a) Do not post bugreports here. See the FAQ answer on how to report bugs properly. The appropriate place for those is the Bug Tracker. Same goes for Feature Requests.
1) I can't find any alternate music tracks in the data files of the Windows version of KQ6 (like there are in KQ5), so I have no clue how the enhanced MIDI tracks were handled there. Please file this as a bug report/feature request, so that it won't be forgotten.

2) The missing instruments are a known problem with the music code, already filed in as a bug:
http://sourceforge.net/tracker/?func=de ... tid=418820
I've added your video to that bug report, thanks!

3) The "hanging mouths" problem in the Windows version of KQ6 has been fixed in the latest SVN version (rev 54983). Thanks for reporting this, but please use our bug tracker for reporting bugs in the future :)
User avatar
Red_Breast
Posts: 770
Joined: Tue Sep 30, 2008 10:33 pm
Location: The Bar Of Gold, Upper Swandam Lane.

Post by Red_Breast »

Happeh-
I would hope that when / if these problems are fixed you will point it out in the Youtube comments. Personally it's not the way I would of handled it. I would of sent the video to the team.
HappehLemons
Posts: 22
Joined: Sat Sep 11, 2010 9:29 am

Post by HappehLemons »

This was me sending the video to the team.
I don't know much about ScummVM so I'd have no clue who to personally email this to.

I plan to remove the video in a little while, I just wanted to get these problems out there with examples and I figured the best way to do this was to make a video showing the problems, I didn't do this to bash scummvm in any way.

Even though now I know I should of posted this on the bug tracker I'm happy with the responses md5 gave me and I'm glad to see things have already been fixed/currently being worked on.
waltervn
ScummVM Developer
Posts: 18
Joined: Mon Apr 14, 2008 12:02 am

Re: Kings Quest VI Problems W/Video

Post by waltervn »

HappehLemons wrote:1) The Windows version and the DOS version play the same music, where the Windows version should play the (or at least be given an option to pick) "extended level midi" that was exclusive to the Windows version of the game.
"Extended level MIDI" is less capable than General MIDI. I don't know how the Windows version of KQ6 handles the music, but mimicking this MIDI output is not a priority.
Post Reply