Shortcut keys in SCI0 games

Ask for help with ScummVM problems

Moderator: ScummVM Team

Sven
Posts: 25
Joined: Tue Nov 16, 2010 2:46 pm

Shortcut keys in SCI0 games

Post by Sven »

I'm trying to play some old SCI0 games like the King's Quest 1 SCI remake and King's Quest IV in ScummVM 1.2. I love that these games are now supported, and I especially love the undithering feature, it especially makes KQ1SCI look much better (because there's hardly any colour in that game that's not dithered).

However, none of the shortcut keys work. F3 for retype, F5 for save, F7 for restore, +/- to change the speed, etc. Nothing works. I can use these features from the menu just fine, but especially lacking F3 is very annoying.

Is there something wrong on my end, or is this a bug?
User avatar
Raziel
ScummVM Porter
Posts: 1360
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Post by Raziel »

You are holding a lot of essential information back

Platform?
OS?

Have you tried recopying the data files from your media?
Some of these strange behaviour are triggered by faulty data
Collector
Posts: 549
Joined: Sun Oct 30, 2005 6:58 pm
Contact:

Post by Collector »

I can confirm this on Win7 x64 with ScummVM 1.2.0. I have just tried it on several different SCI0 games. I never used most of the keys myself, but the F3 not working is the one most sorely missed.
User avatar
Raziel
ScummVM Porter
Posts: 1360
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Post by Raziel »

Using a 1.3svn build here and all is fine :-?

Maybe its a regression which sneeked in the 1.2 build and has since been fixed?
User avatar
envisaged0ne
Posts: 159
Joined: Mon Nov 01, 2010 9:17 am
Location: United States

Post by envisaged0ne »

I'm using daily build 1.3 svn54236 and the function keys work fine for me. However, the + & - keys to increase or decrease speed don't work. Using Win7 Ultimate 32 bit
User avatar
Raziel
ScummVM Porter
Posts: 1360
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Post by Raziel »

Affirmative

+ and - doesn't do anything

AmigaOS4
Collector
Posts: 549
Joined: Sun Oct 30, 2005 6:58 pm
Contact:

Post by Collector »

Just tried today's SVN build (1.3.0svn54272) and they still didn't work. Just to be sure that there wasn't something odd going on with my config file, I deleted the scummvm.ini to generate a new one. Still nothing from the F keys. Just so you know, I am not using 64-bit builds and the games are clean copies with no NRS patches.
User avatar
MusicallyInspired
Posts: 1076
Joined: Fri Mar 02, 2007 8:03 am
Location: Manitoba, Canada
Contact:

Post by MusicallyInspired »

I ran into this a lot. CTRL+KEY shortcuts don't work either. The problem is you have to disable numlock. Then all the shortcut keys work. But the numpad keys (+, -, etc) still don't work which is annoying.
Collector
Posts: 549
Joined: Sun Oct 30, 2005 6:58 pm
Contact:

Post by Collector »

Turning off the Num lock did make the F keys work, but it would be nice if it worked either way.
Sven
Posts: 25
Joined: Tue Nov 16, 2010 2:46 pm

Post by Sven »

Sorry for the incomplete information. For future reference, I was using Windows 7 Professional x64.

I can confirm that turning off numlock got me the F-keys back like other people have said. Thanks for the help, everyone. :)
User avatar
md5
ScummVM Developer
Posts: 2250
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

This has been fixed now in the latest daily version. Function keys should work correctly regardless of the state of the num lock key
Collector
Posts: 549
Joined: Sun Oct 30, 2005 6:58 pm
Contact:

Post by Collector »

md5 wrote:This has been fixed now in the latest daily version. Function keys should work correctly regardless of the state of the num lock key
Great
Sven
Posts: 25
Joined: Tue Nov 16, 2010 2:46 pm

Post by Sven »

md5 wrote:This has been fixed now in the latest daily version. Function keys should work correctly regardless of the state of the num lock key
That's great news. Does that include the +/- keys (which currently don't work at all regardless of the num lock key)?
User avatar
md5
ScummVM Developer
Posts: 2250
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

Sven wrote:
md5 wrote:This has been fixed now in the latest daily version. Function keys should work correctly regardless of the state of the num lock key
That's great news. Does that include the +/- keys (which currently don't work at all regardless of the num lock key)?
That includes the F1-F10 keys, I didn't know about the +/- keys, will check them out too. For bugs like this, it's best to file a bug report instead of posting in the forums, as bugs listed in the forums tend to get forgotten, plus not all devs visit the forums:
http://www.scummvm.org/faq/#question.report-bugs
User avatar
md5
ScummVM Developer
Posts: 2250
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 »

These keys should now work in the daily build
Post Reply