Problem with fullscreen

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Lag
Posts: 8
Joined: Fri Nov 30, 2007 7:07 pm

Problem with fullscreen

Post by Lag » Tue Mar 23, 2010 5:32 pm

Hello,

I've just download ScummVM latest version and launched it on my new computer (OS is Windows 7 Family Premium Edition) and when I turn the fullscreen setting on, all I get is a black screen, with no possibility to take over with alt-enter, ctrl-alt-del, alt-F4, alt-tab.

I've got the problem when launching directly with fullscreen enabled, and when lauching windowed mode and enable fullscreen with alt-enter. Either with default render, 2x or 3x.

Does anyone have a hint on what I could do? Thanks.

User avatar
bobdevis
Posts: 563
Joined: Fri Jan 16, 2009 10:52 am

Post by bobdevis » Tue Mar 23, 2010 7:26 pm

First and foremost, update your video card driver. Get the newest driver from the manufacturers website.

Secondly, if you still have the problem then there are 2 places you can fiddle with settings.
- The video card driver settings in the Control Panel
- The monitor settings with the buttons on your monitor.
The goal of the fiddling is to make it so that resolutions that are unsupported are displayed smaller and with black borders around them.

I can't help you further because;
- You haven't told us what your video card and monitor are.
- I most probably don't have the same hardware so I can't tell you exactly what button to push.

Good luck.

Lag
Posts: 8
Joined: Fri Nov 30, 2007 7:07 pm

Post by Lag » Sat Mar 27, 2010 8:08 pm

Sorry for the lack of information.
My video card is NVIDIA GeForce GT 220 and my monitor is HP v216.
OS is Windows 7 64-bit by the way.
Resolution displayed is 1680x1050, but it used to work fine with my former computer.
I've downloaded update for my video card driver, I hope it will solve the problem.

Lag
Posts: 8
Joined: Fri Nov 30, 2007 7:07 pm

Post by Lag » Sat Mar 27, 2010 9:52 pm

Well, the problem still happens even though the driver has been updated :(

User avatar
bobdevis
Posts: 563
Joined: Fri Jan 16, 2009 10:52 am

Post by bobdevis » Sun Mar 28, 2010 12:31 am

So you are using Win7 with a proper video driver and running ScummVM fullscreen causes a state you can't break out of with ctrl-alt-del?
That is some serious trouble I have no idea how to fix.

Anyway, how fullscreen works in ScummVM is the responsibility of libSDL, the toolset that ScummVM is build on. Right now, with libSDL 1.2, fullscreen sucks. Their forum is full with related issues and it doesn't work right on my 2-screen setup either.
Supposedly libSDL 1.3 has the fullscreen logic completely rewritten but it will take a while before 1.3 is done and before ScummVM will start to use it.

Lag
Posts: 8
Joined: Fri Nov 30, 2007 7:07 pm

Post by Lag » Sun Mar 28, 2010 7:01 pm

bobdevis wrote:So you are using Win7 with a proper video driver and running ScummVM fullscreen causes a state you can't break out of with ctrl-alt-del?
Yes, that's it. Hard reboot is the only way to get unstuck.

It's quite weird, since the same version of ScummVM used to work on my former computer...

If it's really related to libSDL, I guess I'll have to play windowed mode until ScummVM uses a new version of libSDL...

Thanks for your help.

Lag
Posts: 8
Joined: Fri Nov 30, 2007 7:07 pm

Post by Lag » Mon Apr 11, 2011 7:27 pm

Well, since I also have this problem with other programs running fullscreen, I've been able to find information about it.

It's related to Windows 7 and Direct3D. Microsoft released a hotfix for it but I couldn't install it since... Well I don't know why.

Right now, the solution for me is using OpenGL setting... when available. Is there such a setting for ScummVM?

User avatar
md5
ScummVM Developer
Posts: 2261
Joined: Thu Nov 03, 2005 9:31 pm
Location: Athens, Greece

Post by md5 » Tue Apr 12, 2011 12:36 am

You can set SDL to use the windib graphics backend instead of DirectX. Check here:
viewtopic.php?p=4307
and here:
http://www.libsdl.org/docs/html/sdlenvvars.html

Lag
Posts: 8
Joined: Fri Nov 30, 2007 7:07 pm

Post by Lag » Tue Apr 12, 2011 6:34 pm

I've just tried the "set SDL_VIDEODRIVER=windib" trick in a batch file but I still have the same problem... I thought avoiding Direct3D would help me running ScummVM fullscreen but I think I'll have to stick with windowed mode a little longer :(

Thanks for your help.

Stip
Posts: 1
Joined: Fri Apr 15, 2011 7:42 pm

Post by Stip » Fri Apr 15, 2011 7:44 pm

I'm having this same problem too. I'm on Windows 7 home premium, with updated Radeon HD Mobile 4200.

Is there no workaround?

User avatar
bobdevis
Posts: 563
Joined: Fri Jan 16, 2009 10:52 am

Post by bobdevis » Sat Apr 16, 2011 5:27 am

Stip wrote: Is there no workaround?
If you take the ScummVM daily snapshot from the downloads page (and not the stable release) you will have the option of using the OpenGL grfx filter. While using that you can drag the game window to any size.
It's not exactly 'full-screen', but you can make it 'screen-filling' at least.

Post Reply