Broken Sword 2 crashes

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Toengel
Posts: 3
Joined: Fri Feb 03, 2006 3:36 pm

Broken Sword 2 crashes

Post by Toengel » Fri Feb 03, 2006 3:48 pm

Hi,

I have the German version of BS2 and the ScummVM 0.8.1. I copied the files from the two cd, described as follows:

BS2-Folder:

Carib2.clu
Carib3.clu
cd.bin
cd.inf
Cluster.tab
Credits.bmp
Credits.clu
Docks.clu
Font.clu
General.clu
Jungle.clu
Carib1.clu
Music1.clu
Paris.clu
Players.clu
Pyramid1.clu
Pyramid2.clu
Quaramon.clu
resource.inf
resource.tab
SCRIPTS.CLU
speech.clu
speech1.clu
Startup.inf
TEXT.CLU
Music.clu
Warehous.clu

VIDEO-Subfolder:

carib.mp2
carib.ogg
carib.pal
escape.mp2
escape.ogg
escape.pal
eye.mp2
eye.ogg
eye.pal
finale.mp2
finale.ogg
finale.pal
guard.mp2
guard.ogg
guard.pal
intro.mp2
intro.ogg
intro.pal
jungle.mp2
jungle.ogg
jungle.pal
museum.mp2
museum.ogg
museum.pal
pablo.mp2
pablo.ogg
pablo.pal
pyramid.mp2
pyramid.ogg
pyramid.pal
quaram.mp2
quaram.ogg
quaram.pal
river.mp2
river.ogg
river.pal
sailing.mp2
sailing.ogg
sailing.pal
shaman.mp2
shaman.ogg
shaman.pal
stone1.mp2
stone1.pal
stone2.mp2
stone2.ogg
stone2.pal
stone3.mp2
stone3.ogg
stone3.pal

The game starts normally. After the Intro I click on the block of wood and the bookcase crashes down and kills the spider. Now I click on the metal bracket on the wall and after a few seconds of the animation the SCUMMVM crashes. The WindowsXP-debugger starts and offers me to send a report to MS...

How can I solve my problem?

Toengel@Alex

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3316
Joined: Mon Oct 31, 2005 7:39 am

Re: Broken Sword 2 crashes

Post by eriktorbjorn » Fri Feb 03, 2006 6:52 pm

Toengel wrote:The game starts normally. After the Intro I click on the block of wood and the bookcase crashes down and kills the spider. Now I click on the metal bracket on the wall and after a few seconds of the animation the SCUMMVM crashes. The WindowsXP-debugger starts and offers me to send a report to MS...

How can I solve my problem?

Toengel@Alex
What the... Broken Sword 2 crashes for me, too, with ScummVM 0.8.1, but not with 0.8.0. I wonder what's causing that...

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3316
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Fri Feb 03, 2006 8:11 pm

I guess wjp must have a much faster computer than I have, because he was able to find the bug while I was still waiting for the compile to finish. :)

Anyway, it turns out that a change was made to the standard code for handling WAV data on January 27. This change caused Broken Sword 2 (but not any other games?) to break horribly. Needless to say, I'm not at all pleased about this. I'm going to make sure it can't happen again, and hopefully I'll be able to convince the others that we need to release a 0.8.1a or something like that.

Cesco182
Posts: 3
Joined: Fri Feb 03, 2006 9:53 pm

Post by Cesco182 » Sat Feb 04, 2006 12:56 am

Hi, I'm new to this forum but I think I can help you.
I tried to install this broken sword 2 today and had exactly the same problem. After reinstalling twice the game i found that setting scummvm.exe in windows98 compatibility mode (right click scummvm.exe >properties >compatibility >windows98) made the game run normally. I hope it will work for you too.

Ciao ciao!
Cesco ;)

Cesco182
Posts: 3
Joined: Fri Feb 03, 2006 9:53 pm

Post by Cesco182 » Sat Feb 04, 2006 11:03 am

I just want to add a little thing about the way i've installed the game: I havn t created any video subdirectories, i've put all the files(included the scumm video ones) in a sword2 directory.
I don't know if it changes something but with the compatiblity change these are the only two changes i've made to make the game stable.

pi
Posts: 35
Joined: Wed Oct 26, 2005 7:11 pm

Post by pi » Mon Feb 06, 2006 3:05 pm

I'm actually puzzled how the compatibility mode could help here. It's a known regression in the 0.8.1 release, as Erik mentioned some posts above. A solution should be there "soon". Are you sure you used ScummVM 0.8.1? Any Version before 0.8.1 should work fine even without compatibility mode.

pi~

Cesco182
Posts: 3
Joined: Fri Feb 03, 2006 9:53 pm

Post by Cesco182 » Mon Feb 06, 2006 5:48 pm

Yes I'm sure that I'm using the 0.8.1 version. I tried to play broken sword2 friday and I had EXACTLY the same error as Toengel did. I went to this forum saw Toengel post, but there were no answers yet. So I tried to reinstall putting all files in the same directory, i relauched the game and had the error again. As broken sword is not a LucasArts game, and I don't know anything in programming, and I don't know how scummvm can allow us enjoying our favorite game under XP, I tried some really basic stuff: the first thing I've tried to change is the compatibility mode to windows98, I relaunched the game and "magically" it worked(so well i've finished the game yesterday)... So i decided to register this forum to share what i've found.
I don't know why it works but I can assure you that for me it did(for broken sword2.Broken sword1 ran without changing anything).
As the topic has been read by many people, I hope I've helped some of them..

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3316
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Mon Feb 06, 2006 5:56 pm

The bug causes ScummVM to free an invalid pointer. It does point to allocated memory, but not to the beginning of the allocated block. (And it's not supposed to free that block yet anyway.) I guess it depends on the C library's implementation of free() what happens them. On my system it crashes, but it could reasonably do nothing at all, too. Though why different versions of Windows would behave differently, I do not know.

Toengel
Posts: 3
Joined: Fri Feb 03, 2006 3:36 pm

Post by Toengel » Thu Feb 09, 2006 1:06 pm

Hello,

thanks for 0.8.2!

Toengel@Alex

Post Reply