The Curse of Monkey Island Problem with Aspect Ratio

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
DamagedWill
Posts: 4
Joined: Mon Jul 06, 2009 8:23 am
Location: Pensacola, FL

The Curse of Monkey Island Problem with Aspect Ratio

Post by DamagedWill »

The games runs just fine. But it's always in windowed mode even when I run it in fullscreen. It wouldn't be a problem but it cuts a little too much off the bottom of the screen, knocking off the last dialogue option when I talk to people. I can't seem to make it smaller. I've tried running some of the scalers but none of those helped. Any ideas?

My monitor is a 19' widescreen if that helps.
User avatar
bobdevis
Posts: 567
Joined: Fri Jan 16, 2009 10:52 am

Post by bobdevis »

Ehhh, you must be running a 3x scaler.
Use a 2x scaler instead.

If this doesn't help, you might try to be more specific on what it is that is going on though.
But it's always in windowed mode even when I run it in fullscreen.
This for example doesn't make any scene. So are you running it fullscreen or not? Or are you running in a maximized window? Or in a not-maximized window?
You may also want to share what the resolution of your screen is.
DamagedWill
Posts: 4
Joined: Mon Jul 06, 2009 8:23 am
Location: Pensacola, FL

Post by DamagedWill »

bobdevis wrote:Ehhh, you must be running a 3x scaler.
Use a 2x scaler instead.

If this doesn't help, you might try to be more specific on what it is that is going on though.
But it's always in windowed mode even when I run it in fullscreen.
This for example doesn't make any scene. So are you running it fullscreen or not? Or are you running in a maximized window? Or in a not-maximized window?
You may also want to share what the resolution of your screen is.
Sorry about that. When I start it regularly, without hitting the fullscreen option, it's windowed. But it's a large window, the bottom third of the window is going off my screen.

When I hit the fullscreen option, ScummVM goes to fullscreen but when the game loads, it's not fullscreen. It's the same as it was before. I would take a screenshot of it but I forgot how to do that.

My resolution is 1440 x 900. Perhaps if I lower it a bit it may fix the problem? I will try this a bit later.
User avatar
criezy
ScummVM Developer
Posts: 790
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy »

The Curse of Monkey Island has a native resolution of 640x480. If you are running it with a 2x scaller it would indeed probably have a window slightly bigger that your screen (in heigth, 2 * 480 = 960).

You can change the scaler used by selecting the game in ScummVM, clicking on "Edit Game" and in the Graphic tab select the Normal (no scaling) graphic mode. You can also decide to run the game in full screen there.

Alternatively you can run the game in full screen by hitting alt-Enter after starting the game.

In ScummVM you can set global options (for the launcher and the games) by using the Options button or set some options for a specific games by using the Edit Game button.
DamagedWill
Posts: 4
Joined: Mon Jul 06, 2009 8:23 am
Location: Pensacola, FL

Post by DamagedWill »

criezy wrote:The Curse of Monkey Island has a native resolution of 640x480. If you are running it with a 2x scaller it would indeed probably have a window slightly bigger that your screen (in heigth, 2 * 480 = 960).

You can change the scaler used by selecting the game in ScummVM, clicking on "Edit Game" and in the Graphic tab select the Normal (no scaling) graphic mode. You can also decide to run the game in full screen there.

Alternatively you can run the game in full screen by hitting alt-Enter after starting the game.
Trying to run it in full screen from the launcher for some reason doesn't register. But hitting alt-enter after the game starts though was the clincher. That fixed it. Thanks!
Post Reply