ScummVM closes as soon as launched on my Mac

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

ScummVM closes as soon as launched on my Mac

Post by 3HeadedMonkey »

I think the title says it all, but i will try & be more precise.
I downloaded the correct version for my Mac from this website, opened the download, read the read me stuff, put ScummVM in my applications folder, tried to launch & it begins to open, then immeadiately closes with no windows or error codes....nada! Same happens if it is just on the desktop. Maybe I am just a total kook but I really want to play these old LucasArts games!

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

Forgot to mention....

Post by 3HeadedMonkey »

Almost forgot, I had an older version of scummVM that worked fine, but when we recently upgraded our OS to 10.5.5 I also got the newer version of scummVM. Shoot, wish I had the old one back now!

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem »

If you run ScummVM from some command prompt/shell it should tell you exactly what's wrong with it - at least it does under Windows and Linux.

If you want to try your luck with an older version of ScummVM, all of them are of course available from http://sourceforge.net/project/showfile ... e_id=29373

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

Same old problem...Open & Close, Open & Close

Post by 3HeadedMonkey »

I tried everything I could think of.... trashing everything, & reinstalling it, snapshot, even combed back through the README file......to no avail! Tried installing the developer tool, which had no effect whatsoever, then I began to think it could be a MT-32 emulator or MIDI issue, nope! Does everybody with an Apple (iBook G4) have this much difficulty in getting scummVM to start....Bummer!

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem »

Have you tried deleting the configuration file (scummvm.ini)?
This should re-set ScummVM to its default configuration - maybe it doesn't work because there's a problem with that file?

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

scummvm.ini file

Post by 3HeadedMonkey »

As far as deleting this file, I can & did with the DATA file I obtained but cannot with the application. The application doesnt let me access anything. It just starts to open then shuts down! Not sure if both of these files are necessary in order to run scummvm, but my guess is that the data file is to show content, & is not part of the actual application that is launched. I hope I am doing everything correctly. Thanks for all the help.

User avatar
clone2727
Retired
Posts: 1592
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Re: scummvm.ini file

Post by clone2727 »

3HeadedMonkey wrote:As far as deleting this file, I can & did with the DATA file I obtained but cannot with the application. The application doesnt let me access anything. It just starts to open then shuts down! Not sure if both of these files are necessary in order to run scummvm, but my guess is that the data file is to show content, & is not part of the actual application that is launched. I hope I am doing everything correctly. Thanks for all the help.
Try running the app via the terminal and see what it reports.

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

Run scummVM App through Terminal

Post by 3HeadedMonkey »

Thanks for the advice, but for some reason when I try to run scummVM through the terminal it just gives me a directory path. Not sure how to actually Command the App to Run via the Terminal. Tried to click & drag the scummVM App into Terminal, then press Enter key & all that happens is as said above......Directory path route explanation! Im sorry if I seem like a total idiot, but this type of computer navigation is evidently over my head.......could somebody please give me a laymens description on how to get this scummVM App to work on my Apple so I can play these old LucasArts games......

Three-headed Monkey
Posts: 18
Joined: Wed Nov 09, 2005 9:52 pm

Post by Three-headed Monkey »

Sorry for going off-topic but I think this forum is too big for six monkey heads. Especially if they belong to just two guys.

:wink:

User avatar
clone2727
Retired
Posts: 1592
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Post by clone2727 »

Hold control and click on the app. Then, select "view package contents". In one of the folders there should be a file that's just "scummvm". Run that through the terminal.

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

scummVM file via Terminal

Post by 3HeadedMonkey »

Good news! It actually did something other than just regurgitate what we already know! It said.....
Config file buggy: Invalid character occured in domain name in line 37!
bash-3.2$

User avatar
clone2727
Retired
Posts: 1592
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Re: scummVM file via Terminal

Post by clone2727 »

3HeadedMonkey wrote:Good news! It actually did something other than just regurgitate what we already know! It said.....
Config file buggy: Invalid character occured in domain name in line 37!
bash-3.2$
Check out the "ScummVM Preferences" file. It should be under your user's Preferences folder. If you can't figure out what's wrong, just delete the file and you'll be good again.

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

May sound silly but...

Post by 3HeadedMonkey »

I searched the entire hard drive for scummVM preferences, & user preferences with no luck on either counts. If you meant system preferences or the user folder, checked those....no files containing or pertaining to scummvm preferences! Only files that come up with anything close to scummVM are the 3 on the desktop.... dmg., 0.12.0, & ScummVM. That being said once the ScummVM App is launched after the initial download from .dmg disk, there is a save game file that is imported to the hard drive that contains no data. Trashed that & tried to relaunch App.....nothing! Same game, ScummVm begins to launch then immeadiately closes with no warnings or headers or windows!

User avatar
clone2727
Retired
Posts: 1592
Joined: Fri Jun 09, 2006 8:23 pm
Location: NJ, USA

Post by clone2727 »

It should be at:

Code: Select all

<Insert Your User's Name>/Library/Preferences/ScummVM Preferences"

3HeadedMonkey
Posts: 8
Joined: Sun Dec 28, 2008 9:11 pm

YOU DA MAN!!!

Post by 3HeadedMonkey »

It works! Up & running, thanks so much for the assistance.

Post Reply