Changing permission to c:\windows?

Ask for help with ScummVM problems

Moderator: ScummVM Team

Aidan
Posts: 3
Joined: Tue Jan 03, 2006 3:43 pm
Location: Vancouver, B.C. Canada
Contact:

Changing permission to c:\windows?

Post by Aidan » Tue Jan 03, 2006 4:38 pm

Hello,

When I try to run scummvm I get the following error message in the first window that pops up.

WARNING: Unable to open configration file C:\WINDOWS\scummvm.ini!

The second window that comes up is the program screen, but it lags/frozen, and I am unable to do anything with it.

I have tried the FAQ that says that the solution to this problem is to make you that I enough permissions to write in c:\windows directory. I currently have Windows XP Home edition on my computer and this account is the main and only User on this computer (and it is the Administrator as well) ... I dont quite understand how to change permission to write in the c:\windows directory. Can anyone give me clarification on how to do this, please?

joachimeberhard
ScummVM Team Member
Posts: 378
Joined: Sat Sep 24, 2005 12:25 pm
Location: Austria

Post by joachimeberhard » Tue Jan 03, 2006 5:17 pm

Somehow I think even if ScummVM would hardcodedly assume the scummvm.ini in M:\ it would have a greater chance of succeeding to write there :lol: :lol: Just a joke for the developers.... 8)

So, to solve your actual problem:

Create a text file in your ScummVM directory, rename it to "GO.BAT" or whatever, just make sure the name ends with ".BAT" (Note the DOT).

Write the following entry into that file using an editor and SAVE the file:

Code: Select all



scummvm.exe -cscummvm.ini


Make a shortcut to the GO.BAT file on your desktop.

Now always start ScummVM using the shortcut on your desktop.

Oh, and one more important thing:

Don't ever mess around with permissions on either "C:\", "C:\Windows" , "C:\program files" or "C:\documents and settings" if you are not 100% sure how it works and what you are doing!

You can seriously damage your system with that!

Frank
Posts: 17
Joined: Tue Jan 03, 2006 6:05 pm

Post by Frank » Tue Jan 03, 2006 6:16 pm

I just registered after seeing this thread. It is my exact problem, and I created the start.bat file, then copy/pasted your line "scummvm.exe -cscummvm.ini" and saved it.

The start.bat file launches scummvm, only now the first window says the following.

"C:\Program Files\scummvm>scummvm.exe -scummvm.ini
WARNING: Unable to open configuration file: scummvm.ini"

My first question is if the space should be between "scummvm.exe (and) -cscummvm.ini"?

If so, what did I do wrong?

Thanks
Last edited by Frank on Tue Jan 03, 2006 6:21 pm, edited 1 time in total.

joachimeberhard
ScummVM Team Member
Posts: 378
Joined: Sat Sep 24, 2005 12:25 pm
Location: Austria

Post by joachimeberhard » Tue Jan 03, 2006 6:20 pm

ScummVM uses Bash style parameters.

So you can either use

Code: Select all



"scummvm.exe --config=X:\scummvm.ini"

OR

"scummvm.exe -cX:\scummvm.ini"


You recognize the syntax?

eg. no spaces whatsover within the same parameter.

Frank
Posts: 17
Joined: Tue Jan 03, 2006 6:05 pm

Post by Frank » Tue Jan 03, 2006 6:26 pm

joachimeberhard wrote:ScummVM uses Bash style parameters.

So you can either use

Code: Select all



"scummvm.exe --config=X:\scummvm.ini"

OR

"scummvm.exe -cX:\scummvm.ini"


You recognize the syntax?

eg. no spaces whatsover within the same parameter.
No to recognizing the syntax, but from your last line "scummvm.exe -cX:\scummvm.ini" I am thinking I should edit it to read:

scummvm.exe -c:\windows\scummvm.ini

Hope that doesn't look ignorant, but I am when it comes to this.

Frank
Posts: 17
Joined: Tue Jan 03, 2006 6:05 pm

Post by Frank » Tue Jan 03, 2006 6:42 pm

I have an appointment, I'll check this when I get back.

Thanks

joachimeberhard
ScummVM Team Member
Posts: 378
Joined: Sat Sep 24, 2005 12:25 pm
Location: Austria

Post by joachimeberhard » Tue Jan 03, 2006 7:07 pm

No to recognizing the syntax, but from your last line "scummvm.exe -cX:\scummvm.ini" I am thinking I should edit it to read:

scummvm.exe -c:\windows\scummvm.ini
Either use "-c" or "--config=" immediately followed by the path.

So if you want your scummvm.ini to be in C:\Windows, you have to write:

Code: Select all


scummvm.exe -cC:\Windows\scummvm.ini

OR

scummvm.exe --config=C:\Windows\scummvm.ini



So if you want your scummvm.ini to be in the directory you run ScummVM from, you have to write:

Code: Select all


scummvm.exe -cscummvm.ini

OR

scummvm.exe --config=scummvm.ini


Frank
Posts: 17
Joined: Tue Jan 03, 2006 6:05 pm

Post by Frank » Tue Jan 03, 2006 9:23 pm

This line works:

scummvm.exe -cC:\Windows\scummvm.ini

I no longer get a "Warning", but now I have to do some searching to figure out how to add my game files to scummvm. All I get when I click on "Add Game" is the letters A through H rather than files.

Thanks for the bat file information.

User avatar
frank_m24
Posts: 97
Joined: Sun Oct 30, 2005 4:10 pm
Location: Germany

Post by frank_m24 » Tue Jan 03, 2006 9:50 pm

Hello,

ever heard of drive letters? Yes, the letters are representing the drives in your computer. A is most likely the floppy, C the first HD, D can be a HD or CD/DVD and so on.
I'm sure you have copied the content of your original CD to a HD or installed your floppy-games to it. After that it is easy to add the games to scummvm, since your are knowing the place (Drive letter + Path) from the copy/install procedure.

If you know the hell what I'm talking about, just read a book like "Computers for beginners" or something like that.

BTW: you can forget about the whole .bat story if your are using "-cC:\Windows\scummvm.ini", since scummvm stores the scummvm.ini by default in C:\Windows.

best regards

Frank

Frank
Posts: 17
Joined: Tue Jan 03, 2006 6:05 pm

Post by Frank » Tue Jan 03, 2006 10:01 pm

I don't understand your anger, but thanks for the information anyway. I just had not had time to look at the program until now. I do have the game running although in a small window. May have to go to a different resolution to play it.

Your advice to get a book for beginners seems rather rude, but maybe you had a bad day. I hope it goes better for you tomorrow.

Incidentally the batch file did solve a problem. Before the batch file, I was getting the error that scummvm couldn't find the ini file despite it being in it's default location in Windows.

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem » Tue Jan 03, 2006 10:27 pm

maybe this helps adding games:

http://www.unet.univie.ac.at/~a0200586/stuff/tut/

to change the window size, click on "Options" in on the ScummVM screen, try setting a 2x or 3x scaler there

or press Alt-Enter to switch to fullscreen

Frank
Posts: 17
Joined: Tue Jan 03, 2006 6:05 pm

Post by Frank » Tue Jan 03, 2006 11:26 pm

Excellent, thanks for the link.

User avatar
frank_m24
Posts: 97
Joined: Sun Oct 30, 2005 4:10 pm
Location: Germany

Post by frank_m24 » Tue Jan 03, 2006 11:30 pm

Hello,

I didn't want to be rude, but if someone complains about drive letters in a file dialog, it is very likely, that he is a beginner. The target of this forum is not to tell beginners, what drive letters are.

BTW: It is normal, that ScummVM tells at the first start, that it can't find the ini-File, since it doesnt exist, it will be produced during the first run. Added games and settings will be stored in this file after it is produced. The warning doesn't matter and ScummVM will work nice anyway.
Don't mix it up the the error message ScummVM will produce, if you don't have write permissions for your Windows directory. If you don't have these permissions, even "-cC:\Windows\scummvm.ini" can't help you.

If your Windows is installed in C:\Windows, you can run ScummVM without the .bat file.
But in my opinion it makes sense to store the ini file in the ScummVM directory like joachimeberhard described it. But: If you didn't run ScummVM before with "-cscummvm.ini" it will again produce a warning about a missing scummvm.ini! Maybe you can move the ini from c:\windows to your ScummVM Dir.

best regards

Frank

Aidan
Posts: 3
Joined: Tue Jan 03, 2006 3:43 pm
Location: Vancouver, B.C. Canada
Contact:

Post by Aidan » Wed Jan 04, 2006 6:33 am

Ok it still is'nt working for me, I have tried everything given to me. Obviously I am screwing up somewhere.

Though thanks for all the advice and help everyone. I'm going to keep on trying... shesh, the problems I have.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3315
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Wed Jan 04, 2006 7:04 am

Aidan wrote:Ok it still is'nt working for me, I have tried everything given to me. Obviously I am screwing up somewhere.

Though thanks for all the advice and help everyone. I'm going to keep on trying... shesh, the problems I have.
ScummVM freezing under Windows - if that's still happening to you - is something I've seen been reported a few times in the past. Perhaps the "Problem with Win32 build" or "ScummVM freezes" threads are helpful.

(There may be others. Since I currently don't have access to Windows, I tend not to pay much attention to Windows-specific problems.)

Post Reply