Broken Sword [GER] cutscene problem

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
MadMarvin
Posts: 9
Joined: Thu Jan 17, 2008 2:04 pm
Location: Germany

Broken Sword [GER] cutscene problem

Post by MadMarvin »

Hi there, folks,
I'm currently trying to play Broken Sword (or Baphomets Fluch, as it is called here in Germany) and it's working just fine with the exception of some cutscenes.

I bought the german trilogy a few days ago (this one I might add) but didn't install it according to the setup. Instead, I copied the BS1 and BS2 files to my scummvm directory according to the scheme explained in the wiki and the BS2-setup thread. Take a look:

Broken Sword I/Baphomets Fluch I (the music folder was to big to fit on the screen but you get the picture, it's all there)

Broken Sword II/Baphomets Fluch II


The video files in the BS1 video folder match the contents of the 32MB german cutscene package in the "Downloads" section. Both games were added correctly to scummvm, I didn't edit anything safe for the "Language" entry (I changed that one to "German" obviously) and the savegame path.




Well ... forgot something? Oh, yes, the problem! The BS1 intro is swapped with the BS2 intro although they of course reside in different directories (sword1 and sword2). This even happened when I hadn't "registered" BS2. The only way to see the correct BS1 intro ingame is to cut and paste the sword2 folder out of the scummvm folder. But this isn't the only weird cutscene. When I stepped out of the Hotel Ubu with the map in my possession and realized I made a mistake, a totally out of context cutscene was played. In this one, George flees onto a boat somewhere in South America, where he is chased by a helicopter in the night which blows the boat up. A gravestone is shown and the program explains that I'm dead. Is this the only "death cutscene" of the game? If no, this clearly is another mix-up.

It doesn't matter if I'm using 0.11.1 or the daily snapshot.


Any help is appreciated and of course I ask you to excuse my bad English. :D

User avatar
sev
ScummVM Lead
Posts: 2047
Joined: Wed Sep 21, 2005 1:06 pm
Contact:

Post by sev »

Please, provide contents of your scummvm.ini file.


Eugene

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3329
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

Sounds like you have somehow managed to put a folder with the Broken Sword 2 cutscene videos where ScummVM will find it when playing Broken Sword 1. Both games have cutscenes named "intro" and "river", but they are quite different from each other.

MadMarvin
Posts: 9
Joined: Thu Jan 17, 2008 2:04 pm
Location: Germany

Post by MadMarvin »

eriktorbjorn wrote:Sounds like you have somehow managed to put a folder with the Broken Sword 2 cutscene videos where ScummVM will find it when playing Broken Sword 1. Both games have cutscenes named "intro" and "river", but they are quite different from each other.
That's what i guessed. As for the .ini file:

[scummvm]
music_volume=192
midi_gain=100
speech_volume=192
browser_lastpath=D:\Spiele\ScummVM\sword2\
aspect_ratio=false
extrapath=D:\Spiele\ScummVM\
music_driver=auto
lastselectedgame=sword1
native_mt32=false
gui_theme=Classic (Builtin)
subtitles=false
fullscreen=true
sfx_volume=192
talkspeed=60
speech_mute=false
autosave_period=300
enable_gs=false
multi_midi=false
versioninfo=0.11.1

[sword1]
description=Broken Sword 1: The Shadow of the Templars
music_volume=192
speech_volume=231
path=D:\Spiele\ScummVM\sword1\
music_driver=auto
subtitles=true
music_balance=50
gameid=sword1
language=de
sfx_volume=192
sfx_balance=50
talkspeed=60
speech_mute=false
speech_balance=50
savepath=D:\Spiele\ScummVM\sword1\

[sword2]
description=Broken Sword 2: The Smoking Mirror
path=D:\Spiele\ScummVM\sword2\
gameid=sword2
language=de
savepath=D:\Spiele\ScummVM\sword2\








Strange, what does "browser_lastpath" mean? If it's the path to the game last played: That should be "...\sword1".

Edit: In the past month, I always installed new versions over older versions (and vice versa) without doing a clean uninstall. Could that be the source of the problem?

Edit2: Maybe ScummVM desperately searches for a .fla or .dxa cutscene file first, no matter what the exact directory is. So in case of Broken Sword, the program maybe scans the whole main folder and finds an intro.dxa in the sword2 folder whereas it cannot find a ferrari.dxa or ferrari.fla. Thus, it plays the ferrari.mp2. The Dark engine (Thief, System Shock 2) is a little like that.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3329
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

MadMarvin wrote: Strange, what does "browser_lastpath" mean? If it's the path to the game last played: That should be "...\sword1".
It's the most recent path visited by ScummVM's file/directory browser dialog. It's so that it'll start in the same path the next time you add a game.
MadMarvin wrote: Edit2: Maybe ScummVM desperately searches for a .fla or .dxa cutscene file first, no matter what the exact directory is.
It will look for .dxa files before .mp2 files, because .dxa files are movies of higher quality. But it won't look everywhere. Only where ScummVM has told it to look, which would be (at least):
  • The Theme Path.
  • The Extra Path, and every sub-folder inside it.
  • The game's Game Path.
  • [Broken Sword 1 only] Folders named clusters, music, speech and video in the game's Game Path.
  • [Broken Sword 2 only] Folders named clusters, sword2 and video in the game's Game Path.
If you run ScummVM from a commant prompt, like this...

scummvm -d 3

(Assuming that ScummVM is in your search path. You may have to type the entire path to the ScummVM executable.)

... it should print debug messages about exactly which files it are opening. You will see a number of other debug messages, including ones about "missing" files, but this is perfectly natural. Sometimes a file can have several different names, so ScummVM has to try a few to figure out which one you have.

User avatar
criezy
ScummVM Developer
Posts: 727
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Post by criezy »

MadMarvin wrote: That's what i guessed. As for the .ini file:

[scummvm]
...
extrapath=D:\Spiele\ScummVM\
eriktorbjorn wrote: It will look for .dxa files before .mp2 files, because .dxa files are movies of higher quality. But it won't look everywhere. Only where ScummVM has told it to look, which would be (at least):
  • The Extra Path, and every sub-folder inside it.
So isn't that the problem?

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3329
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

criezy wrote: So isn't that the problem?
The obvious solution would be to not keep your games inside your "extra path".

MadMarvin
Posts: 9
Joined: Thu Jan 17, 2008 2:04 pm
Location: Germany

Post by MadMarvin »

criezy wrote: So isn't that the problem?
You were right. I deleted the the extra path and now everything's just fine. I don't even know why I changed that one ... could've been the influence of the Baphomet demon. :lol:


You guys are awesome!

Post Reply