tentacle music

Ask for help with ScummVM problems

Moderator: ScummVM Team

Don Quijote
Posts: 11
Joined: Sun Feb 04, 2007 12:20 pm

Post by Don Quijote » Sat May 05, 2007 10:01 am

I ended this game today, so the post is noat actual, for me. game was great, but amazingly, for the best adveture game in history, which is claimed for many people to be, short. if I play more, instead of reading stephen king books, i think i will complete it in 2 days time. my favourite - secret of monkey island - was much longer. other la games - grim fandango and other mi were much longer. only loom was shorter, but it was supposed to be 1st piece of serie and maybe sam & max, other great game, was this lenght. i think it should be 2 times longer. even it's a great game, one of the best i played ("thank you masked man" :lol: ).

clem
Posts: 2185
Joined: Mon Oct 31, 2005 11:14 am

Post by clem » Sat May 05, 2007 10:06 am

Don Quijote wrote:I ended this game today, so the post is noat actual, for me. game was great, but amazingly, for the best adveture game in history, which is claimed for many people to be, short. if I play more, instead of reading stephen king books, i think i will complete it in 2 days time. my favourite - secret of monkey island - was much longer. other la games - grim fandango and other mi were much longer. only loom was shorter, but it was supposed to be 1st piece of serie and maybe sam & max, other great game, was this lenght. i think it should be 2 times longer. even it's a great game, one of the best i played ("thank you masked man" :lol: ).
if you think DOTT is short you should try Full Throttle - imo the shortest LucasArts adventure. Sadly, BASS also seems quite short

Don Quijote
Posts: 11
Joined: Sun Feb 04, 2007 12:20 pm

Post by Don Quijote » Sun May 06, 2007 6:10 pm

it took me about 4 hours to complete full throttle. normally i would say it's a joke, that a game for 150 zl (poland) [about 50$) gave me 4 hours of play, but in this case i can't say it so easy. even though i think it's big rip-off the game is so great (of course much too short) that i can forgot maybe 25$ of this price.

can you tell me if full throttle and curse of monkey island cost the same mon(k)ey??!! if yes, it's a big misunderstood.

domino
Posts: 17
Joined: Tue Nov 01, 2005 12:56 pm

Post by domino » Sun May 06, 2007 6:52 pm

in fact curse of monkey island is cheaper, i have bought it for 80 zl (in poland, just like you) like 5 or more years ago and if i had payed that much for full throttle then man i would be really mad. but anyways, thats what a reviews are for. no matter if its a well known lucasarts or what, just read the review before buying anything.

guillervf91
Posts: 4
Joined: Tue May 08, 2007 8:02 pm

Post by guillervf91 » Tue May 08, 2007 8:06 pm

I'm trying to play sounds in Day of Tentacle, in Debian, but i choose the ALSA driver and the program closes when I try to play game.
Any idea, please?
Thanks

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3309
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Wed May 09, 2007 11:05 am

guillervf91 wrote:I'm trying to play sounds in Day of Tentacle, in Debian, but i choose the ALSA driver and the program closes when I try to play game.
Any idea, please?
Thanks
Have you trying running ScummVM from the command-line? It might print some useful message before crashing. If it doesn't, and you're feeling more adventurous, you could try using GDB to pin-point exactly where it crashes.

guillervf91
Posts: 4
Joined: Tue May 08, 2007 8:02 pm

Post by guillervf91 » Wed May 09, 2007 1:04 pm

It shows this:
Looking for tentacle
Trying to start game 'Day of the Tentacle'
WARNING: Could not open audio device: No available audio device!
WARNING: Sound mixer initialization failed
!
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
Can't open sequencer!
but I have sound in other programs.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3309
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Wed May 09, 2007 1:33 pm

guillervf91 wrote: ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
Can't open sequencer!
but I have sound in other programs.
Selecting the ALSA music driver tells ScummVM to play MIDI through ALSA. It doesn't affect other sounds, though. They are played through whatever the SDL library decides to use.

Googling for "open /dev/snd/seq failed" turns up quite a number of hits. Perhaps one of them can help you? Some of them suggest that it may be that the kernel module for MIDI sequencer support isn't loaded, but I don't know which one that is. To some extent, it probably depends on which sound card you have.

(On my Linux box "it just works", except I still have to load the SoundFont file manually.)

guillervf91
Posts: 4
Joined: Tue May 08, 2007 8:02 pm

Post by guillervf91 » Thu May 10, 2007 3:42 pm

Thanks, I use "sudo modprobe snd-seq".Now it shows an different error:
"Looking for tentacle
Trying to start game 'Day of the Tentacle'
WARNING: Could not open audio device: No available audio device!
WARNING: Sound mixer initialization failed
!
Can't subscribe to MIDI port (65:0) see README for help!"

I found this guide http://ubuntuforums.org/showthread.php?t=8736
But I can't install the packages "alsa-headers" and "alsa-modules", so the program keeps crashing and showing the same error.

User avatar
eriktorbjorn
ScummVM Developer
Posts: 3309
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn » Thu May 10, 2007 4:15 pm

guillervf91 wrote: Trying to start game 'Day of the Tentacle'
WARNING: Could not open audio device: No available audio device!
WARNING: Sound mixer initialization failed
!
Can't subscribe to MIDI port (65:0) see README for help!"
Hmm... These are two different errors. The "Could not open audio device" message comes from SDL_OpenAudio() failing. That function is called from backends/platform/sdl/sdl.cpp but I have no idea why it would fail.

It's possible that setting the SDL_AUDIODRIVER environment variable would make a difference. It's somewhat documented on this page though I thought one of the possible values for it was "arts", not "artsc".

The "Can't subscribe to MIDI port (65:0) see README for help!" comes from snd_seq_connect_to() failing. 65:0 used to be a good default "MIDI port" (whatever that really is) to connect to, but that changed for me some time ago. Nowadays, 17:0 works better for me. This is what "aconnect -o" tells me:

Code: Select all

client 14: 'Midi Through' [type=kernel]
    0 'Midi Through Port-0'
client 16: 'SBLive! Value [CT4832]' [type=kernel]
    0 'EMU10K1 MPU-401 (UART)'
client 17: 'Emu10k1 WaveTable' [type=kernel]
    0 'Emu10k1 Port 0  '
    1 'Emu10k1 Port 1  '
    2 'Emu10k1 Port 2  '
    3 'Emu10k1 Port 3  '
You can override the "65:0" default, either by setting the SCUMMVM_PORT environment variable, or by setting "alsa_port" in the [scummvm] section of your ~/.scummvmrc file. (There's no GUI for this setting, as far as I know.)

guillervf91
Posts: 4
Joined: Tue May 08, 2007 8:02 pm

Post by guillervf91 » Fri May 18, 2007 3:53 pm

Thanks for all. I can fix it changing the driver from alsa to oss.

Post Reply