No real fullscreen with linux

Ask for help with ScummVM problems

Moderator: ScummVM Team

User avatar
pankratz
Posts: 31
Joined: Tue Jul 18, 2006 4:27 pm

No real fullscreen with linux

Post by pankratz »

Hi,

i tried the debian-port of scummvm and it works fine(ubuntu 6.06). But the fullscreen-mode doesn't bring real fullscreen. The resolution is the same like in the window-mode. The rest of the screen become black. But i wouldn't call that fullscreen :D

At windows the whole screen is used...suggestions? :?:
futaris
Posts: 17
Joined: Fri Jul 07, 2006 5:07 am

Post by futaris »

Don't run the SDL/X-Windows version. Boot up in console mode and use it from the framebuffer. NB, you will still need to use a scaler mode, depending on your framebuffer.
cde
Posts: 46
Joined: Thu Jul 06, 2006 9:48 am

Works fine here

Post by cde »

I have SVM 0.9.0 on Ubuntu 6.06, fullscreen works fine. I have set SVM's options to be fullscreen, so when it launches it takes over, and I am not asking for aspect ration correction (I had some issues with the top left of my screen zooming right in but I fixed it by accident before figuring out what was causing it!).

I couldn't get individual games to run full screen by overriding SVM's graphic settings if it is set to NOT launch fullscreen - however I have got each game set to

Code: Select all

aspect_ratio=true
fullscreen=true
(if you open .scummvmrc you can just replace or paste those lines into each game's config section)

I've put the scummvm part of my /home/MYPROFILE/.scummvmrc config file below, perhaps it will help?

Code: Select all

[scummvm]
music_volume=192
midi_gain=80
speech_volume=192
browser_lastpath=/home/
aspect_ratio=false
music_driver=auto
lastselectedgame=sword2
native_mt32=false
subtitles=false
themepath=/usr/lib/scummvm/themes/modern/
fullscreen=true
sfx_volume=192
talkspeed=60
speech_mute=false
enable_gs=false
multi_midi=false
versioninfo=0.9.0
savepath=/home/PROFILE/.scummvm
The themepath might not work on previous builds, and you should probably make sure the lastselectedgame is one you have to avoid confusion! :)

Let us know how it goes,
c
User avatar
pankratz
Posts: 31
Joined: Tue Jul 18, 2006 4:27 pm

Post by pankratz »

Mh, i looked up my config, but i have the same settings :cry:

I tried the fullscreen from start, but that isn't fullscreen. The resolution is the same like in window-mode...


@futarisidea: the terminal from start isn't a good solution, IMO.
User avatar
abelthorne
Posts: 43
Joined: Fri Jun 02, 2006 11:50 am
Location: France

Post by abelthorne »

Have you set a scaler, so that ScummVM will stretch the graphics to fill the screen ?
User avatar
pankratz
Posts: 31
Joined: Tue Jul 18, 2006 4:27 pm

Post by pankratz »

I don't know...how can i set a scaler?
User avatar
abelthorne
Posts: 43
Joined: Fri Jun 02, 2006 11:50 am
Location: France

Post by abelthorne »

pankratz wrote:I don't know...how can i set a scaler?
Options -> graphics -> graphics mode. Choose one of the scaling algorithms that scale by 2x or 3x (e.g. HQ2x if you want smoothed graphics, or 2x if you want good old pixels).
User avatar
gord
Posts: 25
Joined: Tue Feb 21, 2006 10:48 pm

Post by gord »

if your using the debian port then there is a good chance that it isn't linked to your x server, its dead easy to install scummvm on ubuntu just untar the source somewhere and...

Code: Select all

sudo apt-get build-dep scummvm
cd <source dir>
./configure
make
sudo make install
that will use a version of sdl that is linked to your x server and you should get a proper fullscreen
User avatar
pankratz
Posts: 31
Joined: Tue Jul 18, 2006 4:27 pm

Post by pankratz »

abelthorne wrote:
pankratz wrote:I don't know...how can i set a scaler?
Options -> graphics -> graphics mode. Choose one of the scaling algorithms that scale by 2x or 3x (e.g. HQ2x if you want smoothed graphics, or 2x if you want good old pixels).
Oh, Scaler ;). Yes, i tried scaler. The Problem still exists.

@gord: ok, i think i will try to build my own scummvm :shock:
User avatar
pankratz
Posts: 31
Joined: Tue Jul 18, 2006 4:27 pm

Post by pankratz »

Hello again,

i think my ./configure doesn't work well

Code: Select all

Running ScummVM configure...
Looking for C++ compiler... g++
Checking for compiler version... 4.0.3, ok
Checking hosttype... linux-gnu
Checking endianness... little
Running on x86... yes
Alignment required... no
Type with 1 byte... char
Type with 2 bytes... short
Type with 4 bytes... int
Checking whether building plugins was requested... no
Checking for Ogg Vorbis... no
Checking for Tremor... no
Checking for FLAC >= 1.0.1... no
Checking for MAD... no
Checking for ALSA >= 0.9... no
Checking for zlib... no
Checking for libmpeg2 >= 0.3.2... no
Checking for libfluidsynth... no
Checking for nasm... not found

Engines&#58;
    SCUMM &#91;v7 & v8 games&#93; &#91;HE70+ games&#93;
    Simon the Sorcerer
    Beneath a Steel Sky
    Broken Sword 1  &#40;without mpeg2 cutscenes&#41;
    Broken Sword 2 &#40;without mpeg2 cutscenes&#41;
    Flight of the Amazon Queen
    SAGA
    Legend of Kyrandia
    Gobli*ns

Backend... sdl, HQ scalers, MT-32 emu
Looking for sdl-config... none found!
After this make doesn't work...
User avatar
Vinterstum
ScummVM Developer
Posts: 580
Joined: Sun Oct 16, 2005 6:59 am

Post by Vinterstum »

You need to install the libs that ScummVM needs. Most importantly, SDL.

If you're using Ubuntu or another Debian based distro, try 'apt-get install libsdl', and the same for libmad, libvorbis, etc.
clem
Posts: 2160
Joined: Mon Oct 31, 2005 11:14 am

Post by clem »

I'm not too good with linux myself, didn't stop me from starting a howto on the wiki - maybe this helps?

http://wiki.scummvm.org/index.php/Compiling_ScummVM_GCC

I think you will at least need nasm and sdl / sdl-devel to get it to compile, probably zlib as well

clem

PS: anybody more linux-savy than me: please update the wiki :)
User avatar
pankratz
Posts: 31
Joined: Tue Jul 18, 2006 4:27 pm

Post by pankratz »

Mh, i got this:

libsdl1.2debian and libsdl1.2debian-all
some libvorbis
libmad0

Why this isn't found? Ideas?
User avatar
eriktorbjorn
ScummVM Developer
Posts: 3362
Joined: Mon Oct 31, 2005 7:39 am

Post by eriktorbjorn »

pankratz wrote:Mh, i got this:

libsdl1.2debian and libsdl1.2debian-all
some libvorbis
libmad0

Why this isn't found? Ideas?
Those are for running programs using the libraries. To compile programs using the libraries, you also need the development packages, i.e. libsdl1.2-dev, libvorbis-dev, libmad0-dev, etc.

Most of the libraries are optional, so even if the configure script appears to run successfully you should check what it has written, to see if any of the libraries you want it to find are still reported as missing.
Tillw
Posts: 1
Joined: Mon Jul 24, 2006 8:41 am

Post by Tillw »

Hey,
same Problem here. I am quite used to Linux and I recompiled scummvm myself. Works. But only the ScummVM menu changes the res.. The menu now fits to my res but the games does not.
I did not find eny extra options for configure. Are there eny?

Or could this just be a matter of my 19' TFT?

Edit:
The Scaling simply does not work. If I press Ctl+Alt+ +/-/1/2 etc nothing happends and scummvm tells me that there is no scaling. But i selected scaling...
Post Reply