Glitchy Audio

Ask for help with ScummVM problems

Moderator: ScummVM Team

User avatar
rootfather
ScummVM Team Member
Posts: 78
Joined: Tue Mar 31, 2015 11:59 am
Location: Germany
Contact:

Re: Glitchy Audio

Post by rootfather »

I couldn't replicate the issues regarding MT32 emulation or the stuttery sound in COMI. To be fair, the slowest machine I have is some Core i5 from 2017, so that's not a fair comparison.

I'll try to get a build done with Munt 2.4.1, so you could check against it.
I'm running on Windows 7 x64 with a relatively heavy spec. Curse of Monkey Island doesn't use MT32. Is the MT32 emulation always active in the background?
No, the MT32 emulation is only running when it's explicitly enabled, it's not always enabled.
User avatar
Raziel
ScummVM Porter
Posts: 1328
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Re: Glitchy Audio

Post by Raziel »

Alien Grey wrote: Thu Oct 08, 2020 7:42 pm Tried it with a single core and no issues. CPU load is around 12%.
This may be far fetched, but have you tried to enhance your audio buffer?

Take a look in scummvm.ini under the [ScummVM] part right at the top and see if you can find
audio_buffer_size=xxxx
If you have a setting there, you can try to enhance it in 4096 steps.

If not, use something like audio_buffer_size=8192 and try with that.

Helped me at least get rid of audio dropouts in Sierra games (the on-the-fly setting were far too low, 2048 iirc, which made the audio drop out audible)
User avatar
Alien Grey
Posts: 42
Joined: Thu Sep 18, 2014 1:12 pm
Location: Belgium

Re: Glitchy Audio

Post by Alien Grey »

There's no audio buffer setting in the scummvm.ini file.

I made a video with ScummVM 2.2.0 and Munt 2.3.0 running a few game intro: https://www.youtube.com/watch?v=SFet2ssKXJA&t=18s

This is captured on my Windows 7 X64 computer. This is how it runs on my Windows 10 Intel Atom x7 Z8750 device with burst disabled.
User avatar
Raziel
ScummVM Porter
Posts: 1328
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Re: Glitchy Audio

Post by Raziel »

...and did you try with manually adding this setting?
User avatar
Alien Grey
Posts: 42
Joined: Thu Sep 18, 2014 1:12 pm
Location: Belgium

Re: Glitchy Audio

Post by Alien Grey »

I did try to add it to increase the buffer but that didn't work. ScummVM ignores it and removes it from the scummvm.ini.
User avatar
Raziel
ScummVM Porter
Posts: 1328
Joined: Tue Oct 25, 2005 8:27 am
Location: a dying planet

Re: Glitchy Audio

Post by Raziel »

Huh?
That doesn't happen here and it's a perfectly sane option according to the readme

Maybe you also need to add "output_rate"?
User avatar
Alien Grey
Posts: 42
Joined: Thu Sep 18, 2014 1:12 pm
Location: Belgium

Re: Glitchy Audio

Post by Alien Grey »

Here's a new video to show how I setup and configure ScummVM and Munt to use MT-32.

Video lnk: https://www.youtube.com/watch?v=ycADrzSY5F4

Uploaded it because someone complaint that I didn't show what settings I used to get it to run. In this video I've got the Roland GS setting enabled but it also works with it disabled. Not sure what the difference is between them.


I think that to try to find out what's causing these sound glitches with the internal MT-32 emulator we're going to need the same Munt version build.
Post Reply