MT-32

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
Napalmtree
Posts: 7
Joined: Sun Oct 16, 2011 9:02 am

MT-32

Post by Napalmtree »

Trying to use my MT-100, I set midi tab to do not use midi and mt-32 tab to my midi output device and default audio also the device or mt-32 emulation as there is no option for real mt-32 output in audio. Any how, it's still playing it like it's a GM device with audio device set to the midi interface and with mt-32 emulation it trys to laod the emulation rom files. For games it was built for like SQ3 it works fine in midi mode, but it's like the mt-32 tab is broken or something. sam & max has a ton of missing music that is there when the game is actually in mt-32 mode.

How do I set the midi out device to be the actual MT-32? or rather set the preferred music device to mt-32? only options are emulation and windows midi which windows midi is GM. mt32 tab has no effect.

User avatar
criezy
ScummVM Developer
Posts: 649
Joined: Sat Sep 23, 2006 10:41 am
Location: West Sussex, UK

Re: MT-32

Post by criezy »

Does the information in this other thread answer your question?

Napalmtree
Posts: 7
Joined: Sun Oct 16, 2011 9:02 am

Re: MT-32

Post by Napalmtree »

No, but it seems to be that Sam & Max apparently just doesn't utilize the MT-32 properly. All sorts of missing channels. Apparently, Lucasarts didn't bother to transcribe a version of the music for this so it doesn't matter if it's GM mode or MT-32 in SCUMMVM. Will have to fire it up from the original exe to confirm, but pretty sure that's all it is. Kind of a shame. Lots of melodies missing, Just better off using anything except for the MT32.

Post Reply