Nightly builds cannot start on Debian/sid

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
User avatar
WindlePoons
Posts: 83
Joined: Wed Jan 28, 2009 2:06 pm
Contact:

Nightly builds cannot start on Debian/sid

Post by WindlePoons » Mon Apr 22, 2019 7:06 pm

I can't starting and testing ScummVM builds from Buildbot site (latest development/stable build, Debian 64bit)

Code: Select all

./scummvm: error while loading shared libraries: libSDL2_net-2.0.so.0: cannot open shared object file: No such file or directory
(fix when install ibsdl2-net-2.0-0 from Debian/sid)

Code: Select all

./scummvm: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
(fix when install libpng12-0 from Debian/jessie) Why do the nightly builds use old libpng12 and not current libpng16?

Code: Select all

./scummvm: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by ./scummvm)
(only development builds; can't fix) Ticket #10610

Code: Select all

dpkg -l | grep libcurl
ii  libcurl3-gnutls:amd64      7.64.0-2        amd64     easy-to-use client-side URL transfer library (GnuTLS flavour)
ii  libcurl4:amd64             7.64.0-2        amd64     easy-to-use client-side URL transfer library (OpenSSL flavour)
ii  python3-pycurl             7.43.0.2-0.1    amd64     Python bindings to libcurl (Python 3)

apt-file find /usr/lib/x86_64-linux-gnu/libcurl.so.4
libcurl4: /usr/lib/x86_64-linux-gnu/libcurl.so.4
libcurl4: /usr/lib/x86_64-linux-gnu/libcurl.so.4.5.0

apt-cache show libcurl4-openssl-dev | grep Depends
Depends: libcurl4 (= 7.64.0-2)
Siduction 64bit (based on Debian/sid)

Post Reply