Gabriel Knight 1 on Linux, problem with MIDI quality

Ask for help with ScummVM problems

Moderator: ScummVM Team

Post Reply
UrbanGrill
Posts: 2
Joined: Sat Mar 09, 2019 2:16 pm

Gabriel Knight 1 on Linux, problem with MIDI quality

Post by UrbanGrill » Sat Mar 09, 2019 4:16 pm

I have installed ScummVM in Ubuntu 18.04 with sudo snap install scummvm (from https://snapcraft.io/scummvm) and I can run GK1 just fine. However, after the intro sequence when the game proper starts, it is obvious that there is something amiss with the MIDI quality.

For instance, one of the first sounds heard should be the striking of a bell four times (while the text DAY 1 is scribbled across the screen). Probably "tubular bells" or similar in MIDI. Instead, this sounds like a bass note on a synth keyboard. And so it goes on, with really bad MIDI which is quite off-putting. :cry:

I have tried to fiddle with the settings in ScummVM without any luck. I also found this post about better sound quality using a SoundFont: viewtopic.php?t=14541. Looks very promising, but I haven't yet figured out how to make it take effect. Would be grateful for any hints on how to make a workable configuration.

OS: Ubuntu 18.04.2 LTS
ScummVM: 2.1.0git-4828-g833e1d1 (Feb 28 2019)

UrbanGrill
Posts: 2
Joined: Sat Mar 09, 2019 2:16 pm

Re: Gabriel Knight 1 on Linux, problem with MIDI quality

Post by UrbanGrill » Sat Mar 09, 2019 11:46 pm

Ok, I figured it out. Under Audio, set Music Device: FluidSynth. And under MIDI, click SoundFont and specify the path to the SoundFont I downloaded earlier. Strangely enough, MIDI -> GM Device is still set to "Don't use General MIDI music". This is where I tried to set FluidSynth before. Anyway, I am happy that it works. And the SoundFont sounds great!

Post Reply